Auto-starting chromium browser

I am running Peppermint 3 on a non-PAE Dell Latitude D505 laptop.

I have received advice on previous occasions about auto-starting applications in Peppermint:
(http://linuxforums.org.uk/index.php?topic=11003.0 & http://linuxforums.org.uk/index.php?topic=11336.0)
but despite my new-found expertise have failed to get chromium to auto-start.

I performed the following actions:
cp /usr/share/applications/chromium-browser.desktop ~/.config/autostart/
Edit the file:
Removed foreign language references to shorten the file.
Removed the %U from the exec line (which was necessary for Thunderbird)
Renamed the firefox file to prevent it starting.
Saved & rebooted

But chromium does not auto-start. I tried replacing the %U but to no avail.
Any ideas? I attach the config file.

Most of that’s unnecessary for an autostart .desktop file.

Make it’s contents read just:

[Desktop Entry]
Type=Application
Name=Chromium Web Browser
Comment=Access the Internet
Exec=chromium-browser
Icon=chromium-browser
Terminal=false
Categories=Network;WebBrowser;
StartupNotify=true

That’s much shorter! But still doesn’t auto-start. :frowning:

Try moving it to /etc/xdg/autostart

sudo mv -v ~/.config/autostart/chromium-browser.desktop /etc/xdg/autostart/chromium-browser.desktop

does it autostart now (after logging off/on) ?

I had already tried that but re-tried anyway - still no joy.

Perhaps this is a clue:
typing “chromium-browser” into a terminal starts it.
does that help?

Try using the FULL path in the “Exec=” line

Exec=/usr/bin/chromium-browser

[EDIT]

Is it also listed in
menu > Preferences > Desktop Session Settings
and is it ticked ?

[EDIT 2]

does Chromium start if you click on the chromium-browser.desktop file ?

You could also try making the “Exec=” line read:-

Exec=bash -c “/usr/bin/chromium-browser”

or maybe putting in a 10 second delay by making it read:-

Exec=bash -c “sleep 10; /usr/bin/chromium-browser”

Sadly none of your suggestions did the trick.
I also sudo-copied the modified file to /usr/share/applications - after backing up the original one just in case.

Although I prefer Firefox, it is not behaving well in Peppermint (e.g. starts two instances of BBC iPlayer, which echoes really weirdly!) which is why I am trying Chromium. It’s no big deal not having it autostarting - I’m not so lazy - just a nice WIBNI.

If you should think of anything, then do post, but please don’t spend much time on it.
Cheers, Mark.

Keith

If you download the attached file then double-click it, does chromium start ?

and if you go to:-
menu > Preferences > Desktop Session Settings

is Chromium Web Browser in the list ? … and is it ticked ?

Sorry, I forgot to mention that chromium doesn’t appear in Desktop Session Settings.

…and did you attach a file?

Oops … here it is :slight_smile:

Yep; it starts OK.
When I double click on my file a message comes up: “Key file contains line ‘[Desktop Entry]’ which is not a key value pair, group or comment.”
Your file contains this line also, but Peppermint doesn’t complain about it. You clearly carry more influence than I do.

I can’t see any difference between the files except for the Exec=bash -c “sleep 10; /usr/bin/chromium-browser” that I have just added.
Are we getting closer?

delete the file in ~/.config/autostart
and replace it with mine.

now what happens if you log off/on again ?

Done, and …it works!

I guess I ought to replace the other copies in /user/share/applications and /etc/xdg ? though it’s not clear what they are for, unless to make the application appear in Desktop Session Settings, which it doesn’t.

Do you have any idea what the problem might have been, or could it be just a invisible corruption of some kind?
Anyway: many thanks as usual for sorting it out.
Cheers, Mark.

Keith

you can delete the copy of “Chromium Web Browser” (aka. chromium-browser.desktop) from the /etc/xdg/autostart directory.

But if the menu item :-
menu > Internet > Chromium Web Browser
works … leave the file in /usr/share/applications alone.

Willco. And many thanks once more.

Keith

You’re welcome :slight_smile: