Available Soon ....

Well, Ubuntu have made a big deal out of the up and coming 10.04 release … due … today (?) Indeed they have been sporting a countdown logo that you can embed in your own website so everyone knows when the next release will be available.

However, I was sort of expecting the countdown to have reached zero today … but I still see 9.x headlining the download section, and the countdown timer has turned into a message that says “Available Soon!” …

I guess their new patched X server is still doing it’s memory / sieve impression then ??

It’s up and available now, but it does seem somewhat late in the day for them to have noticed that one, and needed to patch… do you know what ‘changed’… AFAIK the X server and nVidia (proprietary) drivers are the same versions as those in 9.10, so where did this problem come from?

Also, do you know if the UNR edition has been updated?.. the screenshots on their website are still ‘brown’, but it now seems to be called UNE… [confused ::)]

Mmm, the comments I read were openGL related, nothing to do with nVidia (!) but I see update manager has now picked up on v10 … not that I’m going to be pressing the button any time soon …

The problem was nothing to do with graphics, they had a bug in grub that sometimes erased other OS’s on upgrade, so they had to respin all the isos, and get them out to the mirrors. Normally not left that late…

Mmm, I can see how that could cause a problem … :slight_smile:

Ok, so I thought I’d have to give v10 a try on something, so I decided to upgrade my Laptop.

I now have an Ex-Laptop.

So, BEWARE, Lucid Linx (Ubuntu 10.04) can render your machine unusable !!!

Once I find out what screwed up I’ll post an update … post-mortem underway …

Well whatdayaknow, they’ve been f****g around with the X server. Just for kickoff they’ve removed the “-probeonly” option, just to help with debugging. Oh, yes, and ctrl-alt-f1 and ctrl-alt-del. So X -config works, and generated a new config file … however when you try to use this, it locks up the machine.


Looking for fixes …

Ok, so here’s the fix, apparently it’s an issue for people with Intel Graphics chipsets … i.e. a LOT of notebook users. They apparently knew about this, but went ahead with the launch anyway … speechless.

If this is a clean install, wipe the installation and re-install using version 9.x.

For a failed upgrade …

When the machine comes up, press ESC to enter the boot menu
Select ‘recovery mode’ and press return
Enter the root password to log in
vi /etc/modprobe.d/i915.conf
Enter one line;
blacklist i915
:wq to save
depmod -a
update-initramfs -u
vi /etc/X11/xorg.conf
Find the line that begins with “Driver” and make it say “Driver vesa
shutdown -r now

Let the machine boot up and hopefully this will work for you. Essentially the Intel graphics driver just doesn’t seem to work so this procedure should force the graphics sub-system to use the built-in non-vendor specific graphics driver instead of the buggy Intel version.

Note; this should give you a working machine, but graphics will be quite slow and things like Compiz (special effects) won’t be working.