back light keyboard problem [Solved}

Hello
i know this is a silly question, but i’m very new to linux and this place is great.
my backlight keyboard dosn’t turn off automatically,like my screen, i can just turn it on and off manually by function key… how can i fix that
thanks

like my screen

What exactly do you mean by this (what/when is blanking the screen) …

when you put the PC into suspend/hibernate ?

when the power manager kicks in and blanks the screen ?

when the screensaver kicks in and blanks the screen ?

etc ?

Hello
Sorry for my bad English.
i mean after some time the screen brightness be less until it go off, but the keyboard light still on all the time, until i turned it off manually.in Windows the keyboard turned off automatically…

Which Linux distro/version/architecture are we talking about ?

Peppermint 7

I take it you mean you’ve set the powermanager to suspend your PC, but when it enters supsend the keyboard stays light ?

Have you tried setting the powermanager to hibernate instead of suspend ?

Hello
No, I mean the screen turned off after 120 sec but the keyboard is not !
the pc still works

Yeah but WHAT is turning the screen off after 120 seconds ?

Peppermint 7 is not set to screen blank out of the box, so you must have set this behaviour somewhere ?

what’s the output from:

xset -q

Keyboard Control:
auto repeat: on key click percent: 0 LED mask: 00000000
XKB indicators:
00: Caps Lock: off 01: Num Lock: off 02: Scroll Lock: off
03: Compose: off 04: Kana: off 05: Sleep: off
06: Suspend: off 07: Mute: off 08: Misc: off
09: Mail: off 10: Charging: off 11: Shift Lock: off
12: Group 2: off 13: Mouse Keys: off
auto repeat delay: 500 repeat rate: 33
auto repeating keys: 00ffffffdffffbbf
fadfffefffedffff
9fffffffffffffff
fff7ffffffffffff
bell percent: 50 bell pitch: 400 bell duration: 100
Pointer Control:
acceleration: 20/10 threshold: 10
Screen Saver:
prefer blanking: yes allow exposures: yes
timeout: 600 cycle: 0
Colors:
default colormap: 0x22 BlackPixel: 0x0 WhitePixel: 0xffffff
Font Path:
/usr/share/fonts/X11/misc,built-ins
DPMS (Energy Star):
Standby: 300 Suspend: 0 Off: 600
DPMS is Enabled
Monitor is On

You currently appear to have the power manager set to put the system to “sleep” after 5 minutes (300 seconds), and to power off after 10 minutes.

I’m betting you have “Sleep” mode set to “Suspend” in the xfce4-power-manager ?

Do you have the option to change the system sleep mode to “Hibernate” instead ?

I just have Suspend, Hibernate operation not permitted

Okay, we can enable hibernate, but first we need to test it works.

Open an application such as your web browser … leave it open and also open a terminal (Ctrl+Alt+T) … in the terminal run:

sudo pm-hibernate

did your system appear to shut down ? … but when you restart it the web browser and terminal are still open.

If so, we can move on to enabling hibernation.

its ok after hibernate just the web page is halted, not responding

is it wireless that’s disabled after a hibernate, or just the web browser … eg. does restarting the browser make it work again ?

hibernate again, then when you awake the PC run:

ping -c 5 google.com

and post the output

just the web page that left before hibernate, the rest web page is ok

If you want to enable hibernation, open a terminal and run

sudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

make it read:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate;org.freedesktop.login1.handle-hibernate-key;org.freedesktop.login1;org.freedesktop.login1.hibernate-multiple-sessions;org.freedesktop.login1.hibernate-ignore-inhibit
ResultActive=yes

SAVE the file and exit gedit.

REBOOT

You should now be able to choose “Hibernate” as well as “Suspend” as the system sleep mode in the power-manager