Bash script caused system program problem [solved]

Evening all,

I tried my first script a few days ago.

#! /bin/sh
sudo /usr/bin/gpodder start

Needless to say it doesn’t work properly. It gives a list of errors, but it does open gpodder.

#! /bin/sh
sudo /usr/bin/gpodder stop

also gives a list of errors, but fails to close gpodder.

The trouble is, every time I boot up I now get a popup telling me “System program problem detected”. It doesn’t include a description of the problem.
The system seems to be working ok though.

Any ideas on how to proceed please - with the system problem, that is. I’m not expecting tuition on writing scripts. I’ll read up on that later…

Hi Mike.

Please post the entire output that you received on startup - including a last prompt line if that appears.
Is there a particular reason that you want to start it via the command line rather than via the menu? I find that starting applications from the terminal often lists a few errors although the application works fine.


Thanks Keith,

I’ll do that later today. Need to go to bed now.

On startup it’s just a dialog box. Not the terminal.

And the reason for the script is that I’d like to call it from a cron job so that I don’t forget to run gpodder and miss episodes.

Hi Mike.

Not sure which dialogue box you refer to, but in the meantime I have a couple of suggestions:

  1. Instead of running a cron job you could add gpodder to the startup applications - unless you want it to start at particular times/days.
  2. At a terminal, one shouldn’t need super-user authority to start gpodder. Here’s my output:
    [i]keith@T500:~$ gpodder
    1585296242.411845 [gpodder.sync] WARNING: Could not find gpod
    1585296242.412341 [gpodder.sync] WARNING: Could not find eyed3.mp3

Note that this ties up the terminal to the application, but it gpodder works well.

As well as posting the terminal output from my previous post, would you also post the output from

inxi -Fx

Thanks Keith,

Not sure what you mean by the terminal output from your previous post. The terminal isn’t open. I just boot the computer and get a dialogue box which says “System program problem detected”.

The reason I thought a cron job was the answer is that I want gpodder to run, allow episodes to download, then close, without my having to remember to do it manually. So, maybe at 10pm every day, when I’m bound to be online. I suppose I could just add it to the startup applications and close it manually, but that doesn’t seem as neat a solution.

mike@xubuntu:~$ inxi -Fx
System: Host: xubuntu Kernel: 4.15.0-76-generic x86_64 bits: 64 gcc: 7.4.0
Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Ubuntu 18.04.4 LTS
Machine: Device: desktop System: . product: . serial: N/A
Mobo: Abit model: IP35 PRO(P35+ICH9R) v: 1.0 serial: N/A
BIOS: Phoenix v: 6.00 PG date: 02/19/2008
CPU: Dual core Intel Core2 Duo E8200 (-MCP-)
arch: Penryn rev.6 cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 10688
clock speeds: max: 2672 MHz 1: 2004 MHz 2: 2004 MHz
Graphics: Card: Advanced Micro Devices [AMD/ATI] Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM]
bus-ID: 01:00.0
Display Server: x11 (X.Org 1.19.6 )
drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
Resolution: [email protected]
OpenGL: renderer: AMD CAICOS (DRM 2.50.0 / 4.15.0-76-generic, LLVM 9.0.0)
version: 3.3 Mesa 19.2.8 Direct Render: Yes
Audio: Card-1 Advanced Micro Devices [AMD/ATI] Caicos HDMI Audio [Radeon HD 6450 / 7450/8450/8490 OEM / R5 230/235/235X OEM]
driver: snd_hda_intel bus-ID: 01:00.1
Card-2 Intel 82801I (ICH9 Family) HD Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-3 Ensoniq 5880B / Creative Labs CT5880
driver: snd_ens1371 port: bf00 bus-ID: 04:04.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-76-generic
Network: Card-1: Realtek RTL-8110SC/8169SC Gigabit Ethernet
driver: r8169 v: 2.3LK-NAPI port: ba00 bus-ID: 04:00.0
IF: enp4s0 state: up speed: 100 Mbps duplex: full
mac: 00:50:8d:be:be:f3
Card-2: Realtek RTL-8110SC/8169SC Gigabit Ethernet
driver: r8169 v: 2.3LK-NAPI port: bc00 bus-ID: 04:01.0
IF: enp4s1 state: down mac: 00:50:8d:be:be:f4
Drives: HDD Total Size: 120.0GB (88.4% used)
ID-1: /dev/sda model: GIGABYTE_GP size: 120.0GB
Partition: ID-1: / size: 109G used: 98G (95%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 1.02GB used: 0.00GB (0%)
fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 55.0C mobo: N/A gpu: 49.5
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 173 Uptime: 4:24 Memory: 1445.6/3943.7MB
Init: systemd runlevel: 5 Gcc sys: 7.4.0
Client: Shell (bash 4.4.201) inxi: 2.3.56

Hi Mike.

It was your initial post about scripting that led me believe you were using the terminal/script to start gpodder - my error.
The two problems you report: start-up error message and script not starting gpodder properly may well be related.

A couple of questions:
Did you install gpodder from via the built-in “Software” application of XUbuntu, download it from the web, or use the terminal command line and install it yourself?
Does the start-up message have a “Details” button? (that might help diagnosis)
Did the start-up error message only begin after you installed gpodder?

The simplest initial test might be to simply:

  1. If you have a cron job script, remove the cron job and delete the script.
  2. uninstall gpodder and see if the start-up message still appears each time you reboot.
  3. Re-install gpodder (preferably via your System-Settings/Software) and test it by clicking on the entry in the applications menu.

Let us know how you get on and then we can start from scratch.

Hello Keith,

Sorry, I think I’m confusing things.

I haven’t created a cron job yet. I have been using the terminal to try out the scripts, with the results I’ve described above.

From memory, I installed gpodder via the built-in “Software” application in xubuntu.

The start-up error message only began after I started experimenting with scripts - before that gpodder was working fine (and still is - it’s just that xubuntu keeps complaing about the system program problem on startup).

And no, the start-up message doesn’t have a “Details” button. I’m convinced the two problems are related. Too much of a coincidence otherwise.

Try starting gpodder from a terminal with just:

gpodder &

without the “start” that you have used. It ought to work OK (does for me).
Let me know the outcome.


Yes, it works. But like the version with the ‘start’ it also gives a list of errors, all relating to the first podcast in the list.

Actually I’m more concerned about the “system program problem” than I am about getting the script to work…


Keith, I’ve deleted the two scripts and rebooted. No error message now!

I didn’t realise that the mere existence of scripts would be a problem unless a) I ran them manually or b) they were called by a cron job.

Obviously I need to do some reading. Thanks for your help. I’m going to mark this solved now.


Have you tried uninstalling gpodder as per post #5?

No, but please see my edit to my last post.

Thanks again Keith.

Well that’s promising. Good luck with your scripting!


Just had a thought that might help.

If your system was objecting to your script at start-up then you may well have placed the script in amongst system files, where it ought not to be.
If this is the case, I recommend creating a sub-directory in your home directory and adding that sub-directory to your PATH variable. This is all very easy, so let me know when you are ready to have another go.