Black screen after installing Ubuntu

Hi, I installed Ubuntu, restated my pc then selected Ubuntu, I get the loading screen come up but then the screen goes black and nothing happens. What am I doing wrong, I am a noobie and do not remember any MD5SUM option. Please help

Try this…

Turn on your PC, immediately hit and hold the “Shift” key … you should be presented with the GRUB menu.

At the GRUB menu hit the “e” key to edit.

Find the line that ends with:-

quiet splash –

and change it to end with:-

quiet splash nomodeset

then hit Ctrl+X to continue booting.

Did the PC boot ?

Be aware this will not survive a reboot (this is for a single boot only) … but if it works, we can either make it permanent or fix the issue some other way.

Hi Mark, holding the shift key did nothing, so i selected recovery mode and got into the grub. There was no ‘quiet splash’ listed there it just said ‘no modeset’ so i hit Ctrl + x and ubuntu has now loaded up. So thanks very much mark I am so relieved to have ubuntu working and would not have been able to do it without your guidance.

Thanks again, Tray.

You’ve lost me my mate, I’m not 100% sure what you just did … have you checked if it survives a reboot ? or do you have to do whatever you’re doing each time you boot ?

Hi Mark, no, it does not survive a reboot the screen just goes black again. Do you think the ubuntu live disc image was from an untrustworthy source? Or do i need to somehow run an MD5SUM to make it boot up at the OS choosing screen?

No it’s likely a graphics driver issue…

Have you been into “Additional Drivers” (in the menu) and checked if any graphics drivers are being offered to you ?

I have not been offered any graphics drivers or updates in windows, I am just getting used to win 8.1 from 7. In 8.1 I don’t know where to look for or update drivers. If I can go back into ubuntu where would I look to update graphics drivers? Oh wait a min… if ubuntu is loading up could it still be a driver issue that is stopping ubuntu from booting when i choose it in the OS menu screen?

Been back into ubuntu, checked software and updates there but no new graphics drivers. It did say in one tab that this device is using unsupported drivers that developers cannot use. Then there is the option saying do dot use. If I click on ‘Do not use’ will ubuntu start up at the OS menu screen when I choose it? I do not want to make any changes without advice in case I mess things up. Thanks.

Have you set up wireless in Ubuntu yet ? … I mean does it have an active internet connection ?

If so, please open a terminal and enter:

sudo ubuntu-drivers list

and hit enter.

You will be prompted for your password … enter it, and hit enter again (be aware it will not reflect even **** when you enter your password, but it IS going in).

Wait for the command to finish and leave you back at an $ prompt

Now copy what was returned in the terminal and post it back here.

Hi, I clicked Ctrl shift + c but it will not paste to this window. But when I ran the command and waited all it came up with was ‘Intel microcode’. I looked in the boot menu and it said NTFS is unstable. When loading the live DVD I tried ubuntu first then from there I set a clean install after I had removed the ubuntu partition using easyBCD. This new install I never encrypted my drive in case that was a problem. Do you think if I remove the ubuntu partition I would have more luck installing Mint Cinnamom? Thanks.

Here’s a hint when copy pasting … keyboard shortcuts are different in the terminal than pretty much anywhere else

In the forum (and pretty much anywhere else);-
Copy = Ctrl+C
Verbatim Insert aka. Paste = Ctrl+V

In the terminal
Copy = Ctrl+Shift+C
Verbatim Insert aka. Paste = Ctrl+Shift+V

The reason is that in a terminal Ctrl+C is mapped to sending the interrupt signal (SIGINT) to the current foreground process.

If you want to see what Ctrl+C does in a terminal, run:

top

which will show which processes are currently using the CPU the most as an ongoing readout … to exit the ongoing readout, hit Ctrl+C


Anyway, if you want to make “nomodeset” permanent, so you don’t have to enter it each bootup … open a terminal and run:

sudo gedit /etc/default/grub

find the line that reads:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change it to:-

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

SAVE the file, and exit gedit

Back in the terminal run:

sudo update-grub

Now reboot to test.

Hi Mark,
I tried mint but am going to delete it as I did not get the OS choice menu like I did with ubuntu. I am thinking of installing ubuntu again and give it another try. In the burning or loading process of ubuntu do you have to click on ‘Mount’ before going any further? Also, my PC uses the EUFI boot process, I am thinking that one of these two things could be causing my problems. Will post back here later on and let you know how it went. Thanks.

In the burning or loading process of ubuntu do you have to click on 'Mount' before going any further?

Not quite sure what you mean ?

UEFI shouldn’t give you any problems, but it might be a good idea to disable “SecureBoot” in the UEFI BIOS before installing.

I still cannot get used to copy + paste I tried with your instructions but they won’t work. Any way when I tried to update my drivers with the said command it just came back with ‘Intel microcode’. Then when I entered nomodeset it came back saying that it was not executed. The only way for me to get into ubuntu is by changing my boot order to ‘ubuntu’ then when it boots the OS choice screen by selecting advanced options for ubuntu then going to bottom of list and selecting ubuntu rescue mode, then into the grub and going from there by pressing enter where I get a black screen with white writing which scrolls up then I get the ubuntu log in screen. Is all this unusual? Do you think I should delete ubuntu then go into the bios and disabling ‘secure boot mode’. then reinstall from the start.

Hi, I have just read a post by mikep ‘installing ubuntu again’. It mentions in there you can’t have more than four partitions. In my windows I have C: then a recovery drive D:, then removable disc E: then my DVD drive. But in easyBCD there are five partitions, could this be causing problems?

Possibly, but I doubt it … you can only have four PRIMARY partition, but if one is an extended partition you can have any number of logical partitions.

Linux would likely have created an extended partition containing logical partitions, so you may have 5 partitions but only 4 of them are PRIMARY.

The 4 partition limit doesn’t even exist on a hard drive with a GPT partition table which most have now by default.

If you want to check, boot to the LiveCD/LiveUSB and post the output from:

sudo fdisk -l

In easyBCD help I found some useful info, I have to enable ‘Legacy’ Mode by enabling the CSM. but in the Bios UEFI setting It only lists four possible boot options. On looking in security I can see in the right hand pane it says ‘CSM Disabled’. With no way to move over to it to enable it. So I need to somehow enable the CSM which allows 3rd party OS installations. It seems microsoft have disabled the CSM in win 8 onwards from installing 3rd party OS’. If this can be solved I am sure that ubuntu (with grub2) could be installed as a dual boot. Any way around this? Thanks.

Microsoft haven’t disabled CSM, it’s a UEFI BIOS setting…

You need to enter your UEFI BIOS and disable “Secure Boot” … it may then allow you to change the CSM setting.

Be aware - this should be done from within the UEFI BIOS settings … NOT from within Windows.