Bluetooth problems with Netbook and Andriod mobile.

I cannot connect mt new Andriod mobile to my Samsung NC10 netbook, the message I am getting from my netbook is " cannot connect as all packages are not installed".

Any pointers to the correct packages would be welcome. :slight_smile:

Ubuntu 10.04 but may have the same problem on my Laptop with 10.10 as well when I get back from My Hol’s.


How are you trying to set it up ?

Have you tried installing the blueman package

sudo apt-get install blueman

Then either look for the Bluetooth Manager in the menus, or start it with:


Hi Mark.

Installed that, but still the same problem. It can see it but cannot connect to it. The phone can see my laptop, it pairs with it but says “Paired but not connected”.

I’ll see what I can find after my (late) dinner :slight_smile:

Thanks Mark…Bon Appetite!

OK, what exactly are you trying to do ?

From what I gather (could be wrong) “paired but not connected” is normal until you use an application to “do” something such as transfer a file.

I am trying to transfer some photos from my mobile to the netbook.

is there anything on the phone like “make visible” ?

No, only make discoverable, which only lasts for 30 seconds. BTW I have sent files to another phone via bluetooth with no problems.

What application on the Android phone are you using to send the files ?

Can you go through what you are doing step by step, with any messages that you recieve.

I’m using Astro File manager with Bluetooth add on.

Using the Bluetooth program you recommended it shows my phone but only shows the ‘Send file’ icon high lighted along with ‘Send file’. When I click on the ‘send file’ file Icon it starts and then comes up with ‘error’, it does not give an option as to where to send the file.

I’m scabbling in the dark a bit here as I have no Android device or PC with bluetooth available, but on the Phone’s bluetooth options screen (where it says “paired but not connected”) what happens if you tap where it says “Paired but not connected” … may need tap and hold.

Actually Mark, I have just tried that tried and tested formula made famous by ‘the I T Crowd’…I turned them both off and back on again. :wink: Now I can send a file to the phone but not the other way. I will tinker with it over the weekend (still on holiday in London and Wife getting angry with my tinkering). I will try your last suggestion of holding etc.

Thanks for your efforts, I will let you know how I get on by Monday.

Thanks Again. :slight_smile:

Heh, Off and On again … works wonders :slight_smile: … yeh, I’d be interested to know how you get on.

Maybe a radical option, but you could try plugging your USB cable from your phone into your laptop … ;D

To install the packages;

sudo apt-get install libmtp mtptools mtpfs


mkdir /media/android
chmod 775 /media/android

And add the following lines to /etc/fstab;

/usr/bin/mtpfs	/media/android	fuse	rw	0	0

edit /etc/udev/rules.d/51-android.rules and make it look like this;

SUBSYSTEM=="usb", SYSFS{idVendor}=="22b8", MODE="0666"

It should auto-mount as soon as you plug the cable in, or alternatively you can mount it by hand with “mount /media/android” …
Works for me … :slight_smile:

Cheers for that Mad Penguin.

I have managed to get it working by using another Bluetooth program (Andriod). I installed a free program by Medieval software from Andriod market and it works very well with the program that Mark suggested I install to my Ubuntu 10.04 netbook. Scouring around various Andriod forums it would appear that some Bluetooth programs work better with some Andriod phone manufacturers than others. The suggestion that it could be the ‘Front end’ that Various manufacturers are putting on the basic Google Andriod (Linux)Build. For me now, this Bluetooth File Transer software from Medieval works with Blueman Device manager 1.21 on My Samsung NC10 (Ubuntu 10.04) and Sony Experia Arc S Andriod (Gingerbread) phone.

Thanks for the help


Thanks for the update, and I’m glad to hear you sorted it :slight_smile: