Boot-Up Failure

Hi All - I seem to have goosed my system! :o

Running Mint 13KDE with Zorin on slave HDD.

I found another (very old) HDD while having a clear-out and thought I’d check it out before discarding it. I disconnected my slave HDD and connected up the old one but Mint didn’t see it. I tried swapping it with my main HDD but the system wouldn’t boot - no surprises there. I swapped it with my DVD but again the system wouldn’t boot. Btw, the old HDD had no jumper for Main/Slave etc.

Removing the old HDD and returning all connections to their previous state, the system still won’t boot and gives the error -

DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER

I’ve treble-checked the connections and made sure (as far as possible) that everything else is as it should be in the case. Do you think Grub has possibly been corrupted? And if so, can I repair it using the installation disk? The PC does boot to a live session from the DVD.

Thanks in advance

Rich

Sounds like it’s trying to boot from the wrong disc, have you checked the boot order in your BIOS or open the Boot Menu at startup and see what drive it’s trying to boot from ?

Good luck

Graeme

I agree, it’s quite possible that the BIOS had re-ordered things when it detected different devices on boot, and hasn’t re-ordered it back correctly.

If it’s all good in there, then post back, as it’s no biggie to re-install GRUB from a live CD

Well spotted, Graeme! That’s another pint I owe you! :wink: Main pc back up and running!

My pc’s BIOS is listed over several pages and the available disks are not seen on the boot order page, if you get my drift? I have to click on the HDD entry to see the disk order, as it were.

Now, why would the disk order be changed just by me removing/replacing the cables? I did nothing more than that - no altering of the BIOS at all… It had the slave HDD listed first - strange ???

With the old HDD, is there a way I can connect it as a slave and get Mint (or Zorin) to read it despite there being no ‘slave’ jumper on it?

Thanks again - phew!

Rich

is the old drive SATA or IDE ?

if IDE … what’s the make/model ?

Must be IDE, as SATA doesn’t have master/slave.

What is the other drive on the cable set to? If it’s set to cable select, you can have problems if they both aren’t set the same

Why “must” it be ?

You MAY be right, but so far he only said there was no jumper for setting master/slave … which MAY suggest it’s SATA … and kinda why I posted the question.

Have you ever seen an IDE drive with no way to set master/slave/cs ?

Have you ever seen an IDE drive with no way to set master/slave/cs ?
Yup, where the jumper was missing (but the series of pins where there). ;) Some are set to master when no jumper is bridging the pins.

Ok - I’ll try to answer everyone in one go!

@ chemicalfan - I think you are correct. The BIOS has re-ordered the boot order itself - I can’t think of another explanation…
The other drive (2nd HDD with Zorin on it) is set to Slave. Master HDD has Mint installed.

@ Mark - this HDD is very old. It’s IDE, Hewlett Packard Quantum ProDrive LPS.
There’s no capacity listed that I can find, the part number is - HP P/N:D2387-60023.
(there are some other numbers which I can give if required but they are just barcodes)

@ SeZo - The connections at the rear are IDE, power and a small 3-pin (audio perhaps?) but no Master/Slave etc.

Thanks for the help guys!

Rich

@ SeZo - The connections at the rear are IDE, power and a small 3-pin (audio perhaps?) but no Master/Slave etc.

Just dug out an old Maxtor IDE hdd (from 1995) which has the Master/Slave jumpers on the circuit board itself, not on the end as expected.
Though there is a note on the label as Jumper [J20] Master/Single On and Slave Off.
It might be worth to look if it is similar on yours.

See here for the jumper settings:

as SeZo suggests, they’re on the circuit board underneath

LPS model drives are at the end of that PDF

Heh … It’s been some years since I saw a drive with the jumper block underneath :o

Heh .. It's been some years since I saw a drive with the jumper block underneath :o

I kept this one (for reference only) as it was from my first computer… :slight_smile:

Well I never! There they are, underneath!

@ SeZo Thanks for the heads-up and yes, I think this one must be from my first comp too! It’s probably got Win 3.1 on it… ;D

@ Mark Thanks for the pointer. Mine looks like the diagram for the 120/140. Just to clarify - to set it as Slave, I should just remove the jumper?

Rich

Just to clarify - to set it as Slave, I should just remove the jumper?

Yup, I would agree with that. :slight_smile:

Yup … if there’s a jumper across the centre 2 pins (DS) remove it and the drive should be detected as a slave.

If it’s an abnormally small jumper, probably best to tape it to the top of the drive for safe keeping … they’ll be hard to find these days :wink:

Hmmm… The drive isn’t seen no matter how I configure it.

The pc will boot/not boot depending on which pins the jumper’s across (or removed entirely) and checking in BIOS firstly there is no entry for the HDD anywhere. Allowing the pc to boot, the HDD doesn’t appear in partition editor either. Returning the pc to its original config puts everything back the way it was so the cabling etc must be ok.

One final thought…would the small (3rd) connector need to be cabled up? It’s a 3 pin shaped like an inverted ‘tee’ which I took to be for audio?

It’s no biggie - after all, this drive has been gathering dust for years! It’s just my reluctance to ditch anything that might be usable or perhaps contain sensitive material… ::slight_smile:

My o/h says it’s ‘anal retention’! I prefer to call it ‘prudence’… ;D

Hi Rich

This is really a long shot but If I remember correctly some of these really old drives wouldn’t auto detect and had to be installed in the bios by manually entering the drive parameters (cylinders, sectors & head values) which can usually be got off the drive itself

I know what you’re going through I wont throw anything out either and I’ve battled for hours trying to get old drives to work just to find out if there’s anything on them, I would connect it up to it’s own channel so ie if your boot drive is on IDE 0 then connect it to IDE 1 on it’s own with no other drives connected alongside it

.would the small (3rd) connector need to be cabled up? It's a 3 pin shaped like an inverted 'tee' which I took to be for audio?

I would say no I’ve never known that to need connecting

Good luck

Graeme

Does the drive actually spin up when you power the computer on? It might be dead completely :frowning:

@ Graeme

I managed to figure out how to manually input the numbers but the CMOS settings won’t stick - even though I’ve saved/exited. When the numbers are manually inputted, the capacity shows as 211MB, which is correct according to the HDD’s label, so there is something being ‘seen’… ::slight_smile: Btw, only the ‘Access Mode - CHS’ allows manual input in my CMOS, if that makes a difference?

I found some info regarding jumper settings on Seagate drives as follows -

The Prodrive LPS has three drive mode jumper options; DS, SP and DM. To configure the drive as:

The MASTER of a two drive configuration or as the only drive: Jumper DS only, SP and DM open.
A SLAVE drive in a two drive configuration: Remove any jumpers across DS, SP or DM.
A MASTER drive in a two drive configuration if the SLAVE drive does not use DASP: Jumper DS and SP only.
DM not used, DO NOT install a jumper across this position. 

The SP jumper is only used when the second drive in a two drive configuration does not support DASP. DASP (Drive active / drive 1 present) is a CAM (Common Access Method) defined signal that indicates the presence of a second drive, DASP is used during power on initialization and after a reset. Prior to this definition, products were introduced which did not utilize this method to detect the presence of a second drive. The SP jumper is only used on the MASTER drive, with the DS jumper, when the second drive does not support DASP.

Can I take this to mean that the SP pins on the MASTER drive should also have the jumper on, as well as the DS pins? (Frankly, I’m a bit wary as I don’t want to b****r up my main HDD :o)

@ chemicalfan

Yes, the drive does spin up ok.

Erm… another problem has surfaced :-[

With all this swapping and changing of cables etc. I can’t now boot into Zorin on the slave HDD! The slave is seen in BIOS and grub has Zorin listed but when I select it to boot I get an error message to say
no such device:d5d73fa8-ec70-47ee-8ad0-d983dadc535b
no such partition
you need to load the kernel first

Mint loads as normal and I’ve updated grub as a precaution (and Ubuntu is listed there) but still no bootable Zorin!

I must be making a daft error here but can’t see it! Any clues please?

Rich

Edit: Just checked with partition manager and both drives are listed as usual.