Broadband speed issue

Hi All

We recently had a Virgin Media broadband outage that lasted approx 36hrs - a local issue, not at our property. That has now been fixed but I find that my internet speed is very slow, compared to that before the outage.

I’ve twice contacted Virgin 150 (20mins waiting, 10mins with operator, then had the call cut off both times before the issue was dealt with!!) I’ve gone through all their instructions ie: speedtesting, re-booting, factory re-set etc. to no avail.

My package gave me a stable 20Mbps download speed and about 2.7 upload speed and that is what I’ve had for about 2 years with no problems. After the outage, I’m getting 2.27Mbps download and 1.97 upload. Ping is @ 300 ms. This is causing major issues with system updates, especially if there are larger files involved. Before, the updates would download between 10 and 20 seconds, now it can be anything up to 20mins!

My rig has a wired ethernet connection (through D-Link homeplugs) and pinging my router returns -

richard@richard-H310M-S2V-2-0:~$ ping -c 5
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=3.83 ms
64 bytes from icmp_seq=2 ttl=64 time=3.33 ms
64 bytes from icmp_seq=3 ttl=64 time=3.39 ms
64 bytes from icmp_seq=4 ttl=64 time=3.39 ms
64 bytes from icmp_seq=5 ttl=64 time=3.35 ms

--- ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4006ms
rtt min/avg/max/mdev = 3.336/3.462/3.834/0.197 ms

which suggests the internal wiring 'tween rig and router is ok.

From the computer, to Virgin's server in Manchester returns Ping 10ms,  Download 2.89Mbps,  Upload 2.00Mbps
Yet from my smartphone, Speedtest returns (wirelessly)  Ping 24ms,  Download 21.01Mbps,  Upload 2.48mbps from the same server......!!  

I'd expect the ping to be slower as it's wireless but the other figures suggest that the internet speed is ok and the issue is with my computer.  I'm baffled, to be honest!

Any help would be good and thanks in advance.


what’s the output from


and I take it you’ve tried rebooting both the PC and router ?
(have you tried turning it off and on again ;D)

Hi Mark! Yes to both - several times! About the only thing I haven’t done that’s just occurred to me, is deleting the ethernet connection and re-setting it. Do you think that’s worth a try?

info as requested -

richard@richard-H310M-S2V-2-0:~$ ifconfig
enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast
        inet6 fe80::b62e:99ff:fe29:661  prefixlen 64  scopeid 0x20<link>
        ether b4:2e:99:29:06:61  txqueuelen 1000  (Ethernet)
        RX packets 1189  bytes 1203436 (1.2 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 1127  bytes 158661 (158.6 KB)
        TX errors 4  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet  netmask
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 247  bytes 22499 (22.4 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 247  bytes 22499 (22.4 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Basically, I’m trying to find out where the fault (if any) lies, before I set off on a rant at Virgin! I must say I’m becoming a bit disappointed with VM, from having years of near flawless service there seems to be a different culture at work. Probably cost-cutting like many other companies, but that’s a different issue… Sign of the times ::slight_smile:

I left things to settle over the weekend and have just checked my stats on both computer (wired) and Smartphone (wireless) to the same server.

Computer - Ping: 9ms, Down: 3.00Mbps, Up: 2.00Mbps

Phone - Ping: 24ms, Down: 19.19Mbps, Up: 2.39Mbps

Which does suggest there’s an issue at my end?

Either with the Homeplugs connectivity (quite possible, but the ping figure is a puzzle) or my network settings/driver are wrong or have become skewed in some way, maybe through a recent update?

How do I test please, if the network set up is working properly and that I do have the correct driver?



Update: I’ve taken the Homeplugs out of the equation by moving the router back to the office and wired directly to the computer. Test is as follows -

Ping: 8ms, Download: 4.06Mbps, Upload: 1.99Mbps

So no improvement, which rules out the Homeplugs as the problem. So, it’s either my config and/or network driver that’s at fault, the hub itself is playing up, or Virgin have me ‘throttled’ for some reason. I’ve messaged Virgin Technical to get them to look into the hub but would still like to check my set-up, if poss, in the meantime.

Whats the output from:

lspci -vnn | grep -i net




inxi -Fz


iwlist scan

As requested -

lspci -vnn | grep -i net
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 16)
	Subsystem: Gigabyte Technology Co., Ltd Onboard Ethernet [1458:e000]

lo        no wireless extensions.

enp4s0    no wireless extensions.

inxi -Fz
  Host: richard-H310M-S2V-2-0 Kernel: 4.15.0-70-generic x86_64 bits: 64 
  Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa 
  Type: Desktop Mobo: Gigabyte model: H310M S2V 2.0 v: x.x serial: <filter> 
  UEFI [Legacy]: American Megatrends v: F10 date: 09/20/2018 
  Topology: Quad Core model: Intel Core i3-8100 bits: 64 type: MCP L2 cache: 6144 KiB 
  Speed: 800 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 
  Device-1: Intel 8th Gen Core Processor Gaussian Mixture Model driver: i915 v: kernel 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1440x900~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) 
  v: 4.5 Mesa 19.0.8 
  Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel 
  Device-2: Trust Widescreen 3MP Webcam type: USB driver: snd-usb-audio,uvcvideo 
  Sound Server: ALSA v: k4.15.0-70-generic 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 465.76 GiB used: 42.37 GiB (9.1%) 
  ID-1: /dev/sda vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
  ID-1: / size: 72.83 GiB used: 11.51 GiB (15.8%) fs: ext4 dev: /dev/sda1 
  ID-2: /home size: 374.95 GiB used: 30.86 GiB (8.2%) fs: ext4 dev: /dev/sda5 
  System Temperatures: cpu: 27.8 C mobo: 6.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 168 Uptime: 43m Memory: 7.67 GiB used: 813.6 MiB (10.4%) Shell: bash 
  inxi: 3.0.27 

iwlist scan
lo        Interface doesn't support scanning.

enp4s0    Interface doesn't support scanning.

I discovered that Network Manager was at fault by not handling the signal correctly, possibly as a result of the outage. To test that, I’ve swapped it out for WICD (enp4s0 in the list) and speeds now seem to be correct. I am monitoring at present and have a ticket with Virgin to test again from their end, just to be sure. It does look as though the driver is ok after all but I’d still like to check it and ensure it’s configured correctly also.

And there is no WiFi on this rig - not needed.

Thanks, Rich

IIRC, WiCD doesn’t support IPv6 … so maybe all you needed to do was set IPv4 to “Ignored” in network manager (and maybe set a static IP).

That said, if WiCD is doing the job, may as well stick with it :wink:

*According to a 'net search, neither does Virgin, sadly! ::slight_smile: I’ll keep things as they are for now as I’m still waiting for Virgin’s feedback. :wink:

Thanks again