Brother Printer problem (SOLVED)

Hi All, I am in need of help (again).
I have a Brother MFC-J6930DW A3 Wireless Scanner/Copier/Printer that seems to have fallen out with my Linux computer running Peppermint 8 (I think, can’t really remember).
I was printing today using my WIN10 computer but when I went to this Linux machine later to print it wouldn’t print.
The error message was ‘Could not start printer’
‘Please check your printer configuration’

I am at a loss and don’t want to start fiddling with buttons etc. Is there anyone who could guide me as to how to get my set up working again or will I need to transfer files from my Linux machine to the Win 10 machine to get them printed ??
Hope someone can help.
Don W

Hi Don

My Brother HL-1112 printer also stopped working recently when I upgraded to Devuan Chimaera. When I looked at the print settings found that the Enabled box was no longer checked.

Unlikely you have the same error as you have not just upgraded Peppermint but probably worth checking anyway.

Thanks for that but I can’t see an ‘Enabled’ box anywhere.
EDIT Maybe I should just try a re-install of CUPS. I also found the ‘Enable’ box and it was still ticked. I think maybe a reinstall may be the way to go. ??

Hi Don

Yes probably worth trying a re-install it won’t do any harm.
The other problem I have had with Brother printers is that there linux drivers are 32bit so I have had to install the package “lib32z1” to enable them to work on a 64bit system. But as it sound like your printer has worked in the past this must must already have been done.

So many problems with printers over the years you can grow to hate CUPS!

Thanks Gaz511, I have been to Brother but can only find Win or Mac drivers.
I can print no problem from my Win 10 machine so I may just use that but I know myself that I will start to fiddle with this Linux machine and probably upset something along the way.
EDIT I have found the linux packages needed to connect my linux machine wirelessly to my Brother printer and I have given up. I will just use the Win 10 computer for my printing needs as it is a simple plug and play. Maybe 20 years ago I would try and link the two but at my age I need specific instructions and these linux packages are too difficult for me.
Thanks for the help.
Don W
PS I enjoyed the forum when Mark was here as I knew he would iron out any boobs I made but sadly he is very much missed.

Hi All,
I am back again with this problem and need help. I have tried to install the drivers/packages from the Brother website but I have made a right muck up and got totally lost.
Can anyone help with what I need to do to get me printing again with this wireless printer. The last printer was ok as it was wireless/usb and if it stopped talking to the printer I just plugged the usb in and got a connection. This printer is only wireless and although it works in Windoze I prefer it to work in Linux Peppermint 9
Thanks for looking.
Don W

Hi Don.

You’ve probably done this, but I show it for other users in the same boat…

  1. Go to Downloads | MFC-J6930DW | United Kingdom | Brother
  2. In "Step 1 click on Linux. In “Step 2” click on “Linux (Deb)”. Click on “OK”
    This will get you to Downloads | MFC-J6930DW | United Kingdom | Brother
  3. Under “Utilities” click on “Driver Install Tool”
    This will get you to Utilities | Downloads | MFC-J6930DW | United Kingdom | Brother
  4. {Clicking on “Compatible Model” shows that your printer is indeed supported.}
  5. Scroll down to the bottom then
  6. While holding down the Shift key, click on the blue “Agree to the EULA and Download” key to download the drivers.
    This will get you to Utilities | Downloads | MFC-J6930DW | United Kingdom | Brother and also open a download dialogue box.
  7. Select “Save” and “OK”. This will save the compacted file that looks looks like “linux-brprinter-installer-2.2.3-1” to your usual download directory (usually “Downloads”) - make a note of the file name.
  8. The dialogue box will disappear to show the instructions which you should follow. Replace the "*"s with the numbers in your file name. If the command fails then prepend “sudo” to your commands. (More detailed instructions are also here:
  9. You will be asked for your printer’s URI. This is your network’s address of your printer. You can get this from your printer’s menu system or from a terminal command sudo lpinfo -v" where you look for something like network socket:// Ignore “network” and copy the rest.

I don’t have a Brother printer so can’t guarantee the result, but let us know how you get on. By the way, to avoid confusion “lpinfo” is lower case for “LPINFO”.


Thanks for this Keith. I hate the thought of losing a printer on Linux as this is my main machine. I will try out this explanation of what to do after I have been to the doc’s.
I will gather the stuff I have downloaded into a folder and will take note of the things you have mentioned to start over again.
Thanks again.
take care and stay safe.
Don W
PS I will be back

Hi Keith,
I have done quite a bit of what you advised but seem to have come unstuck at the final hurdle, When I enter sudo lpinfo -v" into the terminal it says “lpinfo: cups-deviced failed to execute.”
When I look in the printer menu under WiFi it says “IP Address” is this the number I should use ??
PS I have had a look in the Downloads directory and there are now 11 of these files about the brother printer. Looks fairly serious stuff.

The error message is not encouraging.
Please paste the whole output of the sudo lpinfo -v command.

Hi Keith ,is this what you want

don@ldwatson ~/Downloads $ sudo lpinfo -v
lpinfo: cups-deviced failed to execute.
don@ldwatson ~/Downloads $ sudo lpinfo -v"

Have you ever had this printer working on your Linux computer?


Try this:
Enter localhost:631 into the address bar of your web browser. This should bring up the CUPS page.
If it does:
Click on the Adding Printers and Classes button.
Click on Manage printers.

Let me know the result.

When I click on Adding Printers and Classes it returns “Not Found”

Go back one page, or click on the “Administration” button in the page’s menu bar, then click on “Find new printers” and report the result.

When I click on “Administration” it returns “Not Found”.
Whatever I click on it returns “Not Found”

What’s the output from

ls /usr/share/doc/cups

Is this it
don@ldwatson ~ $ ls /usr/share/doc/cups
don@ldwatson ~ $

I was clutching at straws there.

Try looking at your printer’s wireless network menu and printing out the Wireless LAN Report.
You can find the meaning of error any codes here:
This will tell you if the printer is talking to the router.