Can I boot automatically into Linux Mint instead of Windows 10?

Hi all,

I recently installed Linux Mint 17.3 alongside Windows 10 on my HP Pavilion 15 - mostly because I’m sick to death of Windows!

So far i absolutely LOVE Linux Mint - it’s clean, fast, responsive, and most importantly it works! However, despite changing the boot order in BIOS, every time I start my computer up I still have to go through the process of restarting into BIOS and then choosing to boot from Linux Mint. Sometimes this is a quick process, and sometimes Windows makes it REALLY hard by not responding :frowning:

Is there a way I can fix this, so that by default I’m booting into Linux, and selecting WIndows only if I need it?

Many thanks!

Sure there is, but we’ll first need to discover if your system uses UEFI as opposed to legacy BIOS.

Can you boot into Mint, open a terminal and post the output from running this command:

sudo efibootmgr -v

Hi again Mark!

Thanks for coming back so quickly :slight_smile: Here’s the output:

BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0001,3001,0004,2001,2002,2003
Boot0000* Notebook Hard Drive	BIOS(2,500,00)................-.X.......X.A.X.............................................A.......................
Boot0001* Windows Boot Manager	HD(2,c8800,82000,e0f1b6e0-ce66-41ab-9216-0af86e0a8dec)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}.../................
Boot0004* ubuntu	HD(2,c8800,82000,e0f1b6e0-ce66-41ab-9216-0af86e0a8dec)File(\EFI\ubuntu\shimx64.efi)
Boot0006* Internal Hard Disk or Solid State Disk	RC
Boot2001* USB Drive (UEFI)	RC
Boot2002* Internal CD/DVD ROM Drive (UEFI)	RC
Boot3001* Internal Hard Disk or Solid State Disk	RC

Open a terminal and run:

sudo efibootmgr --bootorder 0004,0001,3001,2001,2002,2003

and reboot to test :wink:

Mark - so I ran the command and at first I was told ‘2003 doesn’t exist’. So I re-typed the command, minus the 2003, and it seemed to respond.

I then rebooted and it went straight into Windows!

What does

sudo efibootmgr -v

return now ?

I ran the command again, and it showed the original:

BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0001,3001,0004,2001,2002,2003
Boot0000* Notebook Hard Drive	BIOS(2,500,00)................-.X.......X.A.X.............................................A.......................
Boot0001* Windows Boot Manager	HD(2,c8800,82000,e0f1b6e0-ce66-41ab-9216-0af86e0a8dec)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}.../................
Boot0004* ubuntu	HD(2,c8800,82000,e0f1b6e0-ce66-41ab-9216-0af86e0a8dec)File(\EFI\ubuntu\shimx64.efi)
Boot0006* Internal Hard Disk or Solid State Disk	RC
Boot2001* USB Drive (UEFI)	RC
Boot2002* Internal CD/DVD ROM Drive (UEFI)	RC
Boot3001* Internal Hard Disk or Solid State Disk	RC

So to check this, I re-ran the ‘sudo efibootmgr --bootorder 0004,0001,3001,2001,2002’ command (not including 2003, which apparently 'doesn’t exist?!), and tested immediately with ‘sudo efibootmgr -v’. The output had changed to reflect the new BootOrder:

BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0004,0001,3001,2001,2002
Boot0000* Notebook Hard Drive	BIOS(2,500,00)................-.X.......X.A.X.............................................A.......................
Boot0001* Windows Boot Manager	HD(2,c8800,82000,e0f1b6e0-ce66-41ab-9216-0af86e0a8dec)File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}.../................
Boot0004* ubuntu	HD(2,c8800,82000,e0f1b6e0-ce66-41ab-9216-0af86e0a8dec)File(\EFI\ubuntu\shimx64.efi)
Boot0006* Internal Hard Disk or Solid State Disk	RC
Boot2001* USB Drive (UEFI)	RC
Boot2002* Internal CD/DVD ROM Drive (UEFI)	RC
Boot3001* Internal Hard Disk or Solid State Disk	RC

Yet it doesn’t seem to stick - when I restart it boots straight into Windows. I come back into Linux and run the ‘sudo efibootmgr -v’ command in terminal again, and it reverts back to the original BootOrder :frowning:

Okay, something in the UEFI (BIOS) must be changing it back … I’ll see what I can find.

Thank you :wink:

Try

sudo efibootmgr -O -o 0004,0001,3001,2001,2002

the added “-O” parameter deletes the bootorder before writing it back

So before rebooting, make sure

sudo efibootmgr -v

lists a bootorder at all

If that still reverts back to defaults after a reboot, we’ll have to look into changing the boot order in the UEFI interface itself.

Unfortunately that didn’t work either… :cry:

That’s strange it works on my two HP 15’s with Peppermint 6 … I wonder if Mint changed something (though this seems more like the UEFI rewriting the boot order), I’ll see what I can find.

That’s much appreciated Mark - thanks. Any ideas so far? 8)

Not yet mate, but then I’m stupidly busy with Peppermint 7 so I’m having to put non critical issues to one side for the moment.

I’ll get around to this, but it may be a short while … sorry.

No worries Mark, that’s understandable. Whenever you have the time, it’ll be appreciated. At least I’m able to enjoy Mint for the time being!

Is there anything in the BIOS or Win10 itself about “Fast Boot” ?