Can not change boot order on dual boot laptop. (resolved)

After my recent escapades I bought a new (to me) laptop. Basically a more together version of the one I had (HP 15 notebook). As it came with Win10 I thought it would be useful to keep this available & so went for a dual boot option with Ubuntu 20.04.

I negotiated making a bootable USB stick. I changed the BIOS to boot 1st from CD/USB then inserted the media & followed the instructions.
I was prompted to make a ‘one time password’ to configure secure boot. I allocated 1/2 the 1Tb hard drive to Ubuntu. checked install updates & 3rd party software option. All was going well.

When prompted to restart at the end I was unsure when to remove the USB stick & didn’t want to restart with it in place as it would boot to that, so I closed that dialogue box intending to power off as normal, remove the stick & power up as usual. There was some short message I didn’t understand on a blackscreen, I could hear stuff going on & a normal GUI displayed. I chose to power off. There was a dialogue box saying to remove the media & press enter, which I did.

On power up it booted to Win10. I powered off & f9’d on power on & selected Ubuntu & this booted but I was not asked to enter the ‘one time password’ at any point (nor have I since).

Carried out checks to make sure 3rd party software stuff was active (pretty sure it is) & made sure I updated everything via terminal. Then accessed the BIOS to turn off secure boot hoping that would sort out the boot order & give the option of which OS to boot on start up (which is what I was expecting). It booted to Win10. Retried a few times & always boots to Win10 as default. Did some searches to find a solution.

I installed Grub-customizer which allegedly allows me to do this in the ‘general settings-default entry-predefined’ dropdown menu. I set this to Ubuntu, saved, restarted - & got Win10 again. Doubled check everything & Grub Customizer has Ubuntu as default/1st entry but if I restart or power off it still boots to Win10, directly without any option to change. If I want Ubuntu I have to f9 to get it.

Ideally I’d like to get the option of which OS to choose when I power on, which is what I was expecting. I’d settle for default boot of Ubuntu & f9 to get Win10. What I don’t want is what I’ve got.

I don’t know where to go from here. Please help.

This way out of my league, but at UEFI Secure Boot: Big Hassle, Questionable Benefit - I did find this:
"Microsoft is requiring Windows 8-certified hardware to ship with UEFI Secure Boot enabled. This prevents installing any other operating systems, or running any live Linux media. There are ways to get around Secure Boot– but why should we, once again, have to jump through Microsoft hoops just to use our own hardware the way we want to?"
As windows is now up to version 10, all this might have changed.

Not helpful, I know. But instructive.

Can you reinstall without secure boot? Or abandon Windows and install Linux alone?


You may also find these articles helpful -

Installing Linux on a PC with UEFI firmware: A refresher and this

I trust you have saved a copy of your ‘one time password’ somewhere…?

Edit: If the above doesn’t work, I suggest a re-install of Ubuntu and a disabling of ‘secure boot’ when prompted (or switching to ‘legacy mode’ if available) :wink:

Thanks for your responses. They’ve proved very helpful.

It would appear I made no mistakes - other than trying to dual boot on an HP machine.
The ZDnet article pretty much covered everything I needed to know. It seems HP configure UEFI (an o/s in it’s own right) in accordance with Macroshaft’s wishes so that no matter what you do it will be ignored if there is a Win o/s available. It will always boot to this 1st. There were various options to try & get round this when similar occurs on other manufacturers machines but HP seem particularly defiant & just will not allow it. I tried them all.

The only 2 ways round this for HP are:

  1. selecting another o/s from f9 when powering on (for HP 15 notebook - what I had been doing).
  2. setting BIOS to boot from CD/USB as 1st option (which allows running a live USB stick / installing another o/s).

So it made no difference setting a onetime password (I did write it down), whatever that did or didn’t accomplish it would be very short lived & reset almost immediately.

My solution was option 2, boot from USB (having disabled secure boot) then wipe the whole drive & install Ubuntu only.
I had the option to just wipe Ubuntu & reinstall but I was sure enough that this would produce the same result.
Macroshaft can take flying dodah as far as I’m concerned, I’m not that desperate to have dual boot. I just though it might be useful at some point but all it’s done is remind why I came to Linux in the first place.

Thanks again.

For my part, you’re welcome!

In my own experience, changing exclusively to Linux (in my case Mint) has made no practical difference at all. Only on a couple of occasions have I ‘needed’ Windows (to update a device - my golf range-finder, as it happens!) and that due to the manufacturer’s firmware rather than any shortcomings with Mint. Five minutes on daughter’s laptop sorted that one out - and that’s in over ten years of using Linux! In all other respects, Linux allows me to do everything I want to without the constant hassle I used to get with Windows. No contest, really.

Glad you got it sorted :slight_smile: