Cannot connect to network (SOLVED)

Earlier this evening my router was accidently unplugged. I now cannot connect to the network on my Vaio laptop. My daughter’s Toshiba laptop reconnected immediately. I am using that at the moment. I have tried rebooting the Vaio but it’s still not connecting.

I’m running Mint 13 Maya.

Thanks in advance.

Hi Tanya

If you click on your network Icon is you network showing up ?

Hi Graeme,

There is normally a list of networks with my own network and my neighbours. All it shows is Wireless On/Off, On is greyed out and it won’t allow to me to click it. I’ve checked the switch on my laptop and it’s definitely in On position.

can you post the output of…

lshw -c network
ifconfig

Could you see if wireless is blocked with:

sudo rfkill list

and post the result

I’m using another laptop so I can’t easily post the outputs. I’d have to write them manually. :-\

Yeah that’s a problem usually what I do is copy and paste the outputs into a text editor save it to a usb drive then plug the device into the working laptop/PC (obviously you would need a spare usb drive ) :slight_smile:

alternatively if you have an ethernet cable you could try connecting to your router via ethernet and see if you can connect to the network that way

I'm using another laptop so I can't easily post the outputs. I'd have to write them manually.
In that case just try to unblock all (just in case any of them is blocked)
sudo rfkill unblock all

and see if that does help.

[EDIT]
You could also try to activate the wireless card manually
First you find out what it is called (eg wlan0)

sudo ip link

Look at the output and note the name of the wireless.
then (replace wlan0 accordingly)

sudo ip link set wlan0 up

Was about to try an ethernet Graeme but just tried SeZo’s suggestion and I’m up and running again.

Many thanks to you both.

Glad you got it working :slight_smile:

Graeme

I’m sorry to restart this thread but I’m still having problems with it. The damn thing just disconnects randomly on wake up or boot up so, I have to keep entering sudo rfkill unblock all.

Thanks

Doesit only fail to connect upon boot or resume … or does it drop out whilst running ?

Not as yet.

This could be down to power management too.
Also it would be useful if you could provide the output (after boot, no wireless):

sudo rfkill list all

As a workaround you could put the following into /etc/rc.local
add this line before exit 0

rfkill unblock wifi

sudo rfkill list all:

0: sony-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes

As a workaround you could put the following into /etc/rc.local
add this line before exit 0

rfkill unblock wifi

[/quote]
Sorry Sezo I don’t understand how to do this.

Hi Tanya

What SeZo is suggesting is this

Open the terminal type

sudo gedit /etc/rc.local

a text file will open up then copy and paste

rfkill unblock wifi

at the bottom immediately above the line that says exit 0, then save the file

Graeme

Thank you Graeme.

You’re welcome :slight_smile:

It happened again.