Cannot delete files from my portable hard drive when on Peppermint laptop SOLVED

Hello guys I am back! I’ve been busy moving to a new place. I now am on Linux again! A guy in a computer shop put Peppermint 8 on a Dell laptop my friend gave me. She said it was a good laptop but the “processor was slow”- er no it was just Windoze filling it up with malware- it is running fast and good on Peppermint! It has Chrome on it, but I asked the fella to put Firefox on it- but I no longer like it as much as I like Chrome, so I’m using Chrome now because I love that I can access all my bookmarks in the nice icon manager extension I have on the Chromebook, so no having to import all my faves into Firefox. Everything is hunky dory except that I can’t seem to delete files that are on my Maxtor portable hard drive! When I click on the delete button or do a right click nothing happens- can’t even send them to the recycling bin. I am needing to do some file management, as got files on it I no longer want/need. Any ideas what could be the problem?
By the way guys- I can see there have been some changes in Peppermint since I was using 6. Looks very slick!

can you plug in the external drive … then (if it doesn’t open automatically) open the file manager and navigate into the external drive.

Then open a terminal and post the output from:


so we can see where the drive is getting mounted.

$ mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=1495216k,nr_inodes=373804,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=303840k,mode=755)
/dev/sda1 on / type ext4 (rw,relatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=35,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=13575)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
mqueue on /dev/mqueue type mqueue (rw,relatime)
sunrpc on /run/rpc_pipefs type rpc_pipefs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tracefs on /sys/kernel/debug/tracing type tracefs (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=303840k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
/dev/sdb1 on /media/barnabas/MAXTOR type vfat (rw,nosuid,nodev,relatime,uid=1000,gid=1000,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,showexec,utf8,flush,errors=remount-ro,uhelper=udisks2)

It mounts instantly Mark. It’s been great to be on a super fast laptop again. The Chromebook was super fast for a few months but then has slowed down as it hasn’t enough RAM. It might speed up again once it has more files removed. I’m bit by bit moving files to my Google drive so that I can move some onto the Maxtor and this Peppermint Dell.

Yeah I’m just trying to find out if there’s a permissions issue

what’s the output from:

ls -l /media/barnabas

barnabas@barnabas-Inspiron-1545 ~ $ ls -l /media/barnabas
total 32
drwxr-xr-x 72 barnabas barnabas 32768 Jan 1 1970 MAXTOR
barnabas@barnabas-Inspiron-1545 ~ $

Thanks Mark. Another thing I keep getting is a notification when navigating some websites:

$1 was blocked because it is out of date. Update plug in Run this time

Probably the flash plugin…

Go to:-
menu > Preferences > Software & Updates

When the “Software & Updates” dialog opens, select the “Other Software” tab.

Now make sure there’s a tick in the box labelled “Canonical Partners” (enter your password if prompted) … then click the “Close” button.

Now open a terminal and run:

sudo apt-get update


sudo apt-get dist-upgrade

then reboot.

Once rebooted, check to see if you still get that error ?

Are you still having problems deleting files from the external drive ?

If so, are you able to create files there ?

Thanks, done all that in the terminal. The flash problem seems sorted now Mark and I can delete filed off the Maxtor. I can save stuff to it as well, many thanks.

Great news, thanks for marking the topic solved :slight_smile: