Can't copy to Android phone [solved]

I’m not sure whether I’m in the right place for this question, or whether the problem lies with my installation of Xubuntu, but here goes.

I’m trying to copy an album ripped from a cd (by Soundjuicer) onto the expansion card in my phone. I’ve done this before with no problem. Today however, nothing gets copied and I get the message "libmtp error. Could not send object. Do you want to skip it? Then File manager seizes up and either I get the “This window is not responding…” message, or I use xkill. Then I have to reboot to get File manager working again.

Any help much appreciated. Thanks.


As an experiment, try booting into the previous kernel and see if it works ?

Thanks Mark,

I’ve just tried the two previous kernels, but nothing has changed…


I just swapped from MTP to PTP on the phone and was able to copy the album to DCIM/100ANDRO on the phone. I then swapped back to MTP, but although I can see the files, I can’t copy them from internal storage to the SD card. Bizarrely, the music app on the phone sees them and plays them though!

I hate it when things work but I don’t understand how, and I hate that I can’t place these files where I want them to be, so any help figuring this out would be hugely appreciated. I’d also like to work out whether the phone is working properly…

The problem may be caused by a colon in the name of the album. Does that make sense?

Maybe … I’m not 100% sure how the MTP protocol is defined.

Linux has always been pretty friendly to having “special characters” in filenames, Windows not so much … and MTP is part of the “Windows Media” framework, so written with Windows Media Player in mind.

Personally I wish they’d just go back to the much more universal and flexible “USB mass storage” and kill of MTP (and the Windows Media DRM stack it’s part of) … but they generally don’t listen to me :slight_smile:


For “generally”, read “never” :slight_smile:

The fools! They don’t listen to me either. But I’ve beaten them - I just sit here and talk to myself instead.

The colon does seem to be the problem. Oddly, the folder with the colon in it’s name gets copied across, but not the contents. Nor can I copy the contents into it afterwards. The only way seems to be to edit the colon out of the name. Easy enough of course, but a real timewaster until you discover the trick.

I’ll mark this solved now. Thanks for your time.