Can't get my floppy to work

Not that it’s critical any more but I do use some old machinery that still relies on a floppy and I need to keep a backup of the discs at home.
I used my win xp lappy to do this the other day and gees it was frustrating, took an age to start up, kept freezing and just really laggy, heck my phone is more usable.
Anyway, when I put a disc in and try to mount the drive it tells me there is “Unable to mount no media in drive”, even tried a usb drive with the same result.
This is the output for lsusb if it helps

gill@gill-ThinkCentre-A50:~$ lsusb
Bus 005 Device 004: ID 0409:0040 NEC Corp. Floppy
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 045e:00e1 Microsoft Corp. Wireless Laser Mouse 6000 Reciever
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 013: ID 148f:2070 Ralink Technology, Corp. RT2070 Wireless Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I’ve just discovered that floppy drives haven’t been working properly in Ubuntu/Debian for some time now… they NEED to fix this.

Anywho… there is a fix :slight_smile:

Can you open /etc/fstab and post the contents:

gedit /etc/fstab

and the contents of /etc/modules :

gedit /etc/modules

and the output from this command:

uname -a

and the output from:

cat /etc/*-release
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
# Commented out by Dropbox
# UUID=aa059838-d27b-4a45-b4f6-d88cd4307a94 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=dddd7957-5304-4e59-8f8d-eff0398a9b44 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
UUID=aa059838-d27b-4a45-b4f6-d88cd4307a94 / ext4 errors=remount-ro,user_xattr 0 1
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

lp
gill@gill-ThinkCentre-A50:~$ uname -a
Linux gill-ThinkCentre-A50 2.6.35-30-generic #56-Ubuntu SMP Mon Jul 11 20:00:22 UTC 2011 i686 GNU/Linux
gill@gill-ThinkCentre-A50:~$ cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.10
DISTRIB_CODENAME=maverick
DISTRIB_DESCRIPTION="Ubuntu 10.10"

OK, you’ve got 2 options…

  1. Manually mount the floppy every time you want to use it:
sudo mount -t vfat /dev/fd0 /media/floppy0

unmount with:

sudo umount /media/floppy0

or

  1. See the instructions in post #10 here:
    Question #101865 “AMD64 Karmic won't auto mount floppy media” : Questions : util-linux package : Ubuntu

Be Aware, I haven’t tested option 2 as I don’t have a floppy drive… that said, downgrading udisks didn’t seem to introduce any problems on my system (Ubuntu 11.04 64bit).

Personally I’d SKIP the section in his instructions that reads

$ sudo -s [your password] # echo udisks hold | dpkg --set-selections # exit $ sudo apt-get update && sudo apt-get upgrade

and instead, I’d lock the udisks version in synaptic.


OK, my modified verion of his instructions (for YOUR Ubuntu 10.10 32bit)…

We’ll ignore the fstab edits as the line is already present.

  1. Check you have a directory at /media/flopp0 with:
nautilus /media

and see if there is a directory called floppy0

  1. run:
sudo gedit /etc/modules

and add a new line at the bottom that reads
floppy
save and exit gedit.

  1. Download this file and put it in your home directory:
    https://launchpad.net/ubuntu/+archive/primary/+files/udisks_1.0.1-1build1_i386.deb
    now run:
cd ~
sudo dpkg -i udisks_1.0.1-1build1_i386.deb

and let it install.

  1. Reboot, but if offered any updates ignore them for now.

  2. Test the floppy drive now recognises the disk.

  3. If it doesn’t, a sinmple

sudo apt-get udate && sudo apt-get upgrade

should replace the original version of udisks.

If it DOES work… fire up Synaptic and in quicksearch enter udisks … highlight the udisks package (which should now state the “installed version” as 1.0.1-1build1), and in the menu’s select Package > Lock Version.

Done.


For future readers that are running Ubuntu 64bit… this is the udisks downgrade file you will need:
https://launchpad.net/ubuntu/+archive/primary/+files/udisks_1.0.1-1build1_amd64.deb

Launchpad udisks package overview:
https://launchpad.net/ubuntu/+source/udisks


FYI … for anyone that DID use his:

echo udisks hold | dpkg --set-selections

command, but now want to remove/undo the “hold” … so the udisks package will update normally:

echo udisks install | dpkg --set-selections

(run as root)

Tried the first option and still get the same result “no media in drive”.
Didn’t try the second in case this is indicative of a different issue.

Try this…

sudo mkdir /mnt/floppy

then

sudo mount -t vfat /dev/fd0 /mnt/floppy

then see if the floppy disks contents are in /mnt/floppy:

nautilus /mnt/floppy

Unmount with:

sudo umount /mnt/floppy

It could be an issue with the floppy disk… have you tried another pre-formatted disk ?

With the floppy disk inserted, what is the output from:

sudo parted -l

and

lsmod | grep floppy

I seem to have the same problem on Ubuntu 11.04

Following readout with floppy in drive -

userone@office2:~$ sudo parted -l
[sudo] password for userone:
Model: ATA WDC WD1600AAJB-0 (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 32.3kB 160GB 160GB primary fat32 boot

Model: ATA MAXTOR STM316021 (scsi)
Disk /dev/sdb: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
1 1049kB 76.5GB 76.5GB primary ext4
2 76.5GB 160GB 83.5GB extended
6 76.5GB 149GB 72.7GB logical ext4
7 149GB 153GB 4291MB logical linux-swap(v1)
5 154GB 160GB 6538MB logical linux-swap(v1)

Warning: Unable to open /dev/fd0 read-write (Read-only file system). /dev/fd0
has been opened read-only.
Model: Unknown (unknown)
Disk /dev/fd0: 1475kB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags

userone@office2:~$ lsmod | grep floppy
floppy 60032 0
userone@office2:~$

… notifyc

Is there a work around…

After some more digging, there appears to be a bug that’s been around for some time in Ubuntu regarding the mounting of floppy disks… I’m guessing it hasn’t received the attention it should because floppy disks are now considered long dead.

Try this

insert the floppy disk, then open a terminal and enter:

udisks --mount /dev/fd0

Let me know if it works, and I’ll look for a more permanent solution.

I can’t test it myself… no floppy drive :slight_smile:

Yes it works fine and I have created a desktop short-cut to mount the drive.

But it would be nice if it would work when you put a floppy in the drive.

I fond some games on floppy’s and I am also reviewing some project work from the 1990s on floppy’s.

I’ll see what I can dig up tomorrow.

are you running 32 or 64bit Natty ?

BTW:

udisks --unmount /dev/fd0

should unmount the floppy.

Ha!
Found another way to achieve what I needed and completely forgot about this thread, sorry :-[
The above CLC works in Maverick too and it’s easy enough to create a desktop launcher but it would be nice to have it work normally.
Tramlink,
I found some old 5.25" discs and some cassettes not long ago and would love to see what I put on them. Oh the heady days of the 1980’s when we thought 128k was the last word.
IIRC I still have a 28k modem lying around somewhere (the kind you put your telephone handset into)

For now, see the above mount and unmount commands.

I think I’ve already posted a fix in option 2 further up this thread, here:
http://linuxforums.org.uk/general-help-advice/cant-get-my-floppy-to-work/msg66031/#msg66031

But before trying it… I’ll test the downgrade of udisks in a VM tomorrow, and see if it causes any problems.

So galaxytdm, you’re running Maverick ?

and Tramlinks using Natty.

OK, I’ll test it in both… would be helpfull to know if you’re running 32 or 64bit though ?

If unsure:

uname -a

[EDIT]

I found some old 5.25" discs

Ahh, when men were men, and floppies were just that, floppy … eh! :slight_smile:

Yeh, 10.10 that’s Maverick right?
Sure i’m using 32bit, but here’s the output.

2.6.35-30-generic #59-Ubuntu SMP Tue Aug 30 15:58:00 UTC 2011 i686 GNU/Linux

Yup 10.10 is Maverick Meerkat :slight_smile:

I’ll test it tomorrow, and post back here.

userone@office2:~$ uname -a
Linux office2 2.6.38-11-generic-pae #50-Ubuntu SMP Mon Sep 12 22:21:04 UTC 2011 i686 athlon i386 GNU/Linux
userone@office2:~$

32bit version.

OK, both of you…

cd ~

then

wget http://dl.dropbox.com/u/11876059/udisks_1.0.1-1build1_i386.deb

then

sudo dpkg -i udisks_1.0.1-1build1_i386.deb

Now reboot, but don’t accept any updates just yet.

Test the floppy drive…

If it doesn’t work, run:

sudo apt-get update && sudo apt-get upgrade

and your back to the original version of udisks.

If it DOES work… fire up Synaptic and in quicksearch enter udisks … highlight the udisks package (which should now state the “installed version” as 1.0.1-1build1), and in the menu’s select Package > Lock Version, Synaotic should now display a little padlock icon next to udisks… now it won’t get updated when you next run Update Manager.


Oh, and can you let me know if it works or not please.

Worked fine for me on 11.4 Ubuntu now locked. I wonder if it will work on my old laptop running peppermint 2 also has the same problem when I hot swap the DVD and floppy drives.

Happy to hear it works, I hope you only locked that one package :wink:

Which version of udisks does Peppermint-2 say is installed ? … and do you know what Peppermint-2 is based on ?

Peppermint 2 showing Udisks 1.0.2-4 Ubuntu2

Peppermint OS is based upon, and is compatible with, Ubuntu 11.04 and it’s repositories. Specifically, Peppermint OS is a fork of Lubuntu.

As udisks 1.0.2-4ubuntu2 is the deefault for Ubuntu 11.04 too, I’d be fairly confident it will work in Peppermint2 as well :slight_smile: