cant initialise HAL!

My AA1 ZG5 os 1.0.9.e was not showing video (sudden failure).
Just followed your advice and installed Firefox 7. Its in there but wont connect. It cant initialise HAL!
Simple advice needed.
I can only think to restore firefox 2.
Is that it?

No … this problem was NOT caused by Firefox 7, it is probably caused either by a lack of inodes, a full SSD, a failed system update, or stale mtab lock files.

Are you still able to open a terminal ? … to open a terminal, hit Alt+F2, in the resulting dialog box type terminal, and hit enter.

If so, can you send the output from these commands:-

In the terminal type:

df -i

hit enter, and post back the resulting output.

In the terminal type:

df -h

hit enter, and post back the resulting output.

In the terminal type:

ls -a /etc/mta*

hit enter, and post back the resulting output.


Links for reference:
http://linuxforums.org.uk/index.php?topic=7751.msg50431#msg50431
and
http://linuxforums.org.uk/index.php?topic=9661.msg68628#msg68628

outputs are

df -i
Inodes IUsed Ifree Iuse Mounted on
/dev/sdal 854784 87117 767667 11%/

df-h
command not found

Is-a/etc/mta-

                No such file or directory

You are not entering the commands properly … I’ll give them again in UPPER case, but you MUST enter them in lower case, as Linux commands ARE case sensitive … and you MUST enter the spaces where shown.

DF -H
not
DF-H

and
LS -A /ETC/MTA-
not
IS-A/ETC/MTA-

df -h
produces

/dev/sdal 6.5G 3.9G 2.3G 63% /

no luck with the last command though: no such file or directory (9 times tried with different perms) - still trying.

My appologies … it should be an asterisk (*) on the end, not a dash (-) … so it should read:

ls -a /etc/mta*

As I originally posted.

ls -a /etc/mta*
gives

cannot access /etc/mtab-13417: Input/out error

and some more numbers …are these relevant?

OK, if the mtab files are unreadable, I’m going to guess your file system is corrupt … you have 2 options.

  1. Create a LiveUSB (of something like Ubuntu or PeppermintOS), boot to the LiveUSB stick and use it to backup your user files, then use it to attempt to fix the file system.
    or
  2. Reinstall Linpus Lite from scratch … see here for instructions:
    http://linuxforums.org.uk/index.php?topic=7491.msg47701#msg47701

In your position, I’d take this opportunity to replace the Linpus Lite OS with PeppermintOS … PeppermintOS will give you easy access to all the latest software unlike Linpus Lite which is now VERY outdated and no longer supported.

If you decide to install PeppermintOS (or another Linux disrtibution), you will have to create a LiveUSB stick (to install from) which can also be used to, first copy all your user files to another USB stick, and secondly to attempt to fix the Linpus Lite installation before deciding to overwrite it with Peppermint.

So in either case you’re going to need to create a LiveUSB stick … do you know how ? … or do you want instructions ?
and have you got preferably 2 USB sticks … one for the LiveUSB and one to backup your user files to ? … one must be 1GB or bigger, and one big enough to backup your user files.

If you want to know more about PeppermintOS, see here:

PeppermintOS (2) is based on Ubuntu 11.04, so has access to all the Ubuntu software, but uses the LXDE desktop environment so is much lighter than the full Ubuntu and runs really well on a standard AA1 … it’s my OS of choice for a standard AA1 :slight_smile:

excellent Mark. I’ll give it a go. After some digesting!
I hope its the last you hear from me.Just one more yes/no answer?
I souped the AA1 with a G of RAM two years ago- could this be relevant?
But thankyou v. much.
Brian

Create a LiveUSB, then come back here and I’ll tell you how to use it to attempt to fix the Linpus file system.

If you need instructions to create one, or ANY other assistance … just ask … after all, that’s what we’re here for :slight_smile:

Or follow that link to reinstall Lipus from scratch … but be aware, that will completely wipe the drive, so using a LiveUSB to backup your user files first would probably be a good idea :slight_smile:

Having 1.5GB RAM is unlikely to have caused the issue (unless the RAM is bad) … but it does mean you can probably install and run the FULL Ubuntu at a reasonable speed … if you wish.

A LiveUSB would also allow you to “test” the RAM if you suspect it.

ok, a new day!
I am still studying.

  1. there’s nothing I need to back up on the machine.
  2. I already have a download -aa1usb recovery GZ 957 file on a usb stick. I also have the original recovery disc with a DVD player. They dont work because none of the usb sockets on the aa1 are live. Is this surmountable?
  3. If it is, I will gladly take your advice about the peppermint os.

The USB ports should work just fine … they are only NOT working once the system has started the broken Linpus Lite OS, and the OS has taken control of them.

If you’ve created the Linpus Lite installation USB stick following the video, or have a USB DVD, just plug it in, turn ON the AA1 and hit F12 as soon as you see the “Acer Empowering People” screen … you will be offered the “boot device selection screen” … select the USB stick or DVD.

But if you would prefer to try PeppermintOS (Two)…

The following instructions are for creating a PeppermintOS LiveUSB stick using a Windows PC … if you need instructions for creating one on a Linux PC, let me know.

OK, on your Windows PC, download the PeppermintOS (two) ISO image from here:
http://peppermintos.info/dl2/Peppermint-Two-i386-06052011.iso
or see here:
http://peppermintos.com/download/

Once you’ve got the ISO image … download Universal USB Installer from here:

or see here:

Start Universal USB Installer, and at …

Step 1 … In the drop down list, select PeppermintOS (Two)
Step 2 … point it at the ISO image you downloaded
Step 3 … Choose your (already plugged in >= 1GB) USB stick … probably best to let it format it too, so backup its contents first.
Step 4 … Set the slider to the largest persistence file it will allow you… so you can save changes. (if you want to test drive it first)

Heres a pic of the Universal USB Creator interface

http://linuxforums.org.uk/MGalleryItem.php?id=1510

Click Create … and wait till it’s done … it will take a while, and may appear to have stopped … but just wait till it says it’s “Done” … as in the following pic

Pic of Universal USB Installer … Installing to USB Stick

http://linuxforums.org.uk/MGalleryItem.php?id=1509

Once the LiveUSB has been created, click Close, plug it into your AA1, then turn ON your AA1 … as soon as you see the first screen (Acer Empowering People), hit the F12 key to access the boot device selection screen … and select the USB stick as the drive to boot from and hit Enter to boot.

When asked, select “Try Peppermint” not “Install Peppermint

Be aware … running from a USB stick will be quite a bit slower that running it from the internal SSD after installation, so don’t draw any conclusions about speed at this point :wink:

I can tell you that once installed, it takes about 15 - 20 seconds longer to boot than Linpus Lite … but once booted it loads/runs applications just as quickly … and has access to all the latest software.

Once you’ve got to a working desktop, we can either attempt to fix the Linpus file system … or you can just click the “Install Peppermint” icon that will be on the desktop.

If you want to try fix the Linpus file system, let me know and I’ll tell you how.

If you decide to give Peppermint a go (and it IS worth it) … Here’s the list of post installation tasks I needed to do to get Peppermint “just right” for me … and the approx time it will take

  1. enter the wireless key and connect … 1min
  2. enable wireless autoconnect … by default you had to turn wireless on every boot … 1min
  3. enable the extra repos … 2min
  4. enable auto login (if you want) … 2min
  5. run an update … 7min
  6. install apt-xapian-index
  7. install firefox
    8.) install vlc
  8. install libreoffice-writer
  9. install libreoffice-calc
  10. install thunderbird
  11. install pidgin (or amsn) IM client
  12. install lubuntu-restricted-extras
  13. apply the fix for the SDcard slot not working, and skype microphone volume … 5mins

all the software can be installed with a single command, and will take about 5 mins to install

I will be more than happy to post instructions for doing these if you want … and/or instructions for any other software you might want to install.

I am going to have a go at peppermintos. After I’ve absorbed your instructions.
But…
I have tried umpteen times to install using both the usb flash and the original product disc. In all cases the boot menu reverts and does not seem to save changes. It just ignores. I use the F2 menu access. The F12 does not give the options necessary.

When you put a USB stick in the back right USB slot (even an empty USB Stick)… then hit F12 at bootup … in the “Boot Menu” you should be offered -

  1. IDE 0: P-SSD1800
    2. USB HDD: General USB Flash Disk

Are you not being offered that?

Obviously if you select option 2 with an empty USB stick (or one without a valid boot sector) it will revert back to the SSD … but are you being offered the option ?

The options seem to have increased (there were only 2) - now there are 4:
1.USB CDROM: Sandisk U3 Titanium
2.USB HDD: Sandisc U3 Titanium
3 IDE 0: P-SSD1800
4. Network boot
I have selected 1
It returns a black screen saying: Error 17

I think that means either it cannot initialise the CD/DVD drive … or it cannot read the disk.

I’d either

  1. follow the instructions in the video to create a Linpus Lite USB stick installer.
    (word of warning … using the DVD that came with your AA1 on a Windows PC to create a USB stick installer has been known to screw up the Windows installation … just thought I’d let you know that)

  2. Download the 1.0.15E version (which I think was the original as installed on the ZG5) as a torrent:
    http://fenopy.com/torrent/acer_aspire_one_recovery_image/MTM4MjkwNA==/download.torrent

Then follow the instructions here:
http://dailycupoftech.com/2008/09/02/diy-acer-aspire-one-recovery-usb-device/

to get it onto the USB stick

or my favorite …
3) Follow my instructions to make a PeppermintOS LiveUSB above.

got peppermint onto my stick and it looked promising booting from usb. The Peppermint logo and pulsing dots though collapsed into a stream of dos numbers… the last statement was a suggestion to type help which gave a list of terminal commands.

Hmm … odd …I created mine from a Linux PC, but I’m surprised Universal USB creator failed

A few things you can try …

  1. I noticed the USB stick was a U3 stick … have you got any non-U3 USB sticks ? … if so try one of those instead.

  2. just try recreating the USB stick with Universal USB creator … sometimes they just go wrong.

  3. Try using something else to put Peppermint on the USB stick, such as Unetbootin:
    http://unetbootin.sourceforge.net/

Just select DiskImage as in the second pic on that page, and point it at the Peppermint ISO image you have already downloaded.


Another LiveUSB creator you could try would be Live USB Creator:

I loaded peppermint to a cd and using an external dvd player have succeeded in getting to the peppermint install. I need some guidance.

Allocate drive space. To replace Fedora release8(werewolf), It seems that the install will take 8.1GB - the entire disc size. ??

It won’t take anywhere near that … it’s asking you how much room you want to give it, but as you don’t want Linpus any more … let it use the whole drive.

In reality it will use about 1GB (ish) for the OS, software and swap file, the rest will be available for your use.