Choosing for my laptop

Hi, I have a lenovo g505s laptop and I’m trying to find the perfect distro for it.
I know most linux works on most pc’s but I’m of the understanding laptops can be a bit more tricky.
I have managed to install Fedora 19 so far after a tricky start and am now exploring the desktop environments available on the dvd iso but am wondering what other distro’s I can run on this machine. By that I’m talking about driver compatibility etc as I have read a few threads all over the place talking about issues with ubuntu and this machine. It was the reason I chose fedora actually, I checked the lenovo site for drivers available for my laptop and it had listing for Red Hat so Fedora seemed compatible to me
Is any of this making sense and can anyone help me?
You might have guessed butI am new to linux :slight_smile:
Thanks

Hi andyturner87, and welcome to the forum :slight_smile:

What makes you think Ubuntu based distros will have driver problems ?

Can you post the output from:

lshw

run in a root terminal, so we can get an idea of the hardware.

Can you also say what you generally use the PC for.

__

https://forums.lenovo.com/t5/Linux-Discussion/g505s-Linux/td-p/1243731
This post and another one somewhere referencing graphics driver issues just sort of put me off as I don’t know anything about CLI’s except for a bit of routers and switches.
The laptop will mainly be used for web surfing etc, some word processing, mp3’s and video, and Cisco Packet Tracer (but that’s another story as I am having trouble with that!) and also qtractor/ardour etc.
I tried that command but it did not work, do I need to be in a different mode/directory?
Part of me feels that my install is a bit buggy as I cant find some stuff like the yum GUI, and a number of commands i have tried to use from reading articles simply wont work (the trouble im having with packet tracer).

My advice would be to try an Ubuntu based distro from a LiveUSB and see how it goes … at the very least we should be able to get that output from there :wink:

I’d expect graphics drivers to be pretty much the same for all recent distro’s … so if it works in Fedora…

You’ll find help / tutorial / etc. much easier to come by for an Ubuntu derivative.

I would normally point you at PeppermintOS … but that being VERY recent hardware you may be better off trying something based on the latest Ubuntu 13.10 release … Ubuntu 13.10 / Kubuntu 13.10 / Lubuntu 13.10 /Xubuntu 13.10 / Mint 16 RC / etc.

Your call, but can’t hurt to try a LiveCD/LiveUSB

openSuSE 13.1 is rather nice - recently released.

Has the advantage of not being driven by a half mad egomaniac as Ubuntu is.

Well i tried ubuntu and mint and neither would load once installed so Im assuming graphics driver issues like I was half expecting.
I’v tried scientific linux but no matter what I do my laptop wont recognise it has got bootable media in it! Shame.
Il try opensuse next :slight_smile:

Ubuntu or Mint should be an easy fix for the graphics driver.

do you want to try, or have you already removed it.


If you still have Ubuntu or Mint installed, try this…

OK, the following instructions are for a single boot ONLY … so you’ll have to do this EVERY time you boot … but if it works, we can automate the procedure.

Turn ON your laptop, and as soon as your BIOS POST screen disappears, press the SHIFT key and hold it, until you are presented with the GRUB menu … SIMILAR to this:
(you won’t have long to hit the shift key, and the timing can be a little awkward, so it may even be easier to hit AND HOLD the Shift key DURING the BIOS POST … ie. immediately after turning on your PC)

http://linuxforums.org.uk/MGalleryItem.php?id=1361

Select the ‘default’ kernel (usually the top one), and rather than pressing enter, press E to edit.

You will be presented with a screen SIMILAR to this:

http://linuxforums.org.uk/MGalleryItem.php?id=1152

Press DOWN ARROW until you get to the line that starts with:

linux /boot

and press the END key to position the cursor at the end of the that line… it usually ends with “quiet splash”.

Now you can enter additional kernel boot options… so add nomodeset as in the above screenshot … so it now reads:

[b]quiet splash nomodeset[/b]
(doesn't matter if it moves down a line, as long as there is a space between splash and nomdeset)

Now hit Ctrl+X to boot.

If nomodeset doesn’t work … try replacing nomodeset with:-

radeon.modeset=0

or

radeon.modeset=0 blacklist=radeon

If this works, it will only work for a single boot and will need re-applying at the next boot … but if it solves the issue, we’ll make it permanent :slight_smile: