Chrome Update for Ubuntu Macbook help needed please! NOT SOLVED BUT MACBOOK DIED

Hello guys, just logged into my Macbook running on Ubuntu and when I launched Chrome it said it is needing an update but I don’t know how to do it. I know how to do it on Peppermint but I’m stumped on Ubuntu!

Some instructions would be very welcome!

I will in the near future take the Macbook to the computer repair blokes I know and pay them to put the latest Peppermint distro on it. Mark Greaves was right: Peppermint works better on a laptop.

I find all these updates on Chrome very annoying- why’d they keep doing this–sigh.

Another question for you, which is related. Since my Chromebook seems to be on its last update, when it is no longer working well enough for use, is it possible to clear the Chrome OS and put Peppermint on it to give it a new lease of life? I’ve read some people can do it.

I’m all for refurbishing laptops.

Hello guys, just logged into my Macbook running on Ubuntu and when I launched Chrome it said it is needing an update but I don't know how to do it. I know how to do it on Peppermint but I'm stumped on Ubuntu!

Some instructions would be very welcome!


In principle, if you do a manual update that should update Chrome along with any other updates available. There are two ways:

  1. If you are using the Unity desktop (with the large icons down the LHS of your desktop) search for “Software update”. If you are using the Classic View desktop click on Applications/System-Tools/Administration/Software-Updater.
  2. To use the terminal, start a terminal session (Ctrl+Alt+T) and enter:
sudo apt update

When that finishes, enter

sudo apt upgrade
Another question for you, which is related. Since my Chromebook seems to be on its last update, when it is no longer working well enough for use, is it possible to clear the Chrome OS and put Peppermint on it to give it a new lease of life? I've read some people can do it.
I am not familiar with the Chromebook, but I don't see why not - other Members may have some experience of doing so.

Keith

I am not sure which I have, but I run the commands and this is what came back:

von@avon-MacBookPro:~$ sudo apt update
[sudo] password for avon:
Hit:1 Index of /ubuntu focal InRelease
Get:2 Index of /ubuntu focal-updates InRelease [114 kB]
Hit:3 http://dl.google.com/linux/chrome/deb stable InRelease
Get:4 Index of /ubuntu focal-backports InRelease [101 kB]
Get:5 Index of /ubuntu focal-security InRelease [114 kB]
Get:6 Index of /ubuntu focal-updates/main amd64 DEP-11 Metadata [282 kB]
Get:7 Index of /ubuntu focal-updates/universe amd64 DEP-11 Metadata [351 kB]
Get:8 Index of /ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [940 B]
Get:9 Index of /ubuntu focal-backports/universe amd64 DEP-11 Metadata [10.4 kB]
Get:10 Index of /ubuntu focal-security/main amd64 DEP-11 Metadata [27.6 kB]
Get:11 Index of /ubuntu focal-security/universe amd64 DEP-11 Metadata [61.1 kB]
Get:12 Index of /ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2,464 B]
Fetched 1,064 kB in 1s (1,109 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
121 packages can be upgraded. Run ‘apt list --upgradable’ to see them.
avon@avon-MacBookPro:~$ sudo apt upgrade
E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem.
avon@avon-MacBookPro:~$

OK so now:

sudo dpkg --configure -a

…and if all is well:

sudo apt upgrade

{Sezo: Please do jump in as I am not familiar with dpkg and this error appeared also on Matilda’s other post http://linuxforums.org.uk/index.php?topic=14115.msg113100#msg113100}

Keith

Run the command it tells you to

sudo dpkg --configure -a

and it should be able to correct itself.

If it doesn’t try running

sudo apt-get install -f

(to fix broken packages) and then try running

sudo dpkg --configure -a

again.
Just make sure you have internet access available so that you can download any dependencies.

Thank you fellas. I’ll do that Sunday. Not been using the Macbook the past few days.

I wanted to watch a series on Channel 5 online a couple of days ago and it wouldn’t load. I thought my Chromebook must be too out of date, so I tried my Android tablet which is the latest version and it wouldn’t work there either.

Then I accidentally got signed up to a free trial for Amazon Prime and accidentally even paid to rent a film, the next day, so what the heck, I thought I’d just watch it, cos it has Dan Stevens in it and my Chromebook seemed too out of date for that too. I watched it on my Peppermint netbook. But- the shield icon at the bottom told me I had about 300 updates waiting! The updates on Peppermint normally only take 3 or 4 mins. This was quite a bit longer!

I’m not sure if Chrome is needing updating there still because there is a funny message at the top of the task bar which says “paused.”

Sorry not been around guys. I broke my knee so been in a lot of pain. I have had trouble even getting the Macbook to boot up the last time I tried it just kept going to a white screen.

Is this the same as your post Need to update Chrome browser on my Peppermint Netbook? Or your ChromeBook?
It would be helpful if each post you make is for one machine, giving details of operating system and the specific problem etc.

If your updates are very out of date, then it might be easiest to delete then re-install the Chrome browser.

Thanks.

This is the thread for the Macbook running on Ubuntu. The new thread was for the netbook running on Peppermint as I stated in that thread. Yeah-- I would do reinstalls but I do not know how.

Sigh–almost worked. :cry:

sudo apt upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages were automatically installed and are no longer required:
libllvm11 linux-headers-5.11.0-40-generic linux-hwe-5.11-headers-5.11.0-40
linux-image-5.11.0-40-generic linux-modules-5.11.0-40-generic
linux-modules-extra-5.11.0-40-generic
Use ‘sudo apt autoremove’ to remove them.
The following packages will be upgraded:
ghostscript ghostscript-x gir1.2-mutter-6
gnome-shell-extension-desktop-icons google-chrome-stable libegl-mesa0
libfprint-2-2 libgbm1 libgl1-mesa-dri libglapi-mesa libglx-mesa0 libgs9
libgs9-common libmm-glib0 libmutter-6-0 libnetplan0 libpulse-mainloop-glib0
libpulse0 libpulsedsp libssl1.1 libxatracker2 linux-firmware mesa-va-drivers
mesa-vdpau-drivers mesa-vulkan-drivers modemmanager mutter mutter-common
netplan.io openssl pulseaudio pulseaudio-module-bluetooth pulseaudio-utils
python3-software-properties rsync software-properties-common
software-properties-gtk ubuntu-advantage-tools update-notifier
update-notifier-common wget
41 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
Need to get 234 MB of archives.
After this operation, 1,725 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 Index of /ubuntu focal-updates/main amd64 rsync amd64 3.1.3-8ubuntu0.1 [318 kB]
Get:2 Index of /ubuntu focal-updates/main amd64 libgl1-mesa-dri amd64 21.0.3-0ubuntu0.3~20.04.5 [10.5 MB]
Get:3 http://dl.google.com/linux/chrome/deb stable/main amd64 google-chrome-stable amd64 96.0.4664.110-1 [89.3 MB]
Get:4 Index of /ubuntu focal-updates/main amd64 libglx-mesa0 amd64 21.0.3-0ubuntu0.3~20.04.5 [138 kB]
Get:5 Index of /ubuntu focal-updates/main amd64 libegl-mesa0 amd64 21.0.3-0ubuntu0.3~20.04.5 [96.2 kB]
Get:6 Index of /ubuntu focal-updates/main amd64 libglapi-mesa amd64 21.0.3-0ubuntu0.3~20.04.5 [26.8 kB]
Get:7 Index of /ubuntu focal-updates/main amd64 libgbm1 amd64 21.0.3-0ubuntu0.3~20.04.5 [28.7 kB]
Get:8 Index of /ubuntu focal-updates/main amd64 libssl1.1 amd64 1.1.1f-1ubuntu2.10 [1,322 kB]
Get:9 Index of /ubuntu focal-updates/main amd64 wget amd64 1.20.3-1ubuntu2 [348 kB]
Get:10 Index of /ubuntu focal-updates/main amd64 libpulse-mainloop-glib0 amd64 1:13.99.1-1ubuntu3.13 [11.7 kB]
Get:11 Index of /ubuntu focal-updates/main amd64 libpulsedsp amd64 1:13.99.1-1ubuntu3.13 [21.7 kB]
Get:12 Index of /ubuntu focal-updates/main amd64 pulseaudio-utils amd64 1:13.99.1-1ubuntu3.13 [55.0 kB]
Get:13 Index of /ubuntu focal-updates/main amd64 pulseaudio-module-bluetooth amd64 1:13.99.1-1ubuntu3.13 [60.4 kB]
Get:14 Index of /ubuntu focal-updates/main amd64 pulseaudio amd64 1:13.99.1-1ubuntu3.13 [814 kB]
Get:15 Index of /ubuntu focal-updates/main amd64 libpulse0 amd64 1:13.99.1-1ubuntu3.13 [262 kB]
Get:16 Index of /ubuntu focal-updates/main amd64 update-notifier amd64 3.192.30.10 [56.7 kB]
Get:17 Index of /ubuntu focal-updates/main amd64 update-notifier-common all 3.192.30.10 [133 kB]
Get:18 Index of /ubuntu focal-updates/main amd64 libnetplan0 amd64 0.103-0ubuntu5~20.04.5 [53.4 kB]
Get:19 Index of /ubuntu focal-updates/main amd64 netplan.io amd64 0.103-0ubuntu5~20.04.5 [125 kB]
Get:20 Index of /ubuntu focal-updates/main amd64 openssl amd64 1.1.1f-1ubuntu2.10 [620 kB]
Get:21 Index of /ubuntu focal-updates/main amd64 ubuntu-advantage-tools amd64 27.4.2~20.04.1 [859 kB]
Get:22 Index of /ubuntu focal-updates/main amd64 ghostscript-x amd64 9.50~dfsg-5ubuntu4.4 [44.1 kB]
Get:23 Index of /ubuntu focal-updates/main amd64 ghostscript amd64 9.50~dfsg-5ubuntu4.4 [51.8 kB]
Get:24 Index of /ubuntu focal-updates/main amd64 libgs9 amd64 9.50~dfsg-5ubuntu4.4 [2,173 kB]
Get:25 Index of /ubuntu focal-updates/main amd64 libgs9-common all 9.50~dfsg-5ubuntu4.4 [682 kB]
Get:26 Index of /ubuntu focal-updates/main amd64 mutter-common all 3.36.9-0ubuntu0.20.04.2 [12.9 kB]
Get:27 Index of /ubuntu focal-updates/main amd64 gir1.2-mutter-6 amd64 3.36.9-0ubuntu0.20.04.2 [109 kB]
Get:28 Index of /ubuntu focal-updates/main amd64 libmutter-6-0 amd64 3.36.9-0ubuntu0.20.04.2 [1,168 kB]
Get:29 Index of /ubuntu focal-updates/main amd64 gnome-shell-extension-desktop-icons all 20.04.0-3~ubuntu20.04.6 [25.0 kB]
Get:30 Index of /ubuntu focal-updates/main amd64 libfprint-2-2 amd64 1:1.90.2+tod1-0ubuntu1~20.04.5 [207 kB]
Get:31 Index of /ubuntu focal-updates/main amd64 libmm-glib0 amd64 1.16.6-2~20.04.1 [188 kB]
Get:32 Index of /ubuntu focal-updates/main amd64 libxatracker2 amd64 21.0.3-0ubuntu0.3~20.04.5 [1,716 kB]
Get:33 Index of /ubuntu focal-updates/main amd64 linux-firmware all 1.187.23 [111 MB]
Get:34 Index of /ubuntu focal-updates/universe amd64 mesa-va-drivers amd64 21.0.3-0ubuntu0.3~20.04.5 [2,825 kB]
Get:35 Index of /ubuntu focal-updates/main amd64 mesa-vdpau-drivers amd64 21.0.3-0ubuntu0.3~20.04.5 [2,944 kB]
Get:36 Index of /ubuntu focal-updates/main amd64 mesa-vulkan-drivers amd64 21.0.3-0ubuntu0.3~20.04.5 [4,731 kB]
Get:37 Index of /ubuntu focal-updates/main amd64 modemmanager amd64 1.16.6-2~20.04.1 [824 kB]
Get:38 Index of /ubuntu focal-updates/main amd64 software-properties-common all 0.99.9.8 [10.6 kB]
Get:39 Index of /ubuntu focal-updates/main amd64 software-properties-gtk all 0.99.9.8 [66.0 kB]
Get:40 Index of /ubuntu focal-updates/main amd64 python3-software-properties all 0.99.9.8 [24.9 kB]
Get:41 Index of /ubuntu focal-updates/main amd64 mutter amd64 3.36.9-0ubuntu0.20.04.2 [129 kB]
Fetched 234 MB in 28s (8,487 kB/s)
Extract templates from packages: 100%
Preconfiguring packages …
(Reading database … 310511 files and directories currently installed.)
Preparing to unpack …/00-rsync_3.1.3-8ubuntu0.1_amd64.deb …
Unpacking rsync (3.1.3-8ubuntu0.1) over (3.1.3-8) …
Preparing to unpack …/01-libgl1-mesa-dri_21.0.3-0ubuntu0.3~20.04.5_amd64.deb .

Unpacking libgl1-mesa-dri:amd64 (21.0.3-0ubuntu0.3~20.04.5) over (21.0.3-0ubuntu
0.3~20.04.3) …
Preparing to unpack …/02-libglx-mesa0_21.0.3-0ubuntu0.3~20.04.5_amd64.deb …
Unpacking libglx-mesa0:amd64 (21.0.3-0ubuntu0.3~20.04.5) over (21.0.3-0ubuntu0.3
~20.04.3) …
Preparing to unpack …/03-libegl-mesa0_21.0.3-0ubuntu0.3~20.04.5_amd64.deb …
Unpacking libegl-mesa0:amd64 (21.0.3-0ubuntu0.3~20.04.5) over (21.0.3-0ubuntu0.3
~20.04.3) …
Preparing to unpack …/04-libglapi-mesa_21.0.3-0ubuntu0.3~20.04.5_amd64.deb …
Unpacking libglapi-mesa:amd64 (21.0.3-0ubuntu0.3~20.04.5) over (21.0.3-0ubuntu0.
3~20.04.3) …
Preparing to unpack …/05-libgbm1_21.0.3-0ubuntu0.3~20.04.5_amd64.deb …
Unpacking libgbm1:amd64 (21.0.3-0ubuntu0.3~20.04.5) over (21.0.3-0ubuntu0.3~20.0
4.3) …
Preparing to unpack …/06-libssl1.1_1.1.1f-1ubuntu2.10_amd64.deb …
Unpacking libssl1.1:amd64 (1.1.1f-1ubuntu2.10) over (1.1.1f-1ubuntu2.8) …
Preparing to unpack …/07-wget_1.20.3-1ubuntu2_amd64.deb …
Unpacking wget (1.20.3-1ubuntu2) over (1.20.3-1ubuntu1) …
Preparing to unpack …/08-google-chrome-stable_96.0.4664.110-1_amd64.deb …
Unpacking google-chrome-stable (96.0.4664.110-1) over (95.0.4638.69-1) …
Preparing to unpack …/09-libpulse-mainloop-glib0_1%3a13.99.1-1ubuntu3.13_amd64
.deb …
Unpacking libpulse-mainloop-glib0:amd64 (1:13.99.1-1ubuntu3.13) over (1:13.99.1-
1ubuntu3.12) …
Preparing to unpack …/10-libpulsedsp_1%3a13.99.1-1ubuntu3.13_amd64.deb …
Unpacking libpulsedsp:amd64 (1:13.99.1-1ubuntu3.13) over (1:13.99.1-1ubuntu3.12)

Preparing to unpack …/11-pulseaudio-utils_1%3a13.99.1-1ubuntu3.13_amd64.deb …
.
Unpacking pulseaudio-utils (1:13.99.1-1ubuntu3.13) over (1:13.99.1-1ubuntu3.12)

Preparing to unpack …/12-pulseaudio-module-bluetooth_1%3a13.99.1-1ubuntu3.13_a
md64.deb …
Unpacking pulseaudio-module-bluetooth (1:13.99.1-1ubuntu3.13) over (1:13.99.1-1u
buntu3.12) …
Preparing to unpack …/13-pulseaudio_1%3a13.99.1-1ubuntu3.13_amd64.deb …
Unpacking pulseaudio (1:13.99.1-1ubuntu3.13) over (1:13.99.1-1ubuntu3.12) …
Preparing to unpack …/14-libpulse0_1%3a13.99.1-1ubuntu3.13_amd64.deb …
Unpacking libpulse0:amd64 (1:13.99.1-1ubuntu3.13) over (1:13.99.1-1ubuntu3.12) .

Preparing to unpack …/15-update-notifier_3.192.30.10_amd64.deb …
Unpacking update-notifier (3.192.30.10) over (3.192.30.9) …
Preparing to unpack …/16-update-notifier-common_3.192.30.10_all.deb …
Unpacking update-notifier-common (3.192.30.10) over (3.192.30.9) …
Preparing to unpack …/17-libnetplan0_0.103-0ubuntu5~20.04.5_amd64.deb …
Unpacking libnetplan0:amd64 (0.103-0ubuntu5~20.04.5) over (0.103-0ubuntu5~20.04.
2) …
Preparing to unpack …/18-netplan.io_0.103-0ubuntu5~20.04.5_amd64.deb …
Unpacking netplan.io (0.103-0ubuntu5~20.04.5) over (0.103-0ubuntu5~20.04.2) …
Preparing to unpack …/19-openssl_1.1.1f-1ubuntu2.10_amd64.deb …
Unpacking openssl (1.1.1f-1ubuntu2.10) over (1.1.1f-1ubuntu2.8) …
Preparing to unpack …/20-ubuntu-advantage-tools_27.4.2~20.04.1_amd64.deb …
Unpacking ubuntu-advantage-tools (27.4.2~20.04.1) over (27.3~20.04.1) …
Preparing to unpack …/21-ghostscript-x_9.50~dfsg-5ubuntu4.4_amd64.deb …
Unpacking ghostscript-x (9.50~dfsg-5ubuntu4.4) over (9.50~dfsg-5ubuntu4.3) …
Preparing to unpack …/22-ghostscript_9.50~dfsg-5ubuntu4.4_amd64.deb …
Unpacking ghostscript (9.50~dfsg-5ubuntu4.4) over (9.50~dfsg-5ubuntu4.3) …
Preparing to unpack …/23-libgs9_9.50~dfsg-5ubuntu4.4_amd64.deb …
Unpacking libgs9:amd64 (9.50~dfsg-5ubuntu4.4) over (9.50~dfsg-5ubuntu4.3) …
Preparing to unpack …/24-libgs9-common_9.50~dfsg-5ubuntu4.4_all.deb …
Unpacking libgs9-common (9.50~dfsg-5ubuntu4.4) over (9.50~dfsg-5ubuntu4.3) …
Preparing to unpack …/25-mutter-common_3.36.9-0ubuntu0.20.04.2_all.deb …
Unpacking mutter-common (3.36.9-0ubuntu0.20.04.2) over (3.36.9-0ubuntu0.20.04.1)

Preparing to unpack …/26-gir1.2-mutter-6_3.36.9-0ubuntu0.20.04.2_amd64.deb …
Unpacking gir1.2-mutter-6:amd64 (3.36.9-0ubuntu0.20.04.2) over (3.36.9-0ubuntu0.
20.04.1) …
Preparing to unpack …/27-libmutter-6-0_3.36.9-0ubuntu0.20.04.2_amd64.deb …
Unpacking libmutter-6-0:amd64 (3.36.9-0ubuntu0.20.04.2) over (3.36.9-0ubuntu0.20
.04.1) …
Preparing to unpack …/28-gnome-shell-extension-desktop-icons_20.04.0-3~ubuntu2
0.04.6_all.deb …
Unpacking gnome-shell-extension-desktop-icons (20.04.0-3~ubuntu20.04.6) over (20
.04.0-3~ubuntu20.04.4) …
Preparing to unpack …/29-libfprint-2-2_1%3a1.90.2+tod1-0ubuntu1~20.04.5_amd64.
deb …
Unpacking libfprint-2-2:amd64 (1:1.90.2+tod1-0ubuntu1~20.04.5) over (1:1.90.2+to
d1-0ubuntu1~20.04.4) …
Preparing to unpack …/30-libmm-glib0_1.16.6-2~20.04.1_amd64.deb …
Unpacking libmm-glib0:amd64 (1.16.6-2~20.04.1) over (1.16.6-2~20.04) …
Preparing to unpack …/31-libxatracker2_21.0.3-0ubuntu0.3~20.04.5_amd64.deb …
Unpacking libxatracker2:amd64 (21.0.3-0ubuntu0.3~20.04.5) over (21.0.3-0ubuntu0.
3~20.04.3) …
Preparing to unpack …/32-linux-firmware_1.187.23_all.deb …
Unpacking linux-firmware (1.187.23) over (1.187.20) …
Preparing to unpack …/33-mesa-va-drivers_21.0.3-0ubuntu0.3~20.04.5_amd64.deb .

Unpacking mesa-va-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.5) over (21.0.3-0ubuntu
0.3~20.04.3) …
Preparing to unpack …/34-mesa-vdpau-drivers_21.0.3-0ubuntu0.3~20.04.5_amd64.de
b …
Unpacking mesa-vdpau-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.5) over (21.0.3-0ubu
ntu0.3~20.04.3) …
Preparing to unpack …/35-mesa-vulkan-drivers_21.0.3-0ubuntu0.3~20.04.5_amd64.d
eb …
Unpacking mesa-vulkan-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.5) over (21.0.3-0ub
untu0.3~20.04.3) …
Preparing to unpack …/36-modemmanager_1.16.6-2~20.04.1_amd64.deb …
Unpacking modemmanager (1.16.6-2~20.04.1) over (1.16.6-2~20.04) …
Preparing to unpack …/37-software-properties-common_0.99.9.8_all.deb …
Unpacking software-properties-common (0.99.9.8) over (0.98.9.5) …
Preparing to unpack …/38-software-properties-gtk_0.99.9.8_all.deb …
Unpacking software-properties-gtk (0.99.9.8) over (0.98.9.5) …
Preparing to unpack …/39-python3-software-properties_0.99.9.8_all.deb …
Unpacking python3-software-properties (0.99.9.8) over (0.98.9.5) …
Preparing to unpack …/40-mutter_3.36.9-0ubuntu0.20.04.2_amd64.deb …
Unpacking mutter (3.36.9-0ubuntu0.20.04.2) over (3.36.9-0ubuntu0.20.04.1) …
Setting up libgs9-common (9.50~dfsg-5ubuntu4.4) …
Setting up mesa-vulkan-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.5) …
Setting up mesa-vdpau-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.5) …
Setting up libgs9:amd64 (9.50~dfsg-5ubuntu4.4) …
Setting up libgbm1:amd64 (21.0.3-0ubuntu0.3~20.04.5) …
Setting up libpulse0:amd64 (1:13.99.1-1ubuntu3.13) …
Setting up linux-firmware (1.187.23) …
update-initramfs: Generating /boot/initrd.img-5.11.0-43-generic
update-initramfs: Generating /boot/initrd.img-5.11.0-41-generic
update-initramfs: Generating /boot/initrd.img-5.11.0-40-generic
Setting up gnome-shell-extension-desktop-icons (20.04.0-3~ubuntu20.04.6) …
Setting up update-notifier-common (3.192.30.10) …
Setting up libssl1.1:amd64 (1.1.1f-1ubuntu2.10) …
Setting up libnetplan0:amd64 (0.103-0ubuntu5~20.04.5) …
Setting up libpulsedsp:amd64 (1:13.99.1-1ubuntu3.13) …
Setting up ghostscript (9.50~dfsg-5ubuntu4.4) …
Setting up libxatracker2:amd64 (21.0.3-0ubuntu0.3~20.04.5) …
Setting up netplan.io (0.103-0ubuntu5~20.04.5) …
Setting up mutter-common (3.36.9-0ubuntu0.20.04.2) …
Setting up python3-software-properties (0.99.9.8) …
Setting up libpulse-mainloop-glib0:amd64 (1:13.99.1-1ubuntu3.13) …
Setting up pulseaudio-utils (1:13.99.1-1ubuntu3.13) …
Setting up libglapi-mesa:amd64 (21.0.3-0ubuntu0.3~20.04.5) …
Setting up libmm-glib0:amd64 (1.16.6-2~20.04.1) …
Setting up update-notifier (3.192.30.10) …
Setting up ubuntu-advantage-tools (27.4.2~20.04.1) …
Installing new version of config file /etc/ubuntu-advantage/uaclient.conf …
Setting up modemmanager (1.16.6-2~20.04.1) …
Setting up mesa-va-drivers:amd64 (21.0.3-0ubuntu0.3~20.04.5) …
Setting up openssl (1.1.1f-1ubuntu2.10) …
Setting up rsync (3.1.3-8ubuntu0.1) …
Setting up libfprint-2-2:amd64 (1:1.90.2+tod1-0ubuntu1~20.04.5) …
Setting up wget (1.20.3-1ubuntu2) …
Setting up libgl1-mesa-dri:amd64 (21.0.3-0ubuntu0.3~20.04.5) …
Setting up ghostscript-x (9.50~dfsg-5ubuntu4.4) …
Setting up pulseaudio (1:13.99.1-1ubuntu3.13) …
Setting up software-properties-common (0.99.9.8) …
Setting up libegl-mesa0:amd64 (21.0.3-0ubuntu0.3~20.04.5) …
Setting up pulseaudio-module-bluetooth (1:13.99.1-1ubuntu3.13) …
Setting up google-chrome-stable (96.0.4664.110-1) …
Setting up libglx-mesa0:amd64 (21.0.3-0ubuntu0.3~20.04.5) …
Setting up software-properties-gtk (0.99.9.8) …
Processing triggers for mime-support (3.64ubuntu1) …
Processing triggers for hicolor-icon-theme (0.17-2) …
Processing triggers for gnome-menus (3.36.0-1ubuntu1) …
Processing triggers for libglib2.0-0:amd64 (2.64.6-1~ubuntu20.04.4) …
Processing triggers for libc-bin (2.31-0ubuntu9.2) …
Processing triggers for systemd (245.4-4ubuntu3.13) …
Processing triggers for man-db (2.9.1-1) …
Processing triggers for dbus (1.12.16-2ubuntu2.1) …
Processing triggers for shared-mime-info (1.15-1) …
Processing triggers for install-info (6.7.0.dfsg.2-5) …
Processing triggers for menu (2.1.47ubuntu4) …
Setting up libmutter-6-0:amd64 (3.36.9-0ubuntu0.20.04.2) …
Processing triggers for desktop-file-utils (0.24-1ubuntu3) …
Setting up gir1.2-mutter-6:amd64 (3.36.9-0ubuntu0.20.04.2) …
Setting up mutter (3.36.9-0ubuntu0.20.04.2) …
Processing triggers for libc-bin (2.31-0ubuntu9.2) …
libdvd-pkg: Checking orig.tar integrity…
/usr/src/libdvd-pkg/libdvdcss_1.4.2.orig.tar.bz2: OK
libdvd-pkg: apt-get check failed, you may have broken packages. Aborting…

Never mind. I will have some money in the summer to take the Macbook to the computer repair shop and they can get rid of this shonky Ubuntu and put the latest Peppermint distro in it for me.

You forgot to update before upgrading - unless you did that but didn’t post the output. Try

sudo apt update

then

sudo apt upgrade

Shouldn’t take long.

Then, if Chrome is the only problem at present, try reinstalling it:

sudo apt remove chrome

then

sudo install chrome

By the way; you can attach long output as a file, which makes the Forum pages easier to read.

Thank you Keith. I don’t understand all these commands you know! I just put them into the terminal. Well I did used to attach files but Mark Greaves told me not to do that. I think he said it would risk viruses on the board or something.

avon@avon-MacBookPro:~$ sudo apt update
[sudo] password for avon:
Hit:1 Index of /ubuntu focal InRelease
Hit:2 Index of /ubuntu focal-updates InRelease
Hit:3 Index of /ubuntu focal-backports InRelease
Hit:4 Index of /ubuntu focal-security InRelease
Hit:5 http://dl.google.com/linux/chrome/deb stable InRelease
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up-to-date.
avon@avon-MacBookPro:~$ sudo apt upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following package was automatically installed and is no longer required:
libllvm11
Use ‘sudo apt autoremove’ to remove it.
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
avon@avon-MacBookPro:~$

I didn’t do the last command because I don’t know if the sudo upgrade has worked or not.

That looks good.
Just to tidy up first - use “autoremove” to dispose of code it no longer needs:

sudo apt autoremove

Now enter these last two commands of post #10:

sudo apt remove chrome

and

sudo apt install chrome

and post the output.

Re attachments: we trust established Members! You can attach images, too, but please reduce them first.

The macbook has died Keith, so thanks anyway. It’s gone to the white screen of death, the useless piece of junk! I have started a new thread for how to update Chrome on my Peppermint netbook.

Sorry to hear that Matilda. Better luck next time.

Keith

It’s no big deal really. It was old and my bro meant well but I think it had a dodgy hardware. Ubuntu just wasn’t working properly on it. Whilst I liked the bigger screen for videos, it was like a mirror ( so curtains had to be shut when it was sunny to see the screen otherwise it was like a mirror ), it was very heavy and it had to be plugged in because the battery was dead. It also took ages to boot up! It’s on the kitchen floor under the table until I can get it to the recycling centre.

Now my Chromebook is on its way out! It fell off the sofa and there is a slight crack in the screen, and whilst it works the touch screen keeps activating itself and enlarging the text to a huge size and wobbling about. It was on its last update so I was planning to get a brand new one in the summer ( should have the money then ) but it’s an inconvenient time to be damaged!
So thank goodness for the little Asus netbook running on Peppermint 9!