Chromium takes a while to start (Solved)

Hi,
I notice lately that Chromium is taking a little longer to start up. Is this anything to worry about ?
In Windross I would just defrag and then use CCleaner.
I have another query but will put that in another thread.

I notice lately that Chromium is taking a little longer to start up

I’m actually finding that as well, to be honest I’ve been getting a little disillusioned with Chromium lately because that’s not the only issues I’ve been having

Graeme

I was wondering if Firefox would be ok ?

I was wondering if Firefox would be ok ?

Nothing wrong with Firefox in fact I’m using it now and finding it faster especially with Flash, no harm installing it and giving it a try, but you’ll need to keep Chromium on your system if you have any SSB’s (ICE Applications) they won’t work with Firefox

Good luck

Graeme

Oddly, Chrome (at least the downgraded version as instructed on the Peppermint forum) starts much faster than Chromium (latest version) … and it can work with Ice too (on Peppermint 5).

That’s exactly my setup … I use Firefox for everyday browsing, and have Chrome (34, pre-Aura) for any SSB’s I create.

Thanks Mark,
I will see what I can disturb with these ideas. :wink:

Hi Mark,
I have successfully downloaded and installed the 64 bit version of Google Chrome.When I check the version number it shows 34.0.1847.137 (Official Build 268882).
When I check in and run Google Chrome it shows the toolbar with some rather outdated sites (stuff I haven’t used for years) so I will have to get rid of some of them, but oddly it doesn’t have a link for linux.co.uk :-[. I have run the command to stop updating and I am happy with that.

Before I start the next sequence of commands regarding the Chromium Web Browser, can I say that I have Chromium starters in the Main Menu and Internet > Chromium Web Browser can I get rid of one of them ?

Yes … there’s a couple of ways of doing this

a) uninstall Chromium … this should get rid of menu>Internet>Chromium Web Browser … BUT, any SSB’s that were created for Chromium will stop working unless you either re-create them for Chrome, or manually edit them (we’ll get to this in a bit).

b) leave Chromium installed, but edit it’s .desktop file to hide it in the menu

Personally I’d go with (a) … but this means doing some preparatory work first … can you post the output from:

ls -a ~/.local/share/applications

As for the top level “Chromium” menu item, run:

gedit ~/.config/lxpanel/Peppermint/panels/panel

find the section that reads:-

        item {
            name=Chromium
            image=chromium-browser
            action=chromium-browser
        }

and change it to

        item {
            name=Chrome
            image=google-chrome
            action=google-chrome
        }

SAVE the file, then log off/on.

It should now have changed to Chrome, and start the Chrome browser.

Hi Mark,
Is the what you need ?
don@ldwatson ~ $ ls -a ~/.local/share/applications
. editorbypixlr.desktop flightgear.desktop googledrive.desktop mimeapps.list peppermintforum.desktop
… entanglement.desktop gmail.desktop mahjong.desktop onlineuserguide.desktop solitr.desktop
chromium-browser.desktop expressbypixlr.desktop googlecalendar.desktop mahjongg.desktop openshot.desktop
don@ldwatson ~ $
EDIT The other command gives this

don@ldwatson ~ $ gedit ~/.config/lxpanel/Peppermint/panels/panel

** (gedit:6572): WARNING **: Couldn’t connect to accessibility bus: Failed to connect to socket /tmp/dbus-1uyyolQk0i: Connection refused

** (gedit:6572): WARNING **: Could not load Gedit repository: Typelib file for namespace ‘GtkSource’, version ‘3.0’ not found

(gedit:6572): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
don@ldwatson ~ $

Ignore the terminal output from this command (those Gtk warnings are nothing to worry about) … but edit the FILE THAT OPENS when you run the command:

gedit ~/.config/lxpanel/Peppermint/panels/panel

in the way suggested.

Or are you saying a file doesn’t open ?

Hi Mark,
I ran the command again and it gave the same warning and it opens an empty panel ?

Running:

gedit ~/.config/lxpanel/Peppermint/panels/panel

should open a text file with a load of text in it … are you saying it doesn’t ?

Are you copy/pasting that command ?

Remember Linux commands ARE case sensitive … so that’s a capital “P” in Peppermint.

Hi Mark,
I have opened a terminal again and copied and pasted the command again, but it still shows a blank panel page with the cursor at line 1, col 1.

This is Peppermint 5 right ?

What’s the output from:

ls -a ~/.config/lxpanel/Peppermint/panels

This is it
don@ldwatson ~ $ ls -a ~/.config/lxpanel/Peppermint/panels
ls: cannot access /home/don/.config/lxpanel/Peppermint/panels: No such file or directory
don@ldwatson ~ $

Hmm…

What’s the outout from:

ls ~/.config/lxpanel

don@ldwatson ~ $ ls ~/.config/lxpanel
Peppermint
don@ldwatson ~ $

OK, how about:

ls ~/.config/lxpanel/Peppermint

don@ldwatson ~ $ ls ~/.config/lxpanel/Peppermint
don@ldwatson ~ $

Sommat seriously screwy here

Run

mkdir ~/.config/lxpanel/default

then

mkdir ~/.config/lxpanel/Peppermint/panels

then

cp -v /usr/share/lxpanel/profile/Peppermint/panels/panel ~/.config/lxpanel/Peppermint/panels/panel

then

cp -v /usr/share/lxpanel/profile/Peppermint/config ~/.config/lxpanel/Peppermint/config

now log off/on.

Once you’ve logged off/on … now see if

gedit ~/.config/lxpanel/Peppermint/panels/panel

opens a text fille with a load of text in it.