Computer Not Shutting Off

Hi. Not sure if this is the best place to ask this.

I’ve been trying to install an OS on an older computer and what ever I do, whether through installed or live, when I come to close down the computer, the system shuts off but the computer stays on. After that, I cannot turn it on or off with the power button - even with a hard shutdown. The only way to restart is to turn the power switch off at the back (or remove the power), turn on and then restart.

Any suggestions?


You could try the suggestions here:

Thanks SeZo. However, the computer doesn’t shut down whatever it runs. I’ve tried Linux distros, Hirens boot CD, etc. None of the OSs forced a complete shutdown.

Try the “magic SysReq” key. Holding down Ctrl and Alt, press first SysReq and then (not to quickly) REISUO and that should cleanly shut down the computer. To make sure that this is enabled, type in the terminal emulator

cat /proc/sys/kernel/sysrq

If the reply is not 1, then use the command

echo 1 > /proc/sys/kernel/sysrq

Sorry I’m probably not making myself clear: the system completely shuts down except for the power light and the fan (and possibly other things I’m not aware of). I cannot do anything with any peripheral at all - including the power button. The only thing that works is the power switch at the back - completely shutting power off.


Is this a very new computer, especially a gaming type? The reason I ask is that I recently built a fancy desktop system for a friend that had all sorts of fancy lights on the mother-board (I wasn’t expecting that!) which stayed on until I used the switch at the back - just like yours. The computer itself certainly switched off.


No, Keith. The unit is a standard shop bought one probably around eight to ten years old. The mother board light remains on, as do the fans. Nothing else is active.

I don’t know if these things use a latching relay or a triac, but it looks like the latching device driver (just a transistor) is not operating. That would certainly account for the behaviour as switching off the mains switch would automatically unlatch the power device.

I must admit that I don’t usually switch off the PSU at the back of the PC, but it’s no hardship I guess. I doubt that there is a safety issue except that leaving the PSU on all the time would not be a good idea.


Is there an easy fix for it (mechanical, not software)?

I doubt it, Matt. It’s probably a semiconductor switch buried inside a chip somewhere. Gone are the days of discrete devices. Sigh!

OK. No problem. Thanks for your help.

Hi Matt

When my system stopped shutting down from the buttons I used the command “shutdown now” and also “poweroff now” in the terminal.
What response do these commands show?


You don’t mention which distro you are trying to install. :wink: Is the computer ex-Windows and does it still have Windows on it or have you successfully installed Linux?

At one point I was using live CDs of Hiren’s Recovery Boot CD and at least two other Linux distros - this, without having a HDD attached at all, in order to see if it was the HDD that was causing the problem. So, the answer is really that I had, at one time, no installed OS on the computer. The original OS, I believe, was Win XP. (I booted Hiren’s (x86) up with both the Mini XP and the Linux recovery. Neither solved the problem.)

And the computer? Make, model, specs etc?