Core Dumps

Hi

I am getting segmentation fault error but no core dump file is generated on a server i am just supporting with no access to source code, it is running Linux 2.6.9-89.0.25.ELsmp x86_64 GNU/Linux

ulimit for coredumps is set to unlimited, value of /proc/sys/kernel/suid_dumpable is set to 1 and a special directory with RWX permission to everyone is specified in kernel.core_pattern but still no core dumps are being generated when the process is crashed.

The strange thing is i did get a core dump file for another process when it crashed but no core files for this specific process which crashes quite regularly.

Can anybody help me in this.

Have you tried to manually force a core dump with:

kill -6
or
kill -11

Can you provide further info such as the distro/version… and more info on the process/app that’s causing the segfault… also is it a SUID app?

I know you’ve covered most of this, but can you also post the output from:

ulimit -Sc

and

ulimit -Hc

and

cat /proc/sys/kernel/core_pattern

and

cat /proc/sys/kernel/core_uses_pid

and

cat /proc/sys/kernel/suid_dumpable

and

cat /etc/profile | grep ulimit

and

cat /etc/init.d/functions | grep ulimit

and

cat /etc/sysctl.conf | grep kernel

and

cat /etc/security/limits.conf | grep core

depending on the distro/version, some of the above may return nothing, or “No such file or directory”.