Creating a wireless network in Ubuntu V11.10 - Solved

I am running Ubuntu V11.10 and, after a few glitches sorted out with help from this forum, I am very happy with it since discovering that I can run it in Classic View.
My next task is to set up a wireless network. My only experience of trying this in XP was disastrous so I am starting by asking for advice, having searched the Forum on the subject.
My goal is to have my desktop wired to a router/modem (one device or a pair) and have a laptop (also Ubuntu) and printer connected wirelessly.
Whilst Ubuntu is great at interacting with whatever device I plug into it, I want to be sure that I buy the “best” wireless adapter and router/modem combination for my purpose without getting out of my depth. I found a web-page somewhere that recommended the Thomson SpeedTouch 546 or Belkin N1 for Linux.
So: which device(s) would Forum users recommend (and why) and what advice would they offer a wireless novice in setting up such a system?
My PC is ?? without a wireless adapter. The laptop is a Dell Latitude D505 and the printer is an HP 7200 series, to be replaced with an Epson PX720WD when I give the system away to a friend. I note Topic post 9844.0 on the subject of wireless printers.
Oh, and a Happy New Year to all my readers.

It depends what you want from your network.

Wireless adapter … do you need Wireless “N” speeds, or will Wireless “G” do ? … ie. are you likely to need to transfer large files between PC’s on the network ?

Router … do you need any extra functionality over and above a “standard” router … ie. gigabit ethernet ports, or the ability to add a USB hard drive and share it as a NAS drive, etc.

I take it this is for an ADSL line and not a Virgin cable connection ?

then there’s how pretty do you want the router to be … purely functional, or pretty too :wink:

According to this:
http://www.dell.com/downloads/us/products/latit/d505_spec.pdf

The Dell D505 has wireless built in … so what is the wireless adapter you want for ?

or is that pdf (or me) wrong ?

According to this:
http://www.dell.com/downloads/us/products/latit/d505_spec.pdf
The Dell D505 has wireless built in … so what is the wireless adapter you want for ?
Oh that’s good. I didn’t realise it was wireless! For now, I don’t need the desktop to be wireless, which probably simplifies everything.

OK, for supported wireless adapters … see here:
https://help.ubuntu.com/community/WifiDocs/WirelessCardsSupported

Routers are less important, as long as they support the same standard, or unless you are after easy of setup or specific functionality.

I quite like the look of this wireless “N” adapter:
http://www.amazon.co.uk/TP-Link-TL-WN822N-300MBPS-Wireless-Adapter/dp/B003VIY03Q/ref=sr_1_1?ie=UTF8&qid=1325708663&sr=8-1
and as you can see (further down the page), you can get it with a 300mbps router by the same manufacturer fo just over £50

I must admit I haven’t personally used either of those, but according to this:
https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsTP-Link
(penultimate entry) … it works “out of the box” with later versions of Ubuntu

also here:
http://www.geekzone.co.nz/forums.asp?forumid=46&topicid=88323

Thanks, Mark.
The TP-Link units look good, and though I’m not in desperate need of a wireless adapter, I think I’ll have a go anyway. The “works out of the box with V11.10” recommendation for the adapter is encouraging, and I am hoping this will be true for the router as well.
I shall order them and report back - then I may need advice getting peripherals such as a printer to work wirelessly. But one thing at a time!

One other thing: the router is described as “for BT connections”. What might that mean? Does it refer to the plug type (I thought they were all the same) or to some characteristic of BT lines?

A router is not OS specific … they should work with all OS’s

I’m guessing “for BT connections” means ADSL (down the phone line internet) rather than a cable modem/router for something like a Virgin cable connection.

The kit arrived.
Although I don’t need a wireless connection between router and PC (only router to laptop and printer) I bought one anyway just to try it.
I followed the instructions and used data from the old modem but nothing is working after meddling for most of the day.

It does seem to connect to a BT server, but the server objects in an unusual way, as shown in the notes.

I would be really grateful if someone with experience of setting up a wireless system with Ubuntu would help me out, and I attach a 3-page file of the set-up data I’ve used, and the results of the final test.

Many thanks in anticipation.

Why did you use data from old modem?

You mention BT are they your broad band provider? If so why do you not have a Home Hub.

I remember all sorts of problems with BT but I have used cable for the last 12 years.

You say nothing is working but how did you post this.

Is it that the wireless is not working and that computers connected by cable are OK.

What operating system are you using on the laptop.

It would have been helpful if I had summarised the situation in my previous post so that contributors wouldn’t have to trawl the whole conversation. But first to answer your questions:

  1. The old modem contained useful data such as the Virtual Path and Virtual Channel Identifiers that are standard for the UK, and other data, so it seemed a good idea to use those.
  2. BT is indeed my ISP, but I discarded their home hub eight years ago as it was a pain to use and my computer was filled with useless Yahoo software. Their Help Centre is in India and although they try hard, communication is difficult. We don’t have cable or fibre here; just very slow and unreliable telephone lines for broadband.
  3. How did I post this? By using the old modem of course! It’s a Thomson SpeedTouch 510 V6 and it worked just by plugging it in!
  4. Let’s forget the laptop and wireless connectivity for now and address one problem at a time by getting the router/modem speaking to my ISP.

My new router is a TP-Link TD-W8960N Wireless ADSL2 Modem Router.
It is connected by wire (when trying to fix it) and I have reported all the data and test results in the link two posts ago -
http://linuxforums.org.uk/index.php?action=dlattach;topic=9845.0;attach=1848.
Thank you for taking an interest – I would be grateful for any advice.

Do you have a windows pc that you can connect by wire to the new router modem.

Then you can set up the modem using windows software.

The information you posted seems to show that the WAN is connected the issue seems to be with the LAN have you tried setting up the LAN using your web browser.

I found the problem.
The router setup asks for my user-name (as specified by my ISP). Normally this is the bit before the “@btinternet.com”. But what the new router needed was the complete address, including the “@btinternet.com”. I now have internet access with a wired connection between the router and the PC.
I shall persevere with the wireless connection and report back.
My thanks for your advice so far.

Problems all solved

TP-Link TD-W8960N Wireless n ADSL2+ Modem Router
The initial problem was due to me using (from previous experience) as a user-name that part of my email address before the “@”. It appears that “user-name” now means the complete email address, and is needed when setting up the router. It then worked flawlessly.
But then I crashed it by me meddling with the set-up whilst trying to get the TP-Link Wireless Adapter to work. The Device MAC Address and Cloned MAC Address had become swapped – reversing them got me back on line on a wired connection.

TP-Link TL-WN822N Wireless Adapter
This device worked for a few minutes then stopped. Testing it next day on an XP and two Windows 7 machines showed no response, so I have returned it to Amazon.

EDUP EP-N8508 Micro Wireless Adapter (802.11n)
I happened to have one lying around. It’s about the size of a USB plug. Plugging it in had no response, but trying another USB port was successful. My Linux PC found it and connected in seconds and I now have a wireless connection.

Laptop Dell Latitude D505 (wireless)
It has Ubuntu 10.4 loaded, connected immediately to the network and works at considerable distances.

Summary
The TP-Link router is very good, though I hope it lasts longer than the TP-Link adapter.
The EDUP micro wireless adapter cost £10, works very well and does not take up any real estate.
If one USB port doesn’t work: try another!
Overall: had it not been for the faulty TP-Link adapter, the creation of a network in Ubuntu 11.10 would have been a breeze.
My thanks to all contributors.

Glad you got it all working, and sorry I couldn’t respond earlier … moving home and it’s taking forever to get a phone line installed :frowning: … currently using an O2 dongle that’s as slow as … well … a really slow thing.
(Vista in half a gig RAM springs to mind).

Just as a rider: My mate is running Vista on 0.5GB RAM and keeps asking me for advice.
My advice every time is to upgrade to Linux. He’s weakening! :wink:

Keith

Jesus H Christ … Vista in half gig RAM … no wonder he’s screaming for help :o

I’m surprised it runs at all :wink: