Dazzle DVC 100 & TvTime in Natty. (Resolved, finally)

@Mark - It is a V4L2, but there’s just something funny in the way it captures sound. Don’t ask me, I’ve no clue. You probably can capture through cheese, but I personally wouldn’t recommend it.

Maybe worth asking SeZo what settings he used in VLC ? … if he can remember.

Perhaps. He’ll probably see your post anyway.

Sorry guys. The last time I used it was around the time Mageia 1 was released.
Unfortunately the laptop was wiped a few times since then.
You know, trying new distros.
I will see what I can dig up. Usually keep some notes.

I’m wanting to get a Hauppage HD PVR, but I think Linux doesn’t support it fully yet, so I may wait.

Finally got around to look at my notes. I was actually wrong about how the audio was captured.

I used this to capture from sky+ using Dazzle DVC101

Here it is how it works now:
First find out the video:

$ dmesg | grep video [ 0.340087] pci 0000:01:05.0: Boot video device [ 5.610232] [drm] S-video [ 207.259557] Linux video capture interface: v2.00 [ 209.608233] em28xx #0: V4L2 video device registered as [b]video0[/b]
Then the audio:
$ arecord -l **** List of CAPTURE Hardware Devices **** card 1: [b]DVC100[/b] [DVC100], device 0: USB Audio [USB Audio] Subdevices: 1/1 Subdevice #0: subdevice #0
Video inputs (I am using S-Video):
$ v4l2-ctl --list-inputs ioctl: VIDIOC_ENUMINPUT Input : 0 Name : Composite1 ------------------------ Input : [b]1[/b] Name : S-Video
Make sure audio is not muted:
$ v4l2-ctl -C mute mute: 1 $ v4l2-ctl -c mute=0
VLC settings Media->Stream->Capture Device:
Capture mode = Video for Linux 2
Video device name = /dev/video0
Audio device name = plughw:DVC100
Video standard = PAL B/G

->Show more options:
MRL = v4l2:///dev/video0
Edit Options:

 :v4l2-standard=PAL_BG :input-slave=alsa://plughw:DVC100 :v4l2-input=1 :v4l2-width=720 :v4l2-height=576 :live-caching=300

->Stream->Destination setup-File->Add:
/home//Video/test.avi

->Transcoding options->Profile:
If required (or just selct from pre-built):
->Create new profile
Name = Video - AVI
Encapsulation = AVI
->Video codec
Video (tick)
Codec = MPEG-4
Bitrate = 8000 kb/s
->Audio codec
-Audio (tick)
-Keep original audio track (tick)
-Save
->Transcoding options->Profile:
Select profile Video - AVI

–>Stream

Of course you might have different requrements.