dead screen on AAO 150

My friend has an AAO 150 ZG5 08/2008 XP with a completely dead display- I’m going to try to fix it w my vast expertise (ha ha). It starts up and battery charge light works,
but not HD light. Besides a bad cable or connector (we hope), what else could this be- blown controller or video adapter (where is that and replaceable)??
Would a display without any apparent damage just fail? Any diagnostic tips?

I made the Pepperment2 stick w Linux Live- MD5 sum matched orig file- all seemed to go well, but hung on boot w boot option 2 (USB dev). Does loading of that involve long no HD light
operation, or is boot option 3: PCI network, the correct option for a USB stick boot? Seem to remember that from Linpus OS reload.

I can’t even search in the file manager. Know installation instructions for a decent file manager for Linpus (total Commander?)?

I take it you mean AOA 150 not AAO 150 ?

If the screen is undamaged, and you’re not seeing the BIOS screen when you turn on the AA1, it sounds like a BIOS failure (corrupt BIOS) … happened on this AA1 too … Luckily the Acer Aspire One has a built-in BIOS recovery routine.

Things you’ll need -

A USB stick … now I must mention this didn’t work with my 8GB stick, but it DID work with an older 256MB stick I had (probably because it was formatted as FAT rather than FAT32) so format your stick as FAT not FAT32.

and the latest BIOS update from the Acer website … go here:

and select
Netbook > Aspire One > AOA150
click the BIOS tab, and download the 3310 BIOS.

OK, now to put it on the USB stick, and flash the BIOS

1.) Make sure the stick is formatted as FAT not FAT32
2.) Unpack the BIOS_Acer_3310_A_AOA110 & file you just downloaded
3.) put the FLASHIT.EXE and 3310.fd files (from the Dos_Flash directory) on the root of USB stick (NOT in a folder)
4.) Rename the 3310.fd file to ZG5IA32.FD ← this is important.
5.) Turn the AA1 off, and make sure both the battery and AC adapter are plugged in.
6.) Make sure the USB stick is plugged in (I used the righ-hand front USB port, but I don’t think it matters)
7.) Hold the Fn and Esc and whilst holding them, press the power button.
8.) Release the Fn and Esc keys after about 5 seconds … the power button should start to flash.

The AA1 should now access the files on the USB stick and re-flash the BIOS.

WAIT for it to do its thing … after a short while the power button will stop flashing and the AA1 will reboot.

Hopefully, you’re now fixed.

After a while the power button stops blinking, and the AA1 reboots by itself. Wait patiently.

If it doesn’t reboot, and the power button keeps flashing, wait at least a few minutes before turning it off, and trying again.

Well Acer Aspire One is AAO, n’est pas?

Really, you don’t think it’s more likely a bad cable- flashing BIOS is scary- but that would lead to a dead screen? It shows no Bios, no flash of light, no nothing.

Have you tried plugging in an external monitor… Have you got the operating manual and a parts diagram you will need one if you are going to start looking for cables.

Thanks. No, but thats logical, and should have thought of that- obvious first diagnostic. Have to hunt down the ext video cable. I tore apart my 110 and know where the cable is- this is indentical except for the HD, I think. My testing will basicly disconnect reconnect the display cable plug/connector and move it around to see if it makes intermittent contact. If I wanted to tear mine apart (NO!!)- I could connect my screen to his NB and get an instant definitive answer to whats the source pf problem.

It is also, like mine a Ukrainian version, with Cyrillic also on keyboard. Would that take a GB BIOS, or are there Russian/Ukr versions? No bios was all English- think the keyboard control is on XP or Linpus (XP Home Russian ULCPC, AOA 150-Bb , SNID 835 1039 1825)- mine (110 ZG5 Linpus) had a Pinyan thing on taskbar that kept changing into Chinese when pressed wrong key combo, till found it and deactivated. Friend said I should shine light on it to see if there was any picture (but illumination failed), but it is jet-black. Figure I must try external monitor before more radical steps- F5. What are the steps for the Erecovery zip (9.6meg)- I know only from the CD. Obviously simpler to just do Bios, but the E-recovery also does Bios + everything else, right? What did you do to corrupt Bios, I accidentally did some Synaptic monster installation of entire folder of 131 programs. Man, that renaming of the Bios file is ah, a little insanely specific and counterintuative- where did you get that from?

Again Mark, did that Bios corruption render the screen totally inoperative, no light at all? Wouldn’t it at least flash a little in starting up? You don’t have to do anything to make USB bootable, just dump those 2 files on it? That bios is specifically an XP one, right, LINPUS (which they didn’t offer) would be different? Wasn’t aware they had an XP 110.

Yup totally dead screen … nothing.

Ukranian BIOS… hmm you’d probably be best seeing if there is one online, or email Acer … as I’m not 100% sure … is YOUR bios in Ukranian ?

Nope, nothing except put those 2 files on the FAT stick and rename the 3310.fd file to EXACTLY the name above.

there is NOT a specific “XP” or “Linux” BIOS … the BIOS is nothing to do with the OS … the BIOS is for the AOA150 hardware

OK, AFAIK the keyboard drivers you mention are part of the OS not the BIOS … certainly if you can change them in the OS, they are part of the OS.
(at least a simplified set of keyboard drivers MUST be hard-wired into the system, or it wouldn’t understand the Fn+Esc key presses :wink: )

What I did to corrupt the BIOS, not sure, according to a million online sources just shutting down sometimes causes it … it’s just a well know issue with the AA1’s.

The renaming of the BIOS binary is because the “in-built” BIOS recovery routine ONLY looks for a file with that EXACT name … it wouldn’t be possible to include DOS on the USB stick, and use the BAT file and original name for the binary, because the BIOS is broken and the AA1 doesn’t understand DOS (or indeed what a USB stick is) without the BIOS.

The built-in BIOS recovery must be a simplified DOS emulator (in its own right) that when run looks for a FAT USB drive, then can ONLY run Flashit.exe, and ONLY look for a binary file with that EXACT name.

Think of the in-built BIOS recovery routine as … DOS on a (non-volatile) chip, that when called by the Fn+Esc keys at startup, contains a batch file that looks for a FAT16 USB stick, and if found, looks for and (if present) runs Flashit.exe, and points it at a binary called ZG5IA32.FD for flashing to the BIOS.

So you MUST use that EXACT name, and use the in-built BIOS recovery routine.

Make sense ?

eRecovery CANNOT also flash the BIOS … the eRecovery image AFAIK is contained on the HDD/SSD which cannot be accessed until after the BIOS has initialised the drive.

Worked like a charm- you are God, or maybe I am, since I brought the dead back to life. And saved ripping apart beast unnecessarily.

Best thing is this is identical BIOS for 110 and 150 (or is it ONLY for XP?). Is there a different BIOS for Linpus??? Very important.

I DID NOT PRESS the power button again after releasing Func-Esc. That apparently is not necessary, and some posts on another site say it might interfere.

Here is a video on it by a 12 yo Brit boy or girl.

The Acer site seems to suggest it’s the same BIOS binary … but just to be sure, select AOA110 instead of AOA150 on their site.

Good news is even if you get it wrong, the in-built BIOS recovery routine should save you.

The BIOS (and therefore the binary) is OS independent, so will be the same for ANY OS … the BIOS’s job is ONLY to initialise the hardware, then look for a bootloader on a specific part of the HDD, load it, and pass control to it … so the BIOS’s job is finished before the OS is loaded.

I’ve also removed the step concerning the extra power button press from the original instructions.

The file actually say 110-150 so guess its the same. How does that relate to the E-recovery download (9.6meg)- that’s the equivalent to the ACer CD recovery disk that I transferred to USB to reload whole OS?

OK, at 9.6MB it’s NOT going to contain the whole OS :wink: … instead the AA1’s with XP preloaded have a hard drive (rather than SSD) that contains a separate hidden partition that contains an eRecovery image of the hard drive.

No doubt that USB just allows access to it … AFAIK, so does pressing F9 at bootup.

yes, of course. So would pressing F9 at startup reload Bios too?

Nope, because it cannot access the hard drive with a messed up BIOS … so why would they put it there.