Desktop terminal window always asks for a password

I am running Gentoo Linux with XFCE4 as my desktop environment. I have roughly the same setup on my desktop and laptop. On my desktop, whenever I open a terminal window from within the desktop environment (I tried the default terminal and xterm), it asks for my password before I can use the terminal. This doesn’t happen on the laptop, but I don’t know what I did to stop it.

Why does the terminal ask me for my password? Is there anything I can do to stop it? (And, indeed, should I want to stop it?)

Does the terminal that asks for a password, open with a root prompt (#) rather than a user prompt ($) ?

It’s just a regular user terminal. However, I’ve solved the problem now. I checked my .bashrc file, and as it happened it contained the line

sudo visudo

Not quite sure how it got in there, but I probably did it by accident when I was really new to Gentoo and following various, and often bad, tutorials. Thanks for your time :slight_smile: