DOCKY weather app works after suspend? (Resolved)

I am using mint 13 64bit and the DOCKY weather app has not worked for sometime now.

I noticed that after I resumed from suspend the app started working with no problems.

Investigation showed that this was due to the internet connection closing during suspend and then resuming.

So I tested this after a normal boot up the app did not work so I disabled networking and then re-enabled networking and the app started working.

Anyone got any clues as to why the app dose not work after a normal boot but starts if the internet connection is turned off and then on?

As always thanks in advance…

Perhaps weather app starts up before the network connection is estabilished.
Try to delay the start up of the app by a few seconds.

Sounds possible any one know how to delay the app from starting…?

Delay the docky autostart

Can you post the output from:

ls -a ~/.config/autostart

userone@office2 ~ $ ls -a ~/.config/autostart
. indicator-weather.desktop
… mate-at-session.desktop
cameramonitor.desktop mintupload.desktop
docky.desktop mintwelcome.desktop
dropbox.desktop my-weather-indicator-autostart.desktop
userone@office2 ~ $

OK, run:

gedit ~/.config/autostart/docky.desktop

find the line that reads:-


and change it to

Exec=bash -c “sleep 20 ; docky”

SAVE the file, and log off/on (or reboot) to test.

The above “Exec=” line will introduce a 20 second delay before docky is started … you may need to play with that figure to find the ideal for your system :wink:

Thanks will try it out…

OK changed the timing a number of times still not working.

So returned to normal…

Is there a way to get the network connection to start after Docky?

Was docky starting after a delay ? … or did changing that line not introduce a delay ?

The line works fine and DOCKY is delayed starting…I tried delays between 10 to 45 secs.

This delay makes no difference investigation shows that the issue is that the internet is connected before DOCKY starts.

If I disconnect the cable and start the computer and when booting is finished I connect the cable the app starts once the internet connection is made.

Thus I need the internet connection to start after DOCKY.

I don’t think that’s right … networking is supposed to come up before docky, otherwise how could it get any weather info ?

I suppose we could write a script that disables wifi, then re-enables it, and autostart that.

But first, have you tried just purging/reinstalling docky ?

sudo apt-get remove --purge docky


sudo apt-get autoremove


sudo apt-get install docky

then log off/on (or reboot to test

It is not an issue with the DOCKY installation the same thing happens with my clean new instillation on mint 17 64bit on my laptop.

Again the app dose not work from a normal boot but if I unplug the internet whilst booting and then connect after booting is finished the app starts.

The connection to the internet on both computers is via cable.

OK, what happens if you boot with the internet cable connected (so docky isn’t working)

then run these 2 commands to disable networking, then re-enable it:

nmcli nm enable false


nmcli nm enable true

does the weather thingy work now ?

If so, I suppose we can author an autostart item that runs those 2 commands.

Yes that dose the trick after enter these commands the weather app starts working.

OK, try this … run:

gedit ~/.config/autostart/network-restart.desktop

when a blank file opens, make it read:-

[Desktop Entry]
Name=Network Restart
Comment=to fix Docky weather app
Exec=bash -c "sleep 20 ; nmcli nm enable false && nmcli nm enable true"

SAVE the file and exit gedit.

Log off/on (or reboot) to test.

again, you can adjust the “sleep 20” if you wish/need.

worked like a dream so will mark as resolved.

Thanks again.

You’re welcome … thanks for marking the topic solved :slight_smile: