Domain Name Does Not Pointing To Installed Java WebApplication In parallel plesk

I have installed One Java Web Application via Plesk 11.0.4 on my server. Now I want My domain name to point my web Application. My address ‘www.domain.com’ shows blank page. As I installed my Application via plesk , I can Access it on ‘www.domain.com:9080/webapp’ address. But I want to access my web application from my domain name Like www.domain.com will access my application. My webapp application’s root path is : ‘/usr/share/tomcat6/work/Catalina/PSA/webapp’

You might want to try the virtual route by using Virtual_host and mod_proxy together
(You need to install the Apache httpd web server)
Point the ProxyPass and ProxyPassReverse to the web app
Server configuration httpd.conf

<VirtualHost *:80>
  ServerName domain.com

  ProxyRequests Off
  ProxyPreserveHost On

  <Proxy *>
    Order deny,allow
    Allow from all
  </Proxy>

  ProxyPass /webapp http://domain.com:9080/webapp
  ProxyPassReverse /webapp http://domain.com:9080/webapp
</VirtualHost>

Some examples here
http://httpd.apache.org/docs/2.0/vhosts/examples.html#proxy

I have Web Apache Server on my server… but i need to stop it to run tomcat…

BUT AFTER UPDATING MY HTTPD.CONF I GOT ERROR : Unable to make action: Unable to manage service by apache_control_adapter: Service /etc/init.d/httpd failed to start
Service /etc/init.d/httpd failed to start (‘–start’, ‘web’)

Did you adjust it to suit your situation?
Also you might need to add the following to your Apache httpd.conf:
Put this after the other LoadModule directives

LoadModule proxy_module /usr/lib/apache2/modules/mod_proxy.so
LoadModule proxy_http_module /usr/lib/apache2/modules/mod_proxy_http.so

Try to re start Apache:

/etc/init.d/httpd restart

then

/usr/sbin/apachectl restart

Check /var/log/httpd/error_log for startup errors

Hello Guys… I solved This problem … !

Actually I got two services in my server.xml ONE is is using port 8080, and Second Is is using port 9080. I Added ProxyPass=“80” in <Connector port=“9080” maxThreads=“15” minSpareThreads=“5” maxSpareThreads=“75” enableLookups=“true” acceptCount=“10” connectionTimeout=“20000” disableUploadTimeout=“true” proxyPort=“80”/> ;D ;D ;D ;D …

My Next step was to update my Worker.Properties according to http://geonetwork.tv/domain/ and httpd.conf for proxy to my service PSA I Updated my httpd.conf file as follows
[b]
NameVirtualHost *:80

<VirtualHost *:80>
ServerName www.domain.com
ServerAlias domain.com *.domain.com
ProxyRequests off
ProxyPreserveHost on
<Proxy *>
Order deny,allow
Allow from all

    DocumentRoot /usr/share/tomcat6/psa-webapps/domain.com/
    ProxyPass /usr/share/tomcat6/psa-webappsdomain.com/  ajp://www.domain.com:9080/mywebapp
    ProxyPassReverse /usr/share/tomcat6/psa-webapps/domain.com/   ajp://www.domain.com:9080/mywebapp
    JkMount /* ajp13_worker1   ///// [i] where ajp13_worker1 is property in my worker.properties. [/i]
/[b]

The above solutions solved my proble of remving my port number and made tomcat to work free on port 80 . but I was only able to access my webaap from address www.domain.com/webapp … But I want to access my web App from www.domain.com or domain.com . NOw as parallel plesk make httpdocs as default directory for every domain and webspace. So I changed my index.html default file to route my default domain to url ref: Parallels Forums so i changed my url to url =“/webapp”; and all problems are solved…

Happy to hear you solved it … thanks for posting the solution :slight_smile: