DraftSight help needed (Solved)

Hi All,
I have been having problems with my installation of DraftSight. Today I downloaded the latest debi upgrade.
Should I delete the existing programme and do a fresh install with the Debi package.

take care
Don W

That depends on what problems you are trying to solve.
What is your current version?

Hi SeZo,
The version I am using is 2015.3.0.3019 and I think I installed it from Software Manager.
I have been having problems with the ‘Home’ box doing some very strange things, and now the ‘Command Line’ doesn’t work.

I downloaded the Gdebi update yesterday, it is version 2015.3.0.3020 and was wondering if I could completely remove the version on my computer and install the update. I am asking about removing the existing version as I don’t want anything lying about that may interfere with a fresh install. Is this feasible ?
EDIT I have just had a look at the programme and the ‘Command Line’ doesn’t work properly and when I shut the programme down the ‘Command Line’ is a zombie box and I had to reboot ?

You can completely remove draftsight:

sudo dpkg -l | grep draftsight

this should return

ii  draftsight                               2015.3.0.3019

then uninstall (You will loose any user preferences you set)

sudo apt-get remove --purge draftsight

after that you can install the fresh copy.

Hi SeZo,
I have carried out those instructions and get this

don@ldwatson ~ $ sudo apt-get remove --purge draftsight
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
libmate-panel-applet-4-1 libunique-1.0-0 linux-headers-3.16.0-49
linux-headers-3.16.0-49-generic linux-headers-3.16.0-51
linux-headers-3.16.0-51-generic linux-headers-3.16.0-52
linux-headers-3.16.0-52-generic linux-headers-3.16.0-53
linux-headers-3.16.0-53-generic linux-headers-3.16.0-55
linux-headers-3.16.0-55-generic linux-headers-3.16.0-56
linux-headers-3.16.0-56-generic linux-image-3.16.0-49-generic
linux-image-3.16.0-51-generic linux-image-3.16.0-52-generic
linux-image-3.16.0-53-generic linux-image-3.16.0-55-generic
linux-image-3.16.0-56-generic linux-image-extra-3.16.0-49-generic
linux-image-extra-3.16.0-51-generic linux-image-extra-3.16.0-52-generic
linux-image-extra-3.16.0-53-generic linux-image-extra-3.16.0-55-generic
linux-image-extra-3.16.0-56-generic mate-power-manager-common
Use ‘apt-get autoremove’ to remove them.
The following packages will be REMOVED
draftsight*
0 to upgrade, 0 to newly install, 1 to remove and 0 not to upgrade.
After this operation, 415 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database … 478986 files and directories currently installed.)
Removing draftsight (2015.3.0.3019) …
dpkg: warning: while removing draftsight, directory ‘/opt/dassault-systemes/DraftSight/Libraries’ not empty so not removed
dpkg: warning: while removing draftsight, directory ‘/var/opt/dassault-systemes/draftsight/settings’ not empty so not removed
don@ldwatson ~ $

When I try the autoremove I get this
don@ldwatson ~ $ apt-get autoremove
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
Have I created a problem ? Or can I just double click the Deb package and install the upgrade ?

The autoremove command should be run as root (sudo)
Before you install draftsight again have a look at the contents of the folder
/var/opt/dassault-systemes/draftsight/settings and remove any file that exists.

Then install draftsight.

Sorry about that SeZo :-[ I have been playing with the new install and got carried away with everything working as it should (at the moment).
I ran the autoremove and was glad I didn’t have to do that manually, there seemed to be pages of stuff.
I have also deleted the Dassault Systemes folder and installed the latest version of DraftSight from the .deb package.
It seems to work a treat at the moment so I will draw out the flywheel I want and let you know what happens.
I have downloaded the Manual (whassatt ?) and will set up what I need from that.
Thanks for the help, I will probably be back.

take care
Don W

Personally I’d remove those 2 “dassault-systemes” folders and their contents

cd /opt

then

sudo rm -rfv dassault-systemes

then

cd /var/opt

then

sudo rm -rfv dassault-systemes

then run autoremove with elevated privileges

sudo apt-get autoremove

I have done that Mark,
I have a problem with the last drawing I done.
When I open it I am shown a blank screen and the mouse takes years to move.
I’ve done something wrong and will have a look on the DraftSight forum for some answer ?
EDIT I have had a look on the DraftSight forum and they seem to be backed up with complaints of mouse lag.
Will have another go tomorrow
RE-EDIT I have had another look and it is only this drawing I am having problems with. I will send it to the rubbish bin and start again

Hi,
I have deleted the offending drawing and have been working away all day on various new drawings.
Everything is working as it should so I will mark this solved.
Thanks all for your help.

Great stuff :slight_smile: