Dual-Booting MINT with Windows 8

Hi, I have an ASUS g75vw that runs Windows 8. I downloaded the Linux Mint 14 - Cinnamon .iso and ran a checksum – the MD5 matched, so the download was good. I then burned the iso to a DVD.

I disabled SecureBoot in my UEFI settings, disabled Fast Boot, enabled CSM and then enabled Legacy opROM. I can’t get the Mint installer to initialize on boot. I go to Settings → Change PC Settings → General → Advanced Settings (Restart) and then the Troubleshooting tab to initialize my UEFI Settings Configuration.

What am I doing wrong? I would like to be able to eventually Dual Boot Mint and Windows 8.

So are you saying it won’t boot the LiveDVD to a Live desktop session … or that it won’t install ?