Dual Monitors under Peppermint 6 (solved)

Hi Folks,

So, i had been running dual monitors for a while under Ubuntu Gnome 14.04, and then switched to P6. I’m also running this on my laptop, so it makes things easier, with my poor eyesight, and in the tramadol induced haze that I seem to be in.

So, I installed ARandR, and long story short it works, almost perfectly… 2 issues remain and I can’t seem to get my head round either

  1. Despite saving the (config) file from the ARandR GUI, there is no persistence, not even across logout and login… I guess I am doing something wrong !

  2. monitor 1 has the entire desktop space on it - scrolling to the RHS of the screen causes the screen to roll to the right, and then the 2nd monitor just shows the same as the first… which makes the 2nd monitor a bit pointless. thus, if its possible, I could do with some help sorting this out please.

The hardware is the same as worked under 14.04. I’ve forgotten how to identify same but the extra graphics card is an Nvidia geforce 210, with the monitor connected by DVI at 1920 X 1080. primary monitor is running off the (Zoostorm i7 ) internal graphics at the same res., also connected by DVI.

Thanks in advance

ATB

Sim

first in ARandR you need to place the monitors side by side, not on top of each other before hitting apply.

Once you’ve figured that part out and have it working how you want … save the settings, then post the contents of the saved settings file.

Thanks for the reply. Have placed them numerous times ::slight_smile: :cry:

Haven’t managed to get beyond problem 2, outlined above, and I don’t know why ???

here’s the content of the screenlayout file:-

#!/bin/sh
xrandr --output HDMI1 --mode 1920x1080 --pos 1920x0 --rotate normal --output VGA1 --off --output VIRTUAL1 --off --output DVI-I-0 --mode 1920x1080 --pos 0x0 --rotate normal --output HDMI-0 --off

TIA :slight_smile:

Well I can tell you how to apply those settings at boot, but if they’re not right there’s little point is there ?

Okay which graphics card(s) do you have … can you post the output from:

inxi -F

and

xrandr

and we’ll see if we can figure out how to disable panning in screen1

Panning !!! Thanks for reminding what the problem is called. -I’ve been racking my brains trying to remember >:(

sim@OCC ~ $ inxi -F
System: Host: OCC Kernel: 3.16.0-71-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Six
Machine: Mobo: Gigabyte model: H81M-DS2V version: x.x Bios: American Megatrends version: F2 date: 01/20/2014
CPU: Quad core Intel Core i7-4790 CPU (-HT-MCP-) cache: 8192 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
Clock Speeds: 1: 3915.703 MHz 2: 1057.500 MHz 3: 913.218 MHz 4: 1693.265 MHz 5: 3960.562 MHz 6: 3977.296 MHz 7: 3995.859 MHz 8: 3993.750 MHz
Graphics: Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
Card-2: NVIDIA GT218 [GeForce 210]
X.Org: 1.16.0 drivers: nvidia,intel Resolution: 1920x1080@60.0hz, 1920x1080@60.0hz
GLX Renderer: GeForce 210/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.96
Audio: Card-1: Intel 8 Series/C220 Series High Definition Audio Controller driver: snd_hda_intel
Card-2: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel
Card-3: NVIDIA High Definition Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture ver: k3.16.0-71-generic
Network: Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
IF: eth0 state: up speed: 100 Mbps duplex: full mac: 74:d4:35:e2:9c:85
Drives: HDD Total Size: 2258.5GB (4.1% used) 1: id: /dev/sda model: Samsung_SSD_850 size: 256.1GB
2: id: /dev/sdb model: WDC_WD20EZRX size: 2000.4GB 3: USB id: /dev/sdc model: Flash_Disk size: 2.0GB
Partition: ID: / size: 223G used: 59G (28%) fs: ext4 ID: swap-1 size: 12.77GB used: 0.00GB (0%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 51C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 206 Uptime: 46 min Memory: 996.8/11904.1MB Client: Shell (bash) inxi: 1.9.17

sim@OCC ~ $ xrandr
Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 8192 x 8192
DVI-I-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 521mm x 293mm panning 3840x1080+0+0
1920x1080 60.0*+
1680x1050 60.0
1440x900 59.9
1280x1024 75.0 60.0
1280x960 60.0
1280x720 60.0
1024x768 75.0 70.1 60.0
800x600 75.0 72.2 60.3 56.2
640x480 75.0 72.8 59.9
HDMI-0 disconnected (normal left inverted right x axis y axis)
VGA1 disconnected
HDMI1 connected 1920x1080+1920+0 510mm x 290mm
1920x1080 60.0*+ 50.0 59.9
1600x1200 60.0
1680x1050 59.9
1280x1024 60.0
1440x900 59.9
1280x960 60.0
1280x800 59.9
1280x720 60.0 50.0 59.9
1024x768 60.0
800x600 60.3 56.2
720x576 50.0
720x480 60.0 59.9
640x480 60.0 59.9
VIRTUAL1 disconnected
1920x1080 (0x285) 148.5MHz
h: width 1920 start 2008 end 2052 total 2200 skew 0 clock 67.5KHz
v: height 1080 start 1084 end 1089 total 1125 clock 60.0Hz
1280x1024 (0x289) 108.0MHz
h: width 1280 start 1328 end 1440 total 1688 skew 0 clock 64.0KHz
v: height 1024 start 1025 end 1028 total 1066 clock 60.0Hz
1280x960 (0x28a) 108.0MHz
h: width 1280 start 1376 end 1488 total 1800 skew 0 clock 60.0KHz
v: height 960 start 961 end 964 total 1000 clock 60.0Hz
1280x720 (0x28b) 74.2MHz
h: width 1280 start 1390 end 1430 total 1650 skew 0 clock 45.0KHz
v: height 720 start 725 end 730 total 750 clock 60.0Hz
1024x768 (0x28e) 65.0MHz
h: width 1024 start 1048 end 1184 total 1344 skew 0 clock 48.4KHz
v: height 768 start 771 end 777 total 806 clock 60.0Hz
800x600 (0x291) 40.0MHz
h: width 800 start 840 end 968 total 1056 skew 0 clock 37.9KHz
v: height 600 start 601 end 605 total 628 clock 60.3Hz
800x600 (0x292) 36.0MHz
h: width 800 start 824 end 896 total 1024 skew 0 clock 35.2KHz
v: height 600 start 601 end 603 total 625 clock 56.2Hz
640x480 (0x295) 25.2MHz
h: width 640 start 656 end 752 total 800 skew 0 clock 31.5KHz
v: height 480 start 490 end 492 total 525 clock 59.9Hz
sim@OCC ~ $

Thanks again, for your help - much appreciated. :slight_smile:

Okay it looks like the nvidia drivers are probably setting panning as mentioned here:
http://ubuntu-bugs.narkive.com/zdCQUE03/bug-1326688-re-can-t-disable-panning-on-multiple-monitors

is there nothing in nvidia-settings to configure multiple monitors, or disable panning ?

What’s the contents of your:

gedit /etc/X11/xorg.conf

file (if anything) ?

Thanks again for the reply.

Within Nvidia settings, under Xserver display configuration, there is an advanced option for panning, viz:-

“the panning domain sets the total width/height that the display device may pan within”

I tried to halve the range, and it wouldn’t let me - clicked apply, and the values returned to the default 1920x1080

However, now you have reminded me what the “problem” is called, and which files to look at, I will see if I can find the old versions of xorg.conf from the version of 14.04 which worked - I will also see if I can boot it into 14.04, and then find the Nvidia settings…

/etc/X11/xorg.conf -

Section “ServerLayout”
Identifier “layout”
Screen 0 “nvidia”
Inactive “intel”
EndSection

Section “Device”
Identifier “intel”
Driver “intel”
BusID “PCI:0@0:2:0”
Option “AccelMethod” “SNA”
EndSection

Section “Screen”
Identifier “intel”
Device “intel”
EndSection

Section “Device”
Identifier “nvidia”
Driver “nvidia”
BusID “PCI:1@0:0:0”
Option “ConstrainCursor” “off”
EndSection

Section “Screen”
Identifier “nvidia”
Device “nvidia”
Option “AllowEmptyInitialConfiguration” “on”
Option “IgnoreDisplayDevices” “CRT”
EndSection

Thanks again :slight_smile:

I have got this “working” by disabling the Nvidia drivers and using the xorg driver, which, granted, is not ideal, but it gets me away from the daft panning until another solution can be found.

Would you mind telling me how to do this please? :slight_smile:

( the X-org setup will do for now… just about :o)

Thanks!

Okay, what’s the screenlayout file called and where is it ?

Thanks :slight_smile:

its called sim.sh, and is in sim/.screenlayout - viz:-

sim@OCC ~ $ cd .screenlayout
sim@OCC ~/.screenlayout $ ls
sim (copy).sh sim.sh
sim@OCC ~/.screenlayout $

( the sim (copy).sh is a backup of the original !)

TIA :slight_smile:

Okay, first let’s make sure that script is executable, so run:

chmod +x /home/sim/.screenlayout/sim.sh

now let’s create an autostart file to launch the script … run:

gedit /home/sim/.config/autostart/dual-monitor-config.desktop

make it read:

[Desktop Entry]
Type=Application
Name=Dual Monitor Configuration
Comment=Apply ARandR Settings
Exec=/home/sim/.screenlayout/sim.sh

SAVE the file and exit gedit.

Now log off/on to test.

if that didn’t work … run:

gedit /home/sim/.config/autostart/dual-monitor-config.desktop

and change it to read

[Desktop Entry]
Type=Application
Name=Dual Monitor Configuration
Comment=Apply ARandR Settings
Exec=bash -c "xrandr --output HDMI1 --mode 1920x1080 --pos 1920x0 --rotate normal --output VGA1 --off --output VIRTUAL1 --off --output DVI-I-0 --mode 1920x1080 --pos 0x0 --rotate normal --output HDMI-0 --off"

SAVE the file … log off/on to test.

The first one works :slight_smile: :slight_smile:

Thanks ever so much for that.

You’re a good un :slight_smile:

You’re most welcome Sim :slight_smile: