Duel-Boot Windows 7 and Linpus

Hello everyone! I was going to duel boot windows 7 and Linpus on my desktop computer and had a problem. I originally tried to use the windows installer that you can download for it but it said it couldn’t find the image for it (Looking at it now, I noticed that I also forgot to make a partition for it, which I did later).

Well, I burned the .iso to a dvd and ran it (after finally making space, around 200GB on my 1TB hard drive). I made sure it used the free space I had left over to install and it seemed like everything worked out. When it rebooted it popped up with a different boot setup that says Linpus Linus Lite 1.7 and Others. I thought others would be my windows 7 but everytime I click it, the Recovery Management pops up and tells me I have to run it!

I did run it once to see if my Windows 7 would pop back up but after it restarted, I was still using the Linpus boot manager and it pops up the recovery manager. Is there anything I can do to recover my files or recover Windows 7 without a completely restoring it back to factory defaults?

Hi joshbl56, and welcome to the forum :slight_smile:

Can you open a terminal, and run this command:

sudo fdisk -l

(enter your password when prompted, but be aware nothing will get ehoed to screen not even ******, but it is going in, so just type it and hit enter)

and post the output from that command back here

That command ends with a lower case L, not a 1 (one) … and remember Linux commands ARE case sensitive.

[EDIT]

can you also post the output from:

ls -a /boot/grub | grep grub

and

grub-install -v

OK, this is what I got. I had to rewrite the whole thing from my laptop because my desktop cannot access my home wireless network (We use a netgear USB adapter).

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Unites = sectors of 1 * 512 = 512 / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x35d5c1f3

     Device Boot     Start                End                  Blocks              ID    System

/dev/sda1 2048 40962047 20480000 27 Hidden NTFS WinRE
/dev/sda2 * 40962048 41166847 102400 7 HPFS/NTFS/exFAT
/dev/sda3 41166848 1543921071 751377112 7 HPFS/NTFS/exFAT
/dev/sda4 1543926825 1953520064 204796620 5 Extended
/dev/sda5 1543926888 1596362984 26218048+ 83 Linux

EDIT:
OK, I got Linpus to actually use Netgear (surprised me) and I am now on the internet. My part from earlier is still the same so I am just updating out of joy ;D

Here is the second one you wanted:

grub.conf

Here is the last one:

grub-install (GNU GRUB 0.97-71.lp)

Can you see my edit in my last posting, and send the output from those too.

Not sure if you can see the update for my earlier post so here is the second one you wanted:

grub.conf

Here is the last one:

grub-install (GNU GRUB 0.97-71.lp)

OK, can you post the contents of:

gedit /boot/grub/menu.lst

If by any chance that opens a BLANK file … close it WITHOUT saving, and let me know.

it’s also important that you postt he output EXACTLY as it is displayed … so it may be easiest to copy the contents to another text file, then copy that file to whatever PC you are currently using.

When you post the contents … can you surround it with

 tags to preserve the formating.

OK, this is what I got after I put that into the terminal:

bash: gedit: command not found

Damn … do you know which text editor Linpus 1.7 uses ?

it might be -
leafpad
mousepad
medit
or any one of a few others ???

if not, open the text editor, then select Help>About … and let me know what it’s called.

What the heck made you pick Linpus Lite … nearly ANY other distro would have found Windows without issue.

You could try nano it seems to work in any distros I have tried before

I was trying to steer clear of the command line editors (at least for now), plus there’s no guarantee nano is installed :wink:

and I’d scare him to death with vi

I liked the way the desktop looked and wanted to start using Linux as well as Windows :cry:

I have looked everywhere on linpus and it doesn’t seem to have a text editor (The only applications it had was firefox, a desktop calendar that couldn’t update correctly, RSS feeder and weather app).

I have looked around other places and found something that allowed me to change the bootloader back into Windows, which seems to be working fine now (at least as well as I remember). The only problems I am going to run into is the point I tried to do a system restore that backed up all my files. Let’s hope it works.

Thank you for your help with this problem. If I may ask for your help again, do you know I can remove Linpus and install another Linux distros that will not mess up anything on my desktop computer? And if so, which one would you choose for a novice like me?

Personally I’d say go for Linux Mint 13 (Cinnamon) or Ubuntu 12.04 (or PeppermintOS Three, if you want screaming fast, but slightly less fully featured).

Have you got Windows booting now ?

When you say it boots the “Recovery Management” … do you mean the Windows 7 recovery options, as in the pic at step 6 here:

or the manufacturers recovery partition … ie. the one that overwrites eveything from a factory image ?

[EDIT]

Any of the above listed distributions should just offer to install over the top of Linpus … but if (for some unknown reason) they don’t … come back here when you’ve decided which you want (and have the LiveCD/LiveUSB), and we’ll help you through the install.

Sadly, you picked a “pretty”, but outdated, badly supported, and just generally crap distribution with Linpus Lite :frowning:

I did go through those steps and none of the system repair options worked (by themselves). I went here:

http://lukeaddison.com/removing-linux-grub-restoring-windows-7-boot-gui/

I had to use the Windows 7 Repair disc I made (Seriously glad I didn’t neglect that) and then went into command prompt. I used both bootsect /nt60 C: and bootrec /fixmbr but the second one said the mbr was fixed. As for the Windows 7 recovery options question, mine popped up a window that asked if I wanted to restore the computer back to factory settings (ie. delete everthing from C:, which I was trying to avoid) or if I wanted to do a system restore with my files backed up to c:backup (which is what I did originally and didn’t work).

When you say install over linpus, do you mean to just choose that partition for installation and let it be removed and replaced by Linux Mint (I have Ubuntu dual-booted on my laptop and it works pretty well so I would like to try Linux Mint). Question about this: I am looking on the Linux Mint download page and they have 2 different version (MATE and Cinnamon), so which one should I choose? The computer I have has AMD Athlon II X2 dual-processor, 3GB of memory and a NVIDIA GeForce graphics card. Also, which one (if either) can use a netgear USB wireless adapter?

EDIT: Also, another question: Should I use 64-bit or 32-bit? My ubuntu was 32-bit and I wanted to know if I should just go with that.

During the boot process (if you remember setting up Ubuntu) it should display any found operating systems, and offer to “replace” the one you select.

All 3 of the distributions should do that because they are ALL based on Ubuntu 12.04 … so ALL use the Ubuntu install routine.

Personally (out of the 2 versions of Mint, I’d say go for the Cinnamon version WITH the codecs (not the one without the codecs) … you can use EITHER the 32bit or 64bit … the only benefit of 64bit is if you have more than 4GB RAM, so it’s unimportant, choose either.

[EDIT]

Ignore that … get the 64bit version, as your graphics card may have 1GB

Direct download link for the Mint 13 Cinnamon 64bit version here:
http://ftp.heanet.ie/pub/linuxmint.com/stable/13/linuxmint-13-cinnamon-dvd-64bit.iso

[END EDIT]

You’d have to tell me which model of Netgear wireless adapter … and preferably how you got it to work in Linpus.

Here’s what you want to do …

Download the Mint Cinnamon ISO image … and burn it to DVD

Boot to it, and select Try Mint

When at the desktop Click the “Install Mint” icon, and go through the install routine … at some point it will ask where you want to install it … if it offers to install over Linpus, select that … if it DOESN’T mention Linpus … STOP, and back out of the installation.

Then I’ll tell you how to start gparted from the Mint LiveDVD and delete the Linpus partition (which in your case would be /dev/sda5 … once that’s done, and you next run the installer, it will offer to install to the free space.

Does that make sense ? … if not, I’ll try to clarify.

Don’t forget to post the model of your netgear adapter.

Another option would be to delete the Linpus partitions from within Win7 … THEN install Mint.

Then it should offer to install to the free space

Ok, I went with Linux Mint 32-bit with codecs. Thanks for helping me choose :slight_smile:

My netgear version is WG111v3 (old but reliable). As for how I got it to work on Linpus, I really do not know. I was playing around with the wireless settings (turning it off and on) but after I did it about 8 times, my wireless network popped up and I was able to connect. Since that moment, it was able to connect instantly.

EDIT: I already downloaded 32-bit but can download 64-bit if you seriously think I would need it I will download the 64-bit as well.

I will try to override Linpus with Mint first and if that doesn’t work, delete it from within Mint/Win7. Thanks again for your help.

In Ubuntu, to get the WG111v3 working, you just have to connect with an ethernet cable … then run:

sudo apt-get install linux-firmware-nonfree

Then it should show up in “Addittional Drivers”

It may be that Mint already includes the nonfree firmware (so it may work out of the box), but if it doesn’t … the instructions will be the same :slight_smile:

Thank you for the help :slight_smile:

I checked GParted for the sda5 partition and this is what came back:

I’m not sure if this is normal or what but I don’t want to mess anything like this up (all I’ve ever had to do was make freespace for Ubuntu and then install, not override others so sorry that I’m not that useful).

EDIT:

Also, I got my netgear adapter to connect in the exact same way I had it connect in Linpus. The network wasn’t originally connecting (or even showing up for that matter) but I just changed the wireless from off to on a few times and it connected around the 6th time.

OK, you can delete

/dev/sda5
/dev/sda6
and
/dev/sda7

You can leave the /dev/sda4 extended partition … or delete it … shouldn’t matter.

just make SURE you DO NOT DELETE sda1, sda2, and sda3 :wink:

OK, here comes the super fun part where I get to tell you GParted refuses to let me delete them. Here are the images when trying to delete sda5 and sda6


It wouldn’t even let me click delete for sda4 and sda7.

EDIT

OK, I figured out how to delete sda4-sda7. I had to right-click sda7 and click swapoff which made it linux-swap instead of logical partition (I don’t know if this is bad or not but it didn’t affect sda1-sda3). I was able then able to delete all the extras and now have a little under 200GB of unallocated space. I will install mint in this and we should be done. Thank you for all your help!. Seriously, without your help I still would have been freaking out over Linpus. I will post if it worked or not.