Duel-Boot Windows 7 and Linpus

Did you navigate into the linpus directory whilst booted to the LiveDVD ? … as that would have mounted the partition.

(gparted will not delete mounted partitions)

if so, reboot to the LiveDVD, then without doing anything else … run grparted and try again.

I was able to successfully install Linux Mint and only 1 big (and weird) problem (which is good). Every time I restart my computer, it will go through BIOS but will then pop up saying my screen has been changed to 1024x768 (the normal resolution) and 60 Hz. It basically stops me from seeing the bootloader completely. The first time it happened, I just let it continue on and it booted into Linux Mint. The second time it happened, I clicked down and left once, which booted me into safe mode for Linux Mint. Here are what each one does:

  1. Boots into Linux Mint
  2. Boots into Linux Mint (Safe Mode)
  3. Boots into a memory test
  4. Boots into a memory test (Same as 3)
  5. Boots into Recovery Management (Same as earlier)
  6. Boots into Windows 7

I would guess this to be all (7 is just Windows 7 again). Any answers to why this is happening?

Is this a message from the monitor ?

Hmm … I wonder if mint have set a vesa mode in the grub bootloader

What are the contents of:

gedit /etc/default/grub

Do you know the resolution BEFORE it switches ?

I also thought it was just the monitor so I turned it off and back on, clicked the menu button, tried to change the sound volume and brightness but nothing happened.

Here is the results from the terminal (another window popped up with this in it):

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Also, I believe the resolution is 800x600 when it first boots up. I have just let it sit there and wait for the message to go away but it hasn’t.

If it’s happening BEFORE the OS is loaded it can ONLY be a message from the monitor.

for now we’ll try increasing the timeout for the GRUB menu … thenn I’m off to bed, so we’ll pick this up tomorrow.

Run:

sudo gedit /etc/default/grub

Find the line that read:-

GRUB_TIMEOUT=10

and change it to:

GRUB_TIMEOUT=60

SAVE the file and exit gedit.

Now back in the terminal, run:

sudo update-grub

It should now sit at the grub screen for 60 seconds before automatically booting Mint … hopefully that will be long enough for the messaage to disappear.

As I said, we’ll pick this up again tomorrow … when we can try telling the GRUB bootloader to stay at 800x600

Ok, sorry I was gone the whole weekend. Personal matters came up and I didn’t have time to reply or even access my computer.

I was loading the grub bootloader and noticed that I had taken the message the wrong way (sort of). It tells me to change my resolution to 1024x768 and 60 Hz, not that it was changed into 1024x768. I was one letter off and made a mistake. Is there anyway for me to the resolution for the grub page to 1024x768?

YES :slight_smile: … you just need to add vesa=791 to the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub

Open a terminal, and run:

sudo gedit /etc/default/grub

Find the line that reads:-

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”

and change it to:-

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash vesa=791”

Visually check that line to be sure it’s EXACTLY as above … then SAVE the file, and exit gedit.

Now back in the terminal run:

sudo update-grub

When that command has finished and left you back at an $ prompt … reboot to test


Other Linux vesa modes are listed here:

Hello again!

I haven’t been able to post for a bit as I have been away from this computer for a few days. I had it working after a reboot (at least, for the grub part) but I couldn’t see the actual loading (load screen?) as the message kept popping up. I didn’t think too much about it as I finally had some kindling on the grub.

I left my computer off for the few days I didn’t post and came back today to find that the grub and load screen both had the message! I tried removing the vesa= 791 and restarting it, which didn’t do anything, and then replacing it but nothing changed.

Do you have another solution for this problem? I turned off the screen and turned it back on and it showed these two numbers:

H= 93 kHz
V= 58 Hz

Do they mean anything to you?

What graphics card do you have ?

Can you open a terminal and run:

sudo lshw -C display

and post back the results.

And can you send the full contents of:

gedit /etc/default/grub

FYI, those 2 numbers are probably being displayed by the monitor … either displaying the current horizontal (H) and vertical (V) scan rates, or if the signal is “out of range” it might be displaying the “maximum” vertical and horizontal sync rates it can handle.

ok, to the first one, this pops up:

PCI (sysfs)

and then:

  *-display               
       description: VGA compatible controller
       product: C61 [GeForce 6150SE nForce 430]
       vendor: NVIDIA Corporation
       physical id: d
       bus info: pci@0000:00:0d.0
       version: a2
       width: 64 bits
       clock: 66MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:22 memory:fb000000-fbffffff memory:e0000000-efffffff memory:fa000000-faffffff memory:febc0000-febdffff

For the second part:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=60
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vesa=791"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

OK, try this…

Open a terminal and run:

sudo gedit /etc/default/grub

find the line that reads:-

#GRUB_TERMINAL=console

and uncomment it, so it reads:-

GRUB_TERMINAL=console

SAVE the file, and back in the terminal run:

sudo update-grub

Now reboot to test.

Ok, I can see the grub loader again! Thank you for the help and sorry that my computer kept having problems :-[

I’m glad it’s now working properly :slight_smile:

Don’t ever be sorry or embarrassed to ask for help … that’s how we all learn :wink:

That’s what we’re all here for … to learn from each other.