DVD Drive problem(Solved)

Trying to update old Inspiron 6400 from peppermint 6 to Peppermint 9, problem encountered as DVD drive didnt seem to be working, have replaced this but still not reading DVD. How can i test this replacement drive is working?
Wont run a normal DVD though does recognise it using VLC Media player, title comes up but then goes off as it starts.
Any help would be appreciated.

Just a bit of further info, have tried a music CD and that plays fine so does that help with any info regarding the Pep 9 DVD. The drive will not play a DVD using VLC Media player either.

OK so further to the above, i have managed to get the drive that i replaced to play both music cd and video DVD with VLC Media player so i guess that tells me the replacement drive is in fact working.
so my problem now is that my Peppermint 9 installation DVD isnt working, though it does work in my other Inspiron and also in a Dell Latitude 5420 so that should suggest the disc is fine, any advice greatly appreciated.


So can it read the contents of the Peppermint DVD ? … ie. can you open it in file manager and see the contents ?

And have you considered using a USB stick (LiveUSB) instead for the installation ?

Hi Mark,
Yes I can open it in file manager and see the contents, if I use F12 on start up and go to dvd however it shows the menu, ie Try peppermint etc but if I click the try option it just doesn’t do anything.
With regard to USB option I am not sure I can do that, there is no option for using a USb stick after pressing F12.
Your further advice is appreciated,


Hi Degsy

Your boot menu won’t usually show the USB option unless there’s a USB drive plugged in

Good luck


Hi, Graeme and Mark,
well I have now learned how to sort out the Bios and boot from a USB drive, so all that remains is to produce a bootable USB stick, thank you both very much for your help, it is much appreciated.
one further question guys, as Peppermint 10 is now available do you recommend that i use that instead of 9, the prime reason for changing in the first place was that it is actuallu my Grandsons laptop that has happily run Pep6 for years but as he is now at college he wants to use word, and 9 gives access to Word Online so that was why I was going to put him on that, plus that is what I am using on my Inspiron 6400, comments appreciated, thanks in advance,


Personally to me either would be good they’re both great distros, but if I had to make a choice I would opt for the latest version unless you had a good reason not to, but that’s just my personal opinion

Good luck whichever way you go


Thanks Graeme,
i seem to have hit an impasse at the moment, found a usb with pep 8 on which i used to put on a laptop for my granddaughter, tried it out on my Inspiron and it works fine, tried it on my grandsons Inspiron and it is just like the DVD, it goes to the opening menu offering Try Peppermint etc put after pressing enter nothing happens at all.
so i am now at a loss unless you guys have any further ideas about what may be causing the problem.

thanks again for your input so far,


Do you know how to add the nomodeset boot parameter ?


I would be obliged if you could help me through ig, Graeme or give me a link to set if up from a tutorial,
Many thanks,

I always forget how to do it I can do it if I’m sitting at the PC but I can never explain it, anyway here’s easy to follow instructions courtasy of Mark from the peppermint forums

Boot to the Peppermint 9 or 10 LiveUSB .. when you get to the screen where it offers you "Try Peppermint" and "Install Peppermint" .. hit the "Tab" key

You’ll then see some white writing at the bottom of screen that ends with:-

quiet splash –

Instead make it end with:-

quiet splash nomodeset –

then hit enter to continue booting.

Did that allow you to boot ?

Good luck


Hi Guys,
Well tried the nomodeset parameter but no joy no boot at all. Tried both with a DVD and with a USB, still just sits at the same screen.
Any other ideas?


Ok, tried the Nomodeset parameter again and this time got a reaction from the Laptop, the response after Loading/casper etc and loads of dots was:
This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot - please use a kernel appropriate for your CPU.

Can you advise further please now.
Or is the answer that I need the 32 bit version for this laptop?

Thanks in advance.

Downloaded Peppermint 10, 32 bit version and that has booted no problem, so my Grandson will be a happy bunny tomorrow.
Thanks for the hints and tips along the way, learn something new every day, and some of us have an awful lot to learn.

Nicely done guys, glad to see you sorted it out :slight_smile: