DVD not playing in Ubuntu 16.04 [SOLVED!]

Once upon a time I could display DVDs on my laptop – perhaps that was on Ubuntu 12 – but no longer. As my DVD collection grows so has my desire to actually view them so I beg assistance.

The symptoms are that often the first screen is displayed inviting a choice of viewing but no videos are displayed. Browsing the web revealed very many other disgruntled Ubuntu users and the proposed solution in each case was the same, as found here: How to play DVDs in Ubuntu 16.04? - Ask Ubuntu
I have implemented all the suggestions given there and although the system attempts to play videos, the screen is grossly, and patchily, pixellated for a few seconds before freezing. I used “regionset” to define region 2 although I had no reason to doubt it.
I have no objection to buying an external USB DVD reader but it would be nice to fix the problem if possible. I show below some system info and would be very grateful for advice.

Laptop: Lenovo T500

lshw -c disk
*-cdrom
description: DVD reader
product: RW/DVD MU10N
vendor: HL-DT-ST
……
capabilities: removable audio cd-r cd-rw dvd
configuration: ansiversion=5 status=nodisc

keith@T500:~$ dpkg -l |grep dvd
ii libdvd-pkg 1.4.0-1-1 all DVD-Video playing library - installer
ii libdvdcss2:i386 1.2.13-0 i386 library designed for accessing DVDs
ii libdvdnav4:amd64 5.0.3-1 amd64 DVD navigation library
ii libdvdread4:amd64 5.0.3-1 amd64 library for reading DVDs
ii lsdvd 0.17-1 amd64 read the content info of a DVD (which does indeed list the contents
keith@T500:~$

Thank you.

Hi Keith,
Im not sure if this is any help, perhaps you are missing some libraries. My knowledge isnt all that good, so I`ve listed my details below.

sudo lshw -c disk

*-cdrom

   description: DVD-RAM writer
   product: DVDRAM GSA-T20N
   vendor: HL-DT-ST
   physical id: 0.0.0
   bus info: scsi@0:0.0.0
   logical name: /dev/cdrom
   logical name: /dev/cdrw
   logical name: /dev/dvd
   logical name: /dev/dvdrw
   logical name: /dev/sr0
   version: WW01
   capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
   configuration: ansiversion=5 status=nodisc

dpkg -l |grep dvd

ii dvd+rw-tools 7.1-11 i386 DVD±RW/R tools
ii dvdauthor 0.7.0-1.4 i386 create DVD-Video file system
ii libdvdcss2 1.2.13-0 i386 library designed for accessing DVDs
ii libdvdnav4:i386 5.0.3-1 i386 DVD navigation library
ii libdvdread4:i386 5.0.3-1 i386 library for reading DVDs

I dont know if there would be any difference between 32bit & 64bit, mines 32bit.

Open a terminal and run:

sudo apt-get install libdvd-pkg

and when prompted answer

OK > YES

by just hitting the enter key

I did that, Mark - that’s how I got the files mentioned above. Tried it again and got: libdvd-pkg is already the newest version (1.4.0-1-1).
But Wishbone’s list of packages (thanks wishbone) does have two extra ones:
ii dvd+rw-tools 7.1-11 i386 DVD±RW/R tools
ii dvdauthor 0.7.0-1.4 i386 create DVD-Video file system

Wishbone: where did you get your files from? And can your read DVDs OK?

I’ve found what appear to be sources for those two files:
Debian -- Error for ii dvd+rw-tools 7.1-11
0.7.0-1.4 : dvdauthor package : Ubuntu
but it looks complicated and I’m not even sure if they are useful.

Any ideas, Mark?

They’re not necessary for playing DVD’s

So what happens when you insert a disk … is the disk recognised ? … ie. does it show up in the left hand column in the file manager ?

Yes, the DVD shows up OK in Nautilus/Nero and I can display the files in the RHS pane. Files that are static pictures often do display but video files don’t work.

Will they play in VLC ?

I think they were installed when I installed or upgraded VLC, I`m not really sure, I just go with what is recommended.

I have a few DVDs that will not read or run, probably due to the age of the DVD drive within the laptop. I bought an external DVD drive and the ones that wouldnt play did with the new one.

That`s probably no help with your problem, just what happened to me.

Best of luck
Tony

Mark, I’ve tried VLC, Media Player, SM Player and the default “Videos”. VLC tries hardest - the others give up almost immediately after showing the initial still.

Wishbone: I did find a reference to one of the files that you have and I don’t that labeled it as “unstable”. Your solution of buying an external player is pragmatic if less aesthetically pleasing, and I might be forced down that route eventually, if all else fails.

I’ve found nothing more on the web that might help.

Just to eliminate a software issue, try booting an Ubuntu 16.04 LiveUSB … then (with an active internet connection) install:

sudo apt-get install libdvd-pkg

then see if a DVD will play in a live session.

If not, I’d suspect a DVD hardware problem.

Entering that command resulted in “Unable to locate package libdvd-pkg”.
Do I need to specify a repository?
This site: Ubuntu – Error list a multiverse source of the package. I found it earlier but couldn’t understand it all!

Hi Keith,
Having had a rethink on my previous post to you I`m fairly certain now that the files were installed when I installed K9Copy. As I recall they were needed for it to work properly. It all works OK and had no problems with it.

Hi Wishbone.
Thank you for that info. I see that K9Copy is no longer being developed, and Ubuntu.com says it is no longer supported and is a candidate for deletion. There is also a long list of prerequisite files to install. So I am a bit reluctant to install it although it looks interesting.

How long ago did you install K9Copy? Are you running KDE?

Keith, those packages have nothing to do with DVD “playback”, so there’s no point in installing them.

You need to find out if this is a hardware issue … which is the most likely.

Do what I said in my last posting (boot to a LiveUSB), but before installing libdvd-pkg search your menu for “Software & Updates” and launch it … now on the first tab, make sure ALL five boxes are ticked, on the second “Other Software” tab, make sure “Canonical Partners” is ticked … click the “Close” button.

Now open a terminal and run:

sudo apt-get update

then

sudo apt-get install libdvd-pkg

Now test the DVD player.

If it still gives has problems it’s not a software issue.

Mark,
I had indeed booted from the live USB before installing the libdvd-pkg.
I have just tried your new suggestions and had some errors:

  1. In the “other software” tab of “software & updates” Canonical Partners was not listed - only “CDROM: [Ubuntu 16.04.1 LTS_Xenial Xerus…main restricted”. But I carried on regardless.
  2. During the get update I got this:
    [i]ubuntu@ubuntu:~$ sudo apt-get update
    Ign:1 cdrom://Ubuntu 16.04.1 LTS Xenial Xerus - Release amd64 (20160719) xenial InRelease
    Hit:2 cdrom://Ubuntu 16.04.1 LTS Xenial Xerus - Release amd64 (20160719) xenial Release
    Hit:4 Index of /ubuntu xenial InRelease
    Hit:5 Index of /ubuntu xenial-updates InRelease
    Hit:6 Index of /ubuntu xenial-security InRelease

** (appstreamcli:5664): CRITICAL **: Error while moving old database out of the way.
AppStream cache update failed.
Reading package lists… Done
ubuntu@ubuntu:~$ [/i]

  1. During the installation of libdvd-pkg I had the error:
    libdvd-pkg: dpkg database is locked. You may need to use command “sudo dpkg-reconfigure libdvd-pkg”.
    libdvd-pkg: Building and installation of package(s) [libdvdcss2 libdvdcss-dev] postponed till after next APT operation.
    Processing triggers for libc-bin (2.23-0ubuntu3) …
    W: Operation was interrupted before it could finish

    so I did “sudo dpkg-reconfigure libdvd-pkg” then tried to install the package again, which operation said:
    libdvd-pkg is already the newest version (1.4.0-1-1).
    0 upgraded, 0 newly installed, 0 to remove and 645 not upgraded.

    The DVD now plays - on the live USB - but not on the installed Ubuntu 16.04 despite taking the same actions.
    So at least the hardware is OK.

I re-installed VLC and the libdvd-pkg then ran VLC from the terminal on my installed Ubuntu. It failed as usual so I crashed out and found this on the terminal:
[i]keith@T500:~$ vlc &
[1] 10763
keith@T500:~$ VLC media player 2.2.2 Weatherwax (revision 2.2.2-0-g6259d80)
[0000000000817148] core libvlc: Running vlc with the default interface. Use ‘cvlc’ to use vlc without interface.
libdvdnav: Using dvdnav version 5.0.3
libdvdread: Encrypted DVD support unavailable.



** No css library available. See **
** /usr/share/doc/libdvdread4/README.css **
** for more information. **



libdvdnav: DVD Title: DVDVolume
libdvdnav: DVD Serial Number: c8e1e47a
libdvdnav: DVD Title (Alternative): DVDVolume
libdvdnav: DVD disk reports itself with Region mask 0x00fd0000. Regions: 2
[00007ff6c0000c18] core input error: ES_OUT_RESET_PCR called
[00007ff6c0000c18] core input error: ES_OUT_RESET_PCR called
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
[00007ff6c0000c18] core input error: ES_OUT_RESET_PCR called
[00007ff6c0000c18] core input error: ES_OUT_RESET_PCR called
Failed to open VDPAU backend libvdpau_va_gl.so: cannot open shared object file: No such file or directory
[/i]

Does it help at all?

It might…

Run:

sudo apt-get remove --purge libdvdcss2

then:

sudo apt-get install --reinstall libdvd-pkg libvdpau-va-gl1

and now test DVD’s

If that doesn’t work, try this:

sudo apt-get remove --purge libdvdcss2

then download this file:-
http://download.videolan.org/pub/ubuntu/raring/libdvdcss2_1.2.13-0_amd64.deb
and double-click it to install … then test DVD’s

After the re-install, VLC shows the initial menu page but selecting an item had no effect. The PC then froze with ~continuous disk access.
Hard reboot.
Purged then installed libdvdcss2_1.2.13-0_amd64.deb as instructed but the same behaviour is shown.

Hmmm! At least CDs run properly, so the R&R is OK.

That’s not necessarily true… the data tracks are MUCH closer together on a DVD, so if the laser is having trouble focussing…

You’re going to have to find a way to test the DVD drive in a different OS as I suggested.