Edimax Wireless LAN

You may be better off just replacing the wireless adapter altogether.

but yeh, let me know how it works after the install … at least that will put you back to the drivers that came with 11.10, so it may just turn out to be 1 issue … weak signal/rubbish adapter :slight_smile:

agreed - although from the ones offered at computer planet the one I’ve got is meant to be quite high quality - do you think this is one faulty unit?

Probably not due to the amount of people bitchin about them on the web … at least in the Linux world :o

Would be interesting to know how the signal is in Windows.

You could try disabling wireless security or changing to WEP rather than WPA/2 in the router, and see if that makes a difference.

Or change channel in the router … sometimes that helps, specially if you have a neighbor who’s using the same channel.

I doubt if these will help much, but worth a try ?

It’s fixed!

The last time I felt this technically inept I was switching over to Ubuntu.

The poor signal was because the antenna hadn’t been attached, and it didn’t connect because IPv6 was set to ‘automatic’ instead of ‘ignore’ by default.

Thanks for your patience!

Heh … yes the do work somewhat better with an aeriel :slight_smile:

OK, the signal is now fine, but it’s still a coin toss as to whether I get a connection. I have no idea what’s happening - I copied the settings on wireless exactly from my laptop, it worked, but the next time I booted up it was back to the same problem. Changing settings sometimes helps and sometimes doesn’t, but there’s still a strong element of luck each time I boot.

How can I tell which settings I should be using? Also, should I have dhcp3-client installed? This was installed on my laptop, but doesn’t seem to make a difference here.

No dhcp3-client doesn’t need to be installed, but isc-dhcp-client does, and probably is … dhcp3-client is just a transitional package that probably installs isc-dhcp-client. but isn’t necessary as long as isc-dhcp-client is installed … but it won’t hurt either.

I’m convinced this ia a driver issue … have you got a USB wireless adapter you could test it with, just to rule out anything else ?

Don’t know if this is relevant or not here but I had a very similar issue on a windross box.
Sometimes it would see the network sometimes not, sometimes connect sometimes not. If it did connect it would drop randomly and then take forever to reconnect, if at all.
After weeks of pi**ing about it turned out to be the router. It was set to auto channel and for some reason was constantly cycling.
Locking it to one channel cured the problem but the odd thing was that all the channels produced different degrees of connectivity (some produced none at all) and stability, in this case channel 11 was the strongest and most stable.
As I said, don’t know if this is relevant or not here but thought I’d mention it.

Is the router doing this now ?

Have you tried setting the PC with a static IP ? … in case it’s a DHCP lease issue

No, I’ve got a different router now plus my windows box is now a linux box.

Have you got another (USB maybe) wireless adapter you could try ?

and have you tried a static IP ?

ktlou also seems to be having issues with a Realtek chipped wireless adapter (though a different chip than yours), that also uses the rtl8192se drivers, so I’m wondering if this is down to some crap drivers/firmware from Realtek ::slight_smile: … which is why it would be nice if you could try a different adapter.

I’m still looking for a fix though :slight_smile:

OK I can’t find a dongle (although I’m sure we had one once).

Anything else to try?

computerplanet say BT could have the answers, but I doubt that. I will retry the driver installation you described earlier.

Can you post the output from:

sudo iwlist scan

GG are you using a BT router?

lo        Interface doesn't support scanning.
eth0      Interface doesn't support scanning.

According to that, it looks like there’s no wireless adapter set up at all

Can you post the output from these again:

sudo lshw -C network

and

ifconfig

and

rfkill list

and

lsmod

can you also run:

dmesg > ~/dmesg.txt

You’ll now find a file called dmesg.txt in your home directoy … attach that file to your next post.

sudo lshw -C network:

  *-network
       description: Wireless interface
       product: RTL8191SEvB Wireless LAN Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 10
       serial: 80:1f:02:2f:14:a0
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192se driverversion=3.0.0-12-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:d000(size=256) memory:fb200000-fb203fff
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eth0
       version: 03
       serial: f4:6d:04:7c:ad:82
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168d-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:45 ioport:c000(size=256) memory:f2104000-f2104fff memory:f2100000-f2103fff memory:f2110000-f211ffff

ifconfig:

eth0      Link encap:Ethernet  HWaddr f4:6d:04:7c:ad:82  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:45 Base address:0xa000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:240 errors:0 dropped:0 overruns:0 frame:0
          TX packets:240 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:18968 (18.9 KB)  TX bytes:18968 (18.9 KB)

wlan0     Link encap:Ethernet  HWaddr 80:1f:02:2f:14:a0  
          inet6 addr: fe80::821f:2ff:fe2f:14a0/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:135 (135.0 B)  TX bytes:155 (155.0 B)

rfkill list:

0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

lsmod:

Module                  Size  Used by
bnep                   18436  2 
rfcomm                 47946  0 
bluetooth             166112  10 bnep,rfcomm
pci_stub               12622  1 
vboxpci                23200  0 
vboxnetadp             13382  0 
vboxnetflt             23441  0 
vboxdrv               282548  3 vboxpci,vboxnetadp,vboxnetflt
parport_pc             36962  0 
ppdev                  17113  0 
vesafb                 13809  1 
binfmt_misc            17540  1 
snd_hda_codec_hdmi     32040  4 
uvcvideo               72711  0 
arc4                   12529  2 
videodev               93004  1 uvcvideo
v4l2_compat_ioctl32    17083  1 videodev
eeepc_wmi              12826  0 
asus_wmi               20035  1 eeepc_wmi
mei                    41480  0 
sparse_keymap          13890  1 asus_wmi
nvidia              11713772  41 
snd_hda_codec_realtek   330769  1 
rtl8192se              99931  0 
rtlwifi               110972  1 rtl8192se
snd_hda_intel          33390  3 
snd_hda_codec         104802  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13668  1 snd_hda_codec
snd_pcm                96755  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_seq_midi           13324  0 
snd_rawmidi            30547  1 snd_seq_midi
snd_seq_midi_event     14899  1 snd_seq_midi
snd_seq                61896  2 snd_seq_midi,snd_seq_midi_event
snd_timer              29991  2 snd_pcm,snd_seq
snd_seq_device         14540  3 snd_seq_midi,snd_rawmidi,snd_seq
video                  19412  0 
snd                    68266  16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
wmi                    19256  1 asus_wmi
psmouse                73882  0 
mac80211              310872  2 rtl8192se,rtlwifi
lp                     17799  0 
serio_raw              13166  0 
joydev                 17693  0 
cfg80211              199587  2 rtlwifi,mac80211
soundcore              12680  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
parport                46562  3 parport_pc,ppdev,lp
usb_storage            57901  0 
uas                    18027  0 
usbhid                 47198  0 
hid                    95463  1 usbhid
r8169                  52788  0 
xhci_hcd               78641  0 

dmesg attached.

OK, bit baffled here … what exactly is the problem ? … reasons I ask -

a) THIS TIME the wlan0 wireless adapter DOES appear to be registered and working.

b) dmesg still seems to suggest it’s looking for an IPv6 router

Can you run:

ifconfig

then look for a wlan0 section … IF there IS a wlan0 section, run this:

iwlist scanning

and post the output.

Does the wireless SOMETIMES work ? … is this the problem ?

In the past, the wireless has sometimes worked and sometimes not. However recently it hasn’t worked at all.

Have you disabled IPv6 in Networkmanager for your wireless connection ?

have you also tried deleting the wireless connection in NetworkManager, and recreating ?

Also … can you post the output I asked for.