Enter password for keyring 'Default' to unlock (SOLVED)

Every time I start up Chrome (installed a few days ago) I get a box “Unlock Keyring. Enter password for keyring ‘Default’ to unlock. An application wants access to the keyring ‘Default’, but it is locked”

I followed instructions on another thread to remove the old password and enter a new one. It works, in that it accepts the password and disappears but, the box still appears.

I opened ‘Details’ drop down menu and there are the following options:
Automatically unlock this keyring I’m logged in.
Lock this keyring when I log out.
Lock this keyring after… mins
Lock this keyring if idle for… mins.

Unfortunately the first option, which I obviously want to click, is greyed out!

Can I stop this box from appearing every time I open Chrome?

Thanks.

Weird … I’ve never known Chrome ask for a password ???

Anyway, let’s rename the ~/.gnome2/keyrings directory:
(it will get recreated on next login)

Open a terminal (Ctrl+Alt+T) and run:

mv -v ~/.gnome2/keyrings ~/.gnome2/keyrings.old

Expected output:-

`/home//.gnome2/keyrings' -> `/home//.gnome2/keyrings.old'

If that command runs without error … REBOOT.

When your system restarts, you may be prompted by “Authentication required by wireless network” … enter your WEP or WPA key, and click the “Connect” button.

You may THEN be prompted to “Choose password for new keyring” … leave BOTH fields BLANK (or use your current login password), and click the “OK” button.

You will then be warned about “Store passwords unencrypted?” … click the “Use Unsafe Storage” button.

You should not be prompted for a keyring password for wireless again. :slight_smile:

Same applies to ANYTHING … if EVER prompted for a “Keyring” Password, either leave it Blank, or use YOUR Linux password.

That worked. Nothing came up when I rebooted.

Thanks Mark :smiley:

You’re welcome :slight_smile: