External hard drive

Hi all,

I have just got another external hard drive which has “gpt”. I reformatted it to ext4, now when I try and add folders to it, it says I can`t because I do not have permissions to create it in the destination or “error copying file, permission denied” when trying to copy files.

Its mounted at dev/sdb2. In GParted theres a little key icon after dev/sdb2 under partition column. Any help appreciated.



I think I`ve found out how to do it by following this:


It seems to work OK for now!

Another option would have been to use the “Disks” utility to take ownership of the file system.


Nice one Mark. Until you mentioned the disks utility, I had forgotten about it. Still, it`s all working OK so far. Bloody microsoft and their gpt and all things to do with them. :o