Failed to mount.

For some reason my external drive has stopped mounting at startup.
Returns this message

Error mounting system-managed device /dev/sdb1: Command-line `mount "/mnt/usb-Samsung_D3_Station_00000000011E0A49-0:0-part1"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

Don’t know if this is related to the recent update but it has only just started happening.
Can manually mount it in discs, and will auto mount if told to do so from mount options but just doesn’t seem to work any more from the existing fstab entry that has always worked.

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation
UUID=9377b20b-4245-47ae-9f57-e7cd2ee5c031 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=d5220637-2a37-44fa-8c91-d7118f3d0ee1 none            swap    sw              0       0
## Added by celticbiker - Mount NAS Public
//192.168.0.10/Public /media/WDMyCloud/NAS-Public cifs iocharset=utf8,dir_mode=0777,file_mode=0777 0 0
##Added by celticbiker - Mount samsung d3
/dev/disk/by-id/usb-Samsung_D3_Station_00000000011E0A49-0:0-part1 /mnt/usb-Samsung_D3_Station_00000000011E0A49-0:0-part1 auto nosuid,nodev,nofail,x-gvfs-show 0 0

Any ideas?

Forgot to say, this is on peppermint six.

What filesystem is on that disk ?

What’s the output from

sudo fdisk -l

and

sudo blkid

File type is ext4

sudo fdisk -l

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x927d3795

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048    17205247     8601600   27  Hidden NTFS WinRE
/dev/sda2        17205248   250677247   116736000    7  HPFS/NTFS/exFAT
/dev/sda3       250679294   488396799   118858753    5  Extended
/dev/sda5       250679296   299810815    24565760   83  Linux
/dev/sda6       484241408   488396799     2077696   82  Linux swap / Solaris
/dev/sda7       299812864   484231167    92209152   83  Linux

Partition table entries are not in disk order
Note: sector size is 4096 (not 512)

Disk /dev/sdb: 3000.6 GB, 3000592977920 bytes
255 heads, 63 sectors/track, 45600 cylinders, total 732566645 sectors
Units = sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0008a0fa

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          63   476168447  1904673540   83  Linux
/dev/sdb2       476168704   732566644  1025591764    7  HPFS/NTFS/exFAT

sudo blkid

/dev/sda1: LABEL="System" UUID="F6084579084539BF" TYPE="ntfs" 
/dev/sda2: LABEL="Windows" UUID="D214489714488109" TYPE="ntfs" 
/dev/sda5: UUID="007a4768-efcc-4650-893f-3d87f0146841" TYPE="ext4" 
/dev/sda6: UUID="d5220637-2a37-44fa-8c91-d7118f3d0ee1" TYPE="swap" 
/dev/sda7: UUID="9377b20b-4245-47ae-9f57-e7cd2ee5c031" TYPE="ext4" 
/dev/sdb1: LABEL="Samsung D3" UUID="6f28a136-1439-4c0d-b996-33e83955d788" TYPE="ext4" 
/dev/sdb2: LABEL="Samsung D3 NTFS" UUID="5AEE725D47C5412E" TYPE="ntfs"

If your sure it’s the ext4 partition you want to automount, what happens if you cahnge this line in fstab

/dev/disk/by-id/usb-Samsung_D3_Station_00000000011E0A49-0:0-part1 /mnt/usb-Samsung_D3_Station_00000000011E0A49-0:0-part1 auto nosuid,nodev,nofail,x-gvfs-show 0 0

to

UUID=b9d0ad2c-7389-45db-a909-ed991b7ef524  /mnt/usb-Samsung_D3_Station_00000000011E0A49-0:0-part1    ext4    errors=remount-ro  0  1

SAVE the file, then run

sudo mount -a

It’s claiming the device doesn’t exist.

mount: special device UUID=b9d0ad2c-7389-45db-a909-ed991b7ef524 does not exist

This is new behavior, it’s never failed before.
Because I still have Peppermint five on another partition I tried that and it mounted ok so it’s not the drive.
I even tried copying the fstab entry from pep 5 and that didn’t work either.

My apologies, I copied the wrong UUID, try

UUID=6f28a136-1439-4c0d-b996-33e83955d788  /mnt/usb-Samsung_D3_Station_00000000011E0A49-0:0-part1    ext4    errors=remount-ro  0  1

then what does

sudo mount -a

return ?

If I mount it with your command it mounts and shows up under devices, all correct.
I have old symlinks pointing at another mount point though so I changed your command to

UUID=6f28a136-1439-4c0d-b996-33e83955d788  /mnt/3TBusb    ext4    errors=remount-ro  0  1

It then mounts at /mnt/3TBusb correctly but I can’t for the life of me to get it to display under devices like it used to, more to the point (for my understanding anyway) why did it suddenly stop working correctly in the first place?

No idea, maybe the id changed, so it was no longer located at

/dev/disk/by-id/usb-Samsung_D3_Station_00000000011E0A49-0:0-part1

in fact I’ve never seen a disk/partition mounted the way you were doing it.