Firefox 4.0 and Linux :(


I was promted on my AA1 to update to firefox 4.0, I did this as I have done in the past, following the instructions.

When it closed down firefox and then restarted it, the problems began, I now cannot get into my browser at all, having to us the big PC to do this, and now it has been over a day and I am so frustrated.

Can someone please help me?


Linpus Linus Lite v.1.0.9.E

Had this same problem, but have now just solved it with the help from this forum member. Have copied and pasted their advice here goes…

you could try starting Firefox in “safe mode” then deleting or disabling the GoogleToolbar addon.
(I haven’t tested this method, so can’t say for sure that it works).

First reboot your PC (to kill any already running firefox processes), but when it starts, DON’T attempt to open Firefox normally… insted, follow these instructions.

To open Firefox in SAFE MODE…

Hit Alt+F2… in the resulting dialogue (text) box enter:
firefox -safe-mode
now click the Run button.
(don’t miss out the space between the “x” and the “-”, and it MUST be all lower case)

In the resulting dialogue, put a tick in “Disable all addons” (or similar)… then click “Continue in safe mode” (or similar).

Then if Firefox starts… Go to Tools>Addons>PlugIns (or Extensions), and delete or disable the GoogleToolbar plugin/extension.

Close Firefox, and restart it normally.

It may be better to disable the addon rather than delete it, as it may get reinstalled if you delete it… but that’s for you to discover, I haven’t got an AA1 so I can’t test it.


Firefox 4 requires a file that isn’t available in Linpus Lite… see here:

you could either follow those instructions fully.
Download this file:
and extract it to your current firefox directory


Full instructions to install Firefox 7 on an Acer Aspire One running Linpus Lite Linux can be found here:[/b]

Okay did what you said by going into safe mode, when I did that it came up with the terminal but then a blank screen :frowning: xx

Thank you so much, it worked doing all the commands, only thing is I have lost all my bookmarks, is there any way to get them back?

:slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile:

I could be wrong about this, but I think if you didn’t export your bookmarks etc. (from the firefox bookmark manager) before attempting the original upgrade, there is no easy way to recover your bookmarks…

That said…

There are 2 things you could try -

  1. Try starting Firefox 4 with the old profile:
firefox -profilemanager -no-remote

Now if there is more than one profile available, try starting one of those.

If the bookmarks ARE available in the other profile… you can either export them, then import them into FF4, or just make that profile the default profile.


  1. Open the ~/.mozilla/firefox directory:
sudo thunar ~/.mozilla/firefox

Now see if there are any directories there with a name similar to:

If there is, see if that directory contains a directory called:

If there is, see if it contains any backups (files that end with .json)

If so, you could try importing the one with the latest date into the Firefox 4 bookmark manager. (be careful, this will erase any new bookmarks you’ve put into Firefox 4)