Firefox 6 on Acer Aspire One very slow or crashing

I have an Acer Aspire One, running Linpus Lite. My Firefox upgraded itself to v6, worked once and then refused to open again.

I found your instructions on installing Firefox 6 , followed them and then disabled automatic upgrades. It seemed to work, but after being started up a couple of times it became very slow (10 minutes to scroll down?) and sometimes stopped working altogether. It also failed to close down correctly and left my netbook unusable for a bit till I had used the power button a few times to power it down.

Several times Firefox had given me an error message about an Unresponsive Script. The latest one said “resource://gre/modules/XPCOMUtils.jsm:282”. It did work better for about 5 minutes after I told it to kill the script but then it slowed right down again.

I have been able to power up my netbook and get a terminal window so I thought I would go back to Firefox version 4, hoping it would overwrite anything terrible the later version has done to my system. It had worked OK when I installed it in May following Macles’ instructions, but the library file now seems to be unavailable at the web address he gave and has obviously been overwritten by the upgrades on my netbook.

Help! Any suggestions please?

The only suggestion that comes to mind is “give up” but I doubt that it will be welcome!

There were a number of versions of the Acer Aspire One, but the range was discontinued in 2013. Linpus is also obsolete — the last version came out in 2014. As for Firefox, the current version is 80!

If you have to keep using this thing, the only realistic solution is to install another distro. AntiX is the lightest you can find and should work, even if you have the original model with the Atom N270. It won’t be fast, but it will be less like a wounded snail.