Firefox crashing after update. [Solved]

I have Mint 17.3 Rosa 64bit and did a recommended update on Firefox yesterday, since then Firefox keeps crashing with the following idiotic message: ‘Gah. your tab has just crashed’. It then invites me to report this to them etc. Can you advise me how to fix this - preferably reverse the update so that Firefox can work properly again?

Well you can revert back to FF57 but from what Mozilla say here:

So if you want to go back to FF57 you’re going to have to delete/rename your Firefox profile, loosing all your bookmarks, etc. unless you have them synced … are you okay with that ?

If so, it might be a good idea to just rename the profile but stick with FF58 first, just to check if it was something in your profile that’s messing things up.

Let me know what you want to do, and we’ll go from there.

also post the output from:

uname -a

Hmm…Thanks Brian, I suppose I’ll stay with the new ‘improved’ version!

If you can help sort it out I would be very grateful. Here is the output you requested:
uname -a
Linux graham-HP-ProBook-455-G2 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Thanks again.

Okay try this…

WITH ALL INSTANCES OF FIREFOX CLOSED, run:

mv -v ~/.mozilla ~/.mozilla-old

Now sttart Firefox and see how it behaves … and let us know.

It seems a bit more stable but unfortunately it is still occasionally crashing.

Maybe you’d like to try the FF59 beta ?

If so, what’s the output from:

dpkg -l | grep firefox

Mark, it seems to have settled a bit, I’ll see how things go over the next couple of days or so and then conclude this one way or another.

Okay let me know, and we’ll go from there.

No, it’s still playing up, crashing and randomly refusing to play some videos so I will have a go at FF59 as you suggest, please.
Here is the output you requested:
graham@graham-HP-ProBook-455-G2 ~ $ dpkg -l | grep firefox
ii firefox 58.0.1+linuxmint1+rosa amd64 Safe and easy web browser from Mozilla
ii firefox-locale-en 58.0.1+linuxmint1+rosa amd64 English language pack for Firefox
graham@graham-HP-ProBook-455-G2 ~ $
Many thanks.

To change to Firefox version 59.0~b7 run these commands in sequence:

mkdir ~/Desktop/FF59beta-installation-files

then

cd ~/Desktop/FF59beta-installation-files

then

wget https://launchpad.net/~mozillateam/+archive/ubuntu/firefox-next/+files/firefox_59.0~b7+build1-0ubuntu0.16.04.1_amd64.deb

then

wget https://launchpad.net/~mozillateam/+archive/ubuntu/firefox-next/+files/firefox-locale-en_59.0~b7+build1-0ubuntu0.16.04.1_amd64.deb

then

sudo apt-get install ./firefox_59.0~b7+build1-0ubuntu0.16.04.1_amd64.deb ./firefox-locale-en_59.0~b7+build1-0ubuntu0.16.04.1_amd64.deb

then close ALL running instances of Firefox … then repoen one.


TO UNDO (ie. return to the default 58.0.1 version of Firefox):

sudo apt-get install firefox=58.0.1+linuxmint1+rosa firefox-locale-en=58.0.1+linuxmint1+rosa

Thanks Mark, I shall have a go at that.

Done that, unfortunately no change. However, a folder entitled FF59 Beta-Installation-Files has appeared on the desktop, inside are 2 folders:

/home/graham/Desktop/FF59beta-installation-files/firefox_59.0~b7+build1-0ubuntu0.16.04.1_amd64.deb
AND:
/home/graham/Desktop/FF59beta-installation-files/firefox-locale-en_59.0~b7+build1-0ubuntu0.16.04.1_amd64.deb

When I try to install the 1st one I get a long error message in red 'Breaks existing package Hunspell-en-us that conflict Iceweasel…goes on to say that the installation files provides it via gnome-www-browser,iceweasel, www-browser. Nothing more is then clickable.

On attempting to open 2nd folder I am warned about dangers of downloading from unknown sources.

What’s the output from:

dpkg -l | grep firefox

now ?

I’ve re-installed and it seems better now, however, here is the output you requested:
dpkg -l | grep firefox
ii firefox 58.0.1+linuxmint1+rosa amd64 Safe and easy web browser from Mozilla
ii firefox-locale-en 59.0~b7+build1-0ubuntu0.16.04.1 amd64 English language pack for Firefox

You still have firefox 58 installed.

As long as you didn’t delete that desktop folder, run:

sudo apt-get install /home/$USER/Desktop/FF59beta-installation-files/firefox_59.0~b7+build1-0ubuntu0.16.04.1_amd64.deb

or if that doesn’t work

cd ~/Desktop/FF59beta-installation-files

then

dpkg -i firefox_59.0~b7+build1-0ubuntu0.16.04.1_amd64.deb

then close ALL running instances of Firefox and reopen

I was also facing the same issue about crashing after update. Then finally I uninstalled it, download it and reinstall again now I’m using the latest version of Firefox without any issue.

None of the actions have worked unfortunately.

Maybe you should try Waterfox … that’s based on the pre-quantum Firefox

To installl

echo 'deb https://dl.bintray.com/hawkeye116477/waterfox-deb release main' | sudo tee /etc/apt/sources.list.d/waterfox.list

then

curl https://bintray.com/user/downloadSubjectPublicKey?username=hawkeye116477 | sudo apt-key add -

then

sudo apt-get update

then

sudo apt-get install waterfox

@Thomas_Raymond: Thanks, I have installed Chrome and tried Opera as FF updates did’t cure the problem.

Seen some interesting +ve reviews of Waterfox, Mark so I shall give it a go.

Have used Waterfox for a fortnight now - very good, just like having my original FF back, thanks again Mark.

NP :slight_smile: