Firefox glitch?

Firefox keeps running slow today- anyone else had the same problem? My internet is fine- usual speed.

Firefox is fine for me.

Have you tried clearing your browser cache etc. ?

If your internet seems fine, what makes you say Firefox is slow … do you mean slow to start ?

It keeps stalling and pages won’t load up and I have to keep rebooting. I thought the cache clears itself?

Not unless you’ve told it to

go to

Edit > Preferences > Privacy (tab)

and click the blue writing “clear your recent history”

Then select “Time range to clear: Everything”

make sure “Cache” is ticked

and click “Clear Now”

OK will do thanks.

Hmm…this is what I have when I go to privacy:

Go to Settings (to the right of Clear History) and see if cache ticked.

It keeps stalling and pages won't load up and I have to keep rebooting.

Are the pages building up slowly (like line by line) or taking long to get to the point when they start building?

No just endlessly buffering or not loading at all. I have rebooted and closed and opened the browser like 50 times tonight and even switched the router box off and on again. It will work normally for a few mins then stop. Then I reboot and on and on it goes like that.

Cache was already ticked. The laptop is working fine otherwise- it is just Firefox.

That sounds like it is a DNS resolver issue. I assume you are using your ISP’s dns servers.
Try changing them (in your router) to something like

OpenDNS IP Addresses

208.67.222.222
208.67.220.220

or

Google Public DNS IP addresses (IPv4):

8.8.8.8
8.8.4.4

Alternatively you could edit /etc/resolv.conf on your local machine:

sudo gedit /etc/resolv.conf

then add:
nameserver 8.8.8.8
nameserver 8.8.4.4

or
nameserver 208.67.222.222
nameserver 208.67.220.220

save and close

Restart any Internet clients you are using

Ok I put that in the terminal and some window opened called gedit- I put the nos in there. I presume that is what you meant? I have no idea what all this means lol.

Your dns server is a bit like a phone book - it’s where your computer looks for the addresses of the sites you wish to visit. Using the dns server from your ISP might cause issues if it becomes ‘overloaded’ or isn’t maintained efficiently. OpenDns or Google, as per SeZo’s post, are non-specific to any ISP and are massive so should work flawlessly pretty much all of the time. Changing addresses in the router may work - depending on the router. I had problems changing mine in a Virgin (not so) Superhub because the Hub is locked to Virgin’s own server. If you wish to change to another server, do this - (and yours may differ slightly, depending on which o/s you are using)

Click on your network icon and then on ‘Network Connections’ then highlight the connection that appears in the box (click on it once). Click on ‘Edit’. Click on the tab ‘IPv6 Settings’ then in ‘Method’ select ‘Ignore’. Click on the ‘Ipv4’ tab and in ‘Method’ choose ‘Automatic (DHCP) Addresses only’. In the box below called ‘DNS Servers’ type in the numbers SeZo gave you (either Open Dns or Google, but not both - you only need one or t’other) but put both numbers on one line with a comma to separate them - like this - 8.8.8.8,8.8.8.4. Hit ‘Save’ and exit all boxes. Then reboot.

To check if the settings have been retained, go through the first few steps again and look in the ‘IPv4’ box to see if the new numbers are there.

This worked fine for me (I use OpenDns btw) and I haven’t had any browsing issues since… :wink:

Hope this helps

Rich

Afterthought - If you like Firefox then Palemoon might be an alternative? It’s like a lite version of Ff and will allow all of the usual add-ons, if you want them.

Thanks guys- Firefox is fine today.