Flash issue

I keep getting told when I try to listen to this online radio st that I need to update my adobe flash. I only updated it in software manager a few days ago and it is doing it again. You Tube and Iplayers are running, so it cannot be my flash can it? What do you guys think?

Which distro/version/architecture ?

which browser ?

which version of flash ?

Peppermint 3, Firefox…I downloaded the latest Flash there which is 11.What happens is the radio plays for about a few seconds then goes off saying to update the Flash,

In Firefox (in the address bar) enter about:plugins then check the resulting page for the currently used flash plugin
You should see something like this:

[i]Shockwave Flash

File: libflashplayer.so
Path: /opt/solydxk-flashplugin/libflashplayer.so
Version: 11.2.202.336
State: Enabled[/i]

By the way that link plays OK with my version of flash.

Shockwave Flash

File: libflashplayer.so
Path: /usr/lib/adobe-flashplugin/libflashplayer.so
Version: 11,2,202,336
State: Enabled
Shockwave Flash 11.2 r202

MIME Type Description Suffixes
application/x-shockwave-flash Shockwave Flash swf
application/futuresplash FutureSplash Player spl

It says enabled. What version of Flash have you got?

It says enabled. What version of Flash have you got?

Same as yours (as posted above):
Version: 11.2.202.336

Odd, because it plays for me, and I’m on the same flashplayer version :o

Probably the best thing to do (at least for now) would be to install Google Chrome and see if flash works in that (as it has its own built-in flashplayer)

Download the .deb version for your architecture (32bit or 64bit) from here:

then double-click to install

You’ll then find Chrome in the menu’s at

menu > Internet > Google Chrome

Does flash work in that ?

if not, can you post the output from:

cat /proc/cpuinfo | grep -i sse2

I have all my favourites on Firefox- I’d lose all that if I used Chrome wouldn’t I?

melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $ cat /proc/cpuinfo | grep -i sse2
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow up extd_apicid pni cx16 lahf_lm extapic cr8_legacy
melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $

No … installing Chrome should not affect the firefox settings at all

In Internet I had something called Chromium which is another browser- it goes to a Peppermint home page. Was that what you meant? The radio is working for now, but it could stop any time as this is what it’s being doing.

melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $ cat /proc/cpuinfo | grep -i sse2
flags : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow up extd_apicid pni cx16 lahf_lm extapic cr8_legacy
melissa@melissa-HP-Compaq-nx6325-RH628ES-ABU ~ $

No it goes off and asked for a new flash again on Chromium also. Could there be some plug in stopping it?

No I didn’t mean Chromium … that’s a version of Chrome but it doesn’t have the pepperflash.

That said, if the flashplayer SOMETIMES works, don’t bother installing Chrome … it’s not a flashplayer issue … most likely due to your lack of RAM

But why would you tube etc work if RAM problem? Could there be some Firefox plug in stopping it working?

The link you provided has a LOT of flash content … in fact it plays on my netbook, but unless I’m running adblock I cannot close the tab once it starts playing

it’s probably overwhelming your RAM, then starting to use the swap partition … swap is nowhere near as fast as RAM.


Easy enough to test your theory … disable the firefox plugins (except flash) and test.

If you’re using the Firefox “flashblock” extension … that will most definitely stop it loading

The link you provided has a LOT of flash content .. in fact it plays on my netbook, but unless I'm running adblock I cannot close the tab once it starts playing

it’s probably overwhelming your RAM, then starting to use the swap partition … swap is nowhere near as fast as RAM.

Bingo! I have adblock!!! I am surprised it uses more flash than iplayer tho.

Easy enough to test your theory .. disable the firefox plugins (except flash) and test.

If you’re using the Firefox “flashblock” extension … that will most definitely stop it loading

Where is flashblock extension?

If you’ve installed it it will be in Firefox > Tools > Add-Ons > Extensions > Flashblock

Will look soon thanks Mark.

I don’t see anything called Flashblock only ad blocks.