Hi All

I’m having a dabble with the above - has anyone on here any experience of it?

I’ve got it installed ok and I’m trying to add a few more aircraft. The aircraft files are in my Downloads folder but when I try to move or copy them to the specific Flightgear folder, I get a pop-up saying ‘permission denied’.

I’ve also tried following the instructions from the Fightgear WIKI -

(Ubuntu 12.04)
Download the aircraft
Open Terminal and log in as root

sudo -i

Navigate to /usr/share/games/flightgear/Aircraft

cd /usr/share/games/flightgear/Aircraft

Extract your aircraft file into the folder

unzip XXXXX.zip

this is where I hit a brick wall!

I suspect I’m using incorrect commands in terminal or perhaps I need to change permissions of the aircraft files? I’ve no experience of doing this so any pointers would be welcome!



It looks like the Flightgear folder needs root permissions to write to it so If you navigate to the Flightgear folder have you tried right clicking on the folder then select “Open as Root” then try to paste the files inside, then assuming these are compressed files you can right click and select “Extract here”

The above assumes you’re running Peppermint

Good luck


Hi Graeme! Thanks for that - spot on! Aircraft in and more to come! Isn’t life grand when you know what you’re doing? ;D


(Using Mint 17 btw, but the instructions worked exactly the same. Just got to learn how to fly 'em now… ::))

Just got to learn how to fly 'em now

Can’t help you there the last planes I played around were made by Airfix

Anyway glad you got it working :slight_smile:


Hi Rich J,
Can I ask what joystick you are using ?

Don W

Saitek Cyborg Evo - I’d borrowed one of the same a couple of years ago (when still on XP) and it worked reasonably well with FG (unfortunately XP didn’t!). Having switched to Linux, I thought I’d give FG a go again and found the same joystick model in a charity shop - £4! Result :smiley:

Are you an FG fan, by any chance? I have a play with it now and again when time (aka ‘the wife’) allows … ::slight_smile:


Hi Rich,
I will have a look for that model. I was looking at Amazon yesterday and found quite a few but then discovered they were for Windros$.
I downloaded Flight Gear yesterday “to ease the stress of trying to get my digital and video pictures to perform as I want”. ;D
I was a long time user of the MS Flight Sim and used the all singing, all dancing Force 5 stick, but after changing to Peppermint I gave that all up.
I had a go at the tutorials yesterday and it was quite refreshing using the keyboard but when it came to taxiing I had to give up as the continual key pushing left me exhausted :wink:
Don W
EDIT I found one on Amazon Saitek Cyborg Evo wireless PC Flight Stick £367.20 (its in the sale) 8)
EDIT Am I right in thinking nearly any joystick will work ?

Hi Don

The Evo works fine for me in Linux Mint 17 - in fact, better than it did in XP but that could have been due to conflicts between FG and XP. I’m only a ‘very’ novice user with FG so I don’t know if any advice I could give would be worth much…

I believe most plug 'n play devices work in Linux (although with at least some degree of configuration - but that’s true of any o/s) and my Evo certainly does so perhaps other models of stick would too?

I found this on ebay - might be worth a punt?


£300 + for a joystick seems a bit excessive to me, especially if you’re not sure if it will work?

Have a google of ‘joysticks for Linux’ and see if there’s any pointers there. :wink:

Good luck and happy flying! :slight_smile:


Hi Rich,
I have had a look at the FG manual and almost any joystick with a USB connection can be programmed.
In fact you are encouraged to programme your joystick and send in the file to their database on the FG forums.
So far I only have the Cessna working as FG starts in a Cessna at San Francisco, I can’t find where to change the default.
I wanted to add some aircraft and I found in the ’ flightgear ’ folder 2 folders with aircraft, the first was >Al > Aircraft that contains 93 airplanes and the other was the second folder >Aircraft that now contains 27 airplanes.
I really am struggling with this as I feel it could be a good programme and I would like to get it working properly.
Can I PM you for info ?
Don W

Do you have ‘Flightgear Launch Control’ installed as well as ‘Flightgear’? The Launch Control wizard will let you change aircraft and airfield and, if you download other aircraft, will place them in the left-hand pane in list form for selection. I think that ‘Flightgear’ on its own will just load the Cessna - and it takes ages to fetch the scenery etc.

You can pm me by all means but as I said, my knowledge is still very thin on this and I’m still very much feeling my way.


Hi Rich,
I have just bought that joystick you mentioned.
I got Flight Gear through the Software Manager. Synaptic shows as having installed 6 packages but none of them are Flight Gear Launch Control ?
It looks as if I have a very basic version but can’t see where to expand it.

Install fgrun:

sudo apt-get install fgrun

then look for FlightGear Launch Control under the Games menu

Thanks Mark,
I couldn’t find that anywhere :-[
I have been on the Flight Gear forum all afternoon and still can’t see a mention.
I didn’t want to jump in and ask, so I have a look through the forums first usually, I am glad I came back here :wink:
That has done the trick, I can have a play with that now :wink:

That joystick has arrived but there are no manual and no drivers disc. >:(
I will have to contact the seller as I can’t zero the controls. :frowning:
It is easier with a joystick, I just wish I hadn’t got rid of my Force Feedback Pro :cry:
Don W

Hi Don - I’ve just seen (and replied to) your pm. :wink:

Hi Rich,
I have just been to Saitek site and the only drivers are for Windross. >:(
I will try the FG forum to see if I can get help there.
There is a Saitek joystick set up in Flight Gear that I can use but I can’t zero the controls as the setup disc is missing :frowning:

Have you tried installing jstest-gtk

sudo apt-get install jstest-gtk

then nusing that to calibrate the joystick ?

Hi Mark,
That worked perfectly.
I will go and see what damage I can do in FlightGear. :wink:
You must know a terrible lot about this OS when you can produce such answers. karma

it does seem as if his knowledge knows no bounds. Awesome!!!