Freezes using either Debian or Mint with KDE

Summary: PC freezes randomly, using it or not, under Debian & Mint latest’s versions with KDE, 64 bits. It was working perfectly with Windows 8. What could be the problem???

Full analysis:

  1. High CPU temperature causing the issue: Doesn’t make sense. The hardware was running perfectly under heavy load in Windows, so with no CPU load in Linux it shouldn’t freeze.
    This motherboard’s CPU temp sensor is not reliable under Linux, but if I restart as soon as it freezes, the BIOS says the temp is 45 Celsius (113 Fahrenheit). I’ve run this CPU stable at 70 Celsius, so I don’t think it could have dropped more than 20 degrees in the 10 seconds it took me to check out the temp after restarting it.

  2. Safeboot/UEFI/CSM (Compatibility Support Module): Secure boot can’t be disabled in my motherboard. But I’ve configured OS Type to “Other OS”, which is described as “Get the optimized function when booting on Windows non-UEFI mode, Windows Vista/XP or other Microsoft Secure Boot non-compliant OS.”. Also, fastboot is disabled just in case. I’m not really familiar with these technologies, but all the problems regarding them I’ve seen mentioned at different forums talk about not being able to boot using UEFI/ Safe Boot but nothing is mentioned about the system being unstable.
    CSM allows to boot from either UEFI, Legacy OpROM or both. I’ve tested this under Legacy OpROM & both, it freezes anyway.
    My motherboard is an Asus Asus M5A99X EVO R2.0 - BIOS revision 1708. It’s reported as working perfectly under a whole different range of Linux distros & versions. It’s even said to be working fine at Linux Mint’s hardware compatibility site:

  3. Faulty RAM, PSU or SSD: I’m using a Crucial M4. I haven’t swapped the RAM, PSU or SSD drive, since I assumed that if they work with Windows, they are working properly. Should I? Did anyone encounter a similar case that was solved by swapping either of these components?

  4. IOMMU: I’ve seen a post reporting that could cause stability issues, 890FXA-GD70 IOMMU Causes Freezing / Kernel & Hardware / Arch Linux Forums. I don’t know if it’s enabled or not, I’m not at the PC now, but I’ll check it out later.

  5. KDE: I don’t know if the particular version of KDE with my particular hardware / BIOS settings could have anything to do, but I’m going to try Mint with Mate to see if it changes anything.

  6. AHCI mode: it’s enabled, does it makes sense to disable it?

BTW, after this, I’m posting /var/log/messages near the time of the lock-up. I don’t see ANY mention to any issues or the freeze itself… but let me know!
If you want to check the whole log from the time Linux booted & the freeze, please see this link:

Thanks again!!!

Oct 9 22:26:15 Pamela kernel: [ 6.471601] r8169 0000:02:00.0: eth0: unable to load firmware patch rtl_nic/rtl8168f-1.fw (-2)
Oct 9 22:26:15 Pamela kernel: [ 6.481385] r8169 0000:02:00.0: eth0: link down
Oct 9 22:26:15 Pamela kernel: [ 6.481400] r8169 0000:02:00.0: eth0: link down
Oct 9 22:26:15 Pamela kernel: [ 6.484976] ADDRCONF(NETDEV_UP): eth0: link is not ready
Oct 9 22:26:15 Pamela kernel: [ 6.595675] lp: driver loaded but no devices found
Oct 9 22:26:15 Pamela kernel: [ 6.602739] ppdev: user-space parallel port driver
Oct 9 22:26:17 Pamela kernel: [ 8.070241] r8169 0000:02:00.0: eth0: link up
Oct 9 22:26:17 Pamela kernel: [ 8.868573] ADDRCONF(NETDEV_UP): wlan0: link is not ready
Oct 9 22:26:17 Pamela kernel: [ 8.875061] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Oct 9 22:26:17 Pamela kernel: [ 8.889553] ADDRCONF(NETDEV_UP): wlan1: link is not ready
Oct 9 22:27:37 Pamela org.kde.powerdevil.backlighthelper: QDBusConnection: system D-Bus connection created before QCoreApplication. Application may misbehave.
Oct 9 22:28:12 Pamela kernel: [ 123.721254] warning: `VirtualBox’ uses 32-bit capabilities (legacy support in use)
Oct 9 22:49:11 Pamela kernel: [ 1382.569862] fuse init (API version 7.17)
Oct 9 22:49:39 Pamela kernel: [ 1410.849393] device-mapper: uevent: version 1.0.3
Oct 9 22:49:39 Pamela kernel: [ 1410.849566] device-mapper: ioctl: 4.22.0-ioctl (2011-10-19) initialised:

I think you’re probably right about the CPU temp, but be aware that CPU temp could drop by 20C in a second, let alone 10. Plus, just because it’s stable under Windows doesn’t mean stable under Linux, as they use different CPU schedulers and governors.

I’d be interested to know if disabling IOMMU in the BIOS fixes things … I’ve seen this cause all sorts of weird problems, from total lockups, to odd stuff like the mouse not working.

Disabling AHCI shouldn’t be necessary.

Have you gone through the logs for clues ?