Frequent crashing of 18.04 <resolved>

Just had my 5th crash in 2 hrs. Mouse cursor freezes nothing works - cont/alt/del does nothing neither does esc. I switch off with the power button & reboot.

18.04 has been a bit crashy since I installed it but it has been getting better, usually goes once after an update then is fine. Was behaving a little oddly the last couple of days, eg. FB spell check doing odd things so I updated yesterday. Didn’t cure anything but this evening it’s been crashing roughly every 20-30min no matter what it is I’m doing (on internet).

Anyone any suggestions as to how I proceed ? things I can check ? I’ll be off to bed shortly so not in a rush. Perhaps it’ll improve next time I use it.


If the crashing is random then it could be a difficult one to nail down, the problem sounds like it could be hardware rather than a software issue.

It might be worth trying running a live disc for a while to see if the problem persists, if it does then it could be overheating or maybe a faulty memory stick or some other physical issue.

Do you have a live disc you can try ?

Thanks Emegra.
I have the USB flashdrive I used to install which I think I can run as an OS. Is that what you mean.
This laptop is a refurb from ebay so you could be right. Don’t think it’s overheating. Is there any checks I could run to find faulty hardware?
So far so good today after the last crash yesterday evening. It rebooted much faster & settled down more quickly that time, felt different.

I have the USB flashdrive I used to install which I think I can run as an OS. Is that what you mean.

Yeah that’s what I mean, if it continues to crash running the live USB then it’s most likely a hardware issue, like many things it’s a process of elimination, figuring out if the problem is hardware or software would be a good place to start.

Try to figure out if the crash occurs under any particular conditions or while running any particular software or process, if you can nail it down to a single application try running that application from the terminal the read the terminal output for clues.

At this point it’s kinda difficult to offer anything more constructive

Good luck



Have you performed a RAM test?
MEMTEST is available during boot up, or free from

Graeme - I’ll give that a go tomorrow. I was just about to say it’s been well behaved today - then , crash. Haha. Doesn’t seem to make much dif what I’m doing. Most usually happens when scrolling down a page but I think that’s because I’m on the interweb a lot. It has happened when just reading a PDF not touching a thing. I’ve used dif mouses but that makes no dif.

Brian000 - I’ll try & do one now.

I ran memory check on boot up (as I can’t find a spare USB stick to make a memtest86 one). This said ‘passed’ so anything else to do on that front?

So far it’s only crashed once since my last post so not often enough for running a live USB to show anything but I’m now having weird page display issues on search results on ebay. Not doing that when I navigate via category but consistently for search results. Rebooting hasn’t cured it. This does Not happen if I use the live USB stick, everything works as it used to. So I presume it’s software ?

Would having to make hard shut downs (using the physical power on/off button) corrupt stuff ?

Would upgrading to vs 20.04 possibly cure these problems ? (though 18.04 was pretty crashy from the get go on this laptop.)

Would having to make hard shut downs (using the physical power on/off button) corrupt stuff ?
Oh yes! I've just screwed up Pulse Audio due a hard shut-down. Fortunately it sorted itself out after a couple of reboots, but only because some files are reconstituted automatically if missing.
Would upgrading to vs 20.04 possibly cure these problems ?
If the problem is hardware related, then no, but you lose nothing by trying. Don't do a "software upgrade" (which uses many existing files): use a live DVD and elect to remove the existing operating system.


I’m pretty convinced now it’s software problem.
Upgrade from DVD would also remove all my folders etc & I’d have to replace them from backup media ?
My autistic brain struggles with upgrading from (making a) disc/stick which is why I bought one ready done to get 18.04. so…
upgrading ‘normally’ (eg through terminal) would still be worth a try ? I’ve just been watching a couple of youtube tutorials & it looks straightforward.

edit: just been looking at something called ‘debsums’. Says this would list corrupted files. Anyone know any more ?

I think debsums checks the MD5 sums of installed/installing packages. It would only tell you if the package was corrupted.

You can right click on the file to check the MD5 sum, but that`s only any good if you have a MD5 sum to check it against.

That`s all my knowledge of it.


Thanks. I remember seeing MD5 mentioned in what I was reading. So prob not much use then.

Anyone know if I could run fsck from the live USB to check my HD ? &/or how I’d go about that ?

I remember seeing MD5 mentioned in what I was reading. So prob not much use then.
On the contrary; it might show that the ISO file that you downloaded was corrupt. Worth a try.
Anyone know if I could run fsck from the live USB to check my HD ? &/or how I'd go about that ?
Have a look at for detailed instructions.


Thanks Keith. I doubt I’ll have time today but I’ll check further on those as soon as I can.

Ok, so whereas it’s entirely possible that your installation software is at issue, it’s not generally the cause of issues like this. The two most likely options are;

  • Driver incompatibility
    • Hardware fault (specifically, memory, but possibly disk)
      The former historically being the “most” likely. If you look in “/var/log” following a crash, specifically at files “syslog” and “kern.log”, if you can identify in the log files “when” the crash happened and look at log entries leading up to this point, it may give some indication of what caused the problem. (whether it be memory or a driver) Unless you are doing something particularly exotic, video drivers are often good candidates for mouse / screen freezes.

As Emegra pointed out, the other thing to try is a memory test … when you first power on the machine the BIOS will have the facility to check it’s memory before booting, sometimes this is a keypress, sometimes you first need to enter the BIOS to enable the feature. If you run this before booting (it can take a few minutes) it should prove / eliminate memory as a potential issue.

If it turns out you have a video issue (he says looking in the general direction of NVIDIA ??? ) the first port of call would be to try different drivers. Some drivers have propriety AND open source variants and the relative features / stability vary. In the past I’ve found that some propriety drivers (NVIDIA in particular) have different versions and it can be critical to the stability of your machine you get the right version of the driver for your specific video card. If in doubt, revert to the open source version of the drivers to first establish this is the issue.

As a rule of thumb, if you can install a package, it was probably Ok at source, so if you didn’t get any errors during installation, any software corruption is likely to be a storage issue within your machine. If the drive (HDD or SSD) is > 3 years old, personally I’d just swap it out before going any further, but at the very least it’s worth running a non-destructive disk check on the entire disk just to make sure it reads reliably. Many people will tell you “I’ve never had a hard disk fail!”, but just looking at the shelf behind be, I have ~ 40 units (>30Tb) of failed HDD’s, and half a dozen smaller SSD’s … average lifespan on modern disks (for me) seems to be 3-5 years.

One more thought, how much memory / swap do you have? Some desktop options (I won’t say “Gnome” but …) eat memory and can get upset if you run out. Minimum practical memory is probably 4G + 2G Swap, but I’d recommend “at least” 8G. If you have less than 8Gb, you might want to consider XUbuntu. (I have seen lack of memory cause lockups, despite that not being expected behaviour)

Being autistic + ADHD is no fun - esp dealing with this sort of thing.

In short I should have done fsck more than a week ago but got completely sidetracked. My laptop was working well, just one crash a few days ago otherwise better than in long while, so just not on the radar & lost track of time.
Today I had some page display issues on ebay & I noted the update ! triangle so I updated. After a couple of reboots things back to normal. Then I had a crash this evening. Hard shut down, reboot a couple of times, OK. Then had page loading issues on FB so I powered down normally but it got stuck on the ‘Ubuntu’ screen on reboot & I had no other option but a hard shut down.

Long & short is won’t reboot. I’m currently on a live USB stick & I’ve had problems with that too. Reboot (not USB) aborts to black screen with some data inc:
/dev/sda2 : Inodes that were part of a corrupt orphan linked list found
run fsck manually (without -a or -p options)

I’ve looked at the link Keith posted about fsck. This is mainly about running it from a mounted & ‘working’ system. There are instructions for using fsck from the recovery option in ‘advanced options for ubuntu’ on the grub screen. I’ve manage to boot to GNU Grub screen but when I select any entry that inc’s (recovery mode) it soon goes to black screen with a lot info I don’t understand ending /dev/sda2 : etc as above.
I tried running fsck from that (initriamfs) prompt there but nothing happens.

The info on the fsck link doesn’t have any info on how to fsck my laptop system files from a live USB OS. So I’m stuck, & out energy. :-[
I’ll check back tomorrow. Thanks for everything so far.

run fsck from a Live-CD/Live-USB
Identify partitions

sudo fdisk -l

Make sure they are unmounted:

for n in /dev/sda* ; do umount $n ; done

then run fsck on them (substitute X to suit):

e2fsck /dev/sdaX

Good try but fell at the 1st hurdle.

Is the 1st command ‘-1’ (numeral one). if so I get ; invalid option --‘1’

if not what is it? - problem my keyboard has reverted to some strange US configuration so the shifted keys aren’t as physically shown anymore.

The “l” is a lower-case “L” and is the “long” option that displays lots of info about each file on a separate line.

I am not very familiar with Mint, but you should find in your menus some way of choosing the right keyboard layout.


Thanks. My brain does this sort of crap all day everyday, it’s very wearing.

Results of fdisk l :

/dev/sda1 is EFI system
/dev/sda2 is Linux file system [problem one]

next command 'for n in /dev/sda*'etc returned :

[flashing cursor which stopped flashing]

then e2fsch /dev/sda2 returned :
bash : syntax error near unexpected token ‘e2fsck’ [& back to usual $ prompt]

Did I make any mistakes ?

Do not know if you made any mistakes but here it is again:
Is your partition ext2/3/4?
Make sure none of the disks in question are mounted first.
Try with sudo

sudo e2fsck /dev/sda2