fstab issue

All,

Version 16.04. It’s just a test VM for learning purposes.

I am relatively new to Linux and I’m currently following the instructions here Adding Disks - Level 3 of the Stairway to SQL Server on Linux – SQLServerCentral

My fstab looks as follows:

#/dev/vg_tempdb/lvo10 /var/opt/mssql/data/tempdb xfs defaults,nobarrier 1 2
#/dev/vg_data01/lvo10 /var/opt/mssql/data/data01 xfs defaults,nobarrier 1 2
#/dev/vg_log01/lvo10 /var/opt/mssql/data/log01 xfs defaults,nobarrier 1 2

If I try and boot without the comment symbol then it runs a start-up job for any uncommented lines. The start up job counts up to 1 minute 30 and then the system boots into emergency mode. Journal -xb shows:

ubuntu system [1]: local-fs target: job local-fs.target/start failed with result ‘dependancy’
.
.
ubuntu system [1]: local-fs target: dependency failed for File System Check on /dev/vg_tempdb/lvo10

I would appreciate some advice on how to identify which dependency is missing.

Do you get the same message if you boot with the lines commented … then uncomment them and run:

sudo mount -a

?

Thanks for your help. The output of

sudo mount -a

is

mount: special device /dev/vg_tempdb/lvo10 does not exist

I checked the file system and /dev/vg_tempdb exists. However vg_tempdb does not contain lvo10. It contains …/dm-1

Does that mean I made a mistake when I created the logical drive with mkfs.xfs? Do I need to remove the logical drive (lvremote?) and do that again?

Dunno (I would have thought it more likely that lvcreate went wrong somewhere), what’s the output from

lsblk