Full conversion

Hi Guys

My laptop is currently set as a dual boot, after installing Ubuntu a while back. I only kept windows for my itunes library, thinking it a safer way to sync my ipod… [insert several expletives here]… I now want to completely remove windows and use Banshee. I’ve just tried dragging from the ipod to Banshee library and that seemed to work fine, but there is not enough room on the hard drive for the (windows) itunes library and the (new) Banshee library; I need to delete itunes before I upload from ipod to Banshee, which scares me a bit. So:

Is deleting itunes --and the rest of windows-- and dragging direct from the ipod to Banshee the best/safest option?
What would be the best way to delete the entire windows partition?

Thanks in advance

Neil

Hmm… iPlods and Linux (again) :wink:

Seriously I’d have a backup of the iTunes stuff on a separate drive/PC before experimenting.

Does the stuff you’ve already moved to Banshee actually play… I’ve heard that with iPid version 6 devices it looks like the music library is there, but the library doesn’t actually work (yet… until someone works out the new database format)… so test first, and check you iPud isn’t a v6 device.

Getting rid of Windows should be fairly straight forward… just use GParted to delete the Windows partition(s) and resize/move the Linux one(s)… then if necessary reinstall the GRUB bootloader from a LiveCD/LiveUSB.

If you need instructions on reinstalling GRUB from a LiveCD (if necessary), see here:
http://linuxforums.org.uk/ubuntu/reinstalling-grub-1-99-in-ubuntu-11-04-from-livecd-command-change/msg46911/#msg46911
or
https://help.ubuntu.com/community/Grub2#Copy_LiveCD_Files

WARNING - As with ALL partition table manipulation there is a small (but mentionable) risk of corruption, so make SURE to backup any important data first, and make sure you have a working LiveCD/LiveUSB , just in case you need to reinstall the GRUB bootloader.

Yes… ipus.

I have a large cherished library --the cds would take forever to rip, a lot are from vinyl for which I bought (and then sold) a usb turntable and many more are downloaded.

I meant to say that the stuff I’ve moved to Banshee does play, although I haven’t checked that it’s not playing from the itunes file which I guess is possible…?

I wasted the morning trying to sort out my daughters itouch as well. It was synced with a playlist from my itunes library (it seemed the simplest option at the time), but this soon became unsatisfactory and then unworkable. She now has a netbook (with windross… don’t get me started on that!) and I thought I’d be able to copy the necessary music files from the device to a new library. Wrong! The icrotch doesn’t show as a generic storage device and thus I can’t get access to the music we thought we owned!

I also tried moving the music files she wanted from my machine onto a memory stick and then into her (new) library on her netbook… they showed in the list but wouldn’t play --file path not found. I kind of know what needs to be done, but I think it’ll be easier from Banshee.

Re backing up. The only large storage device I have (apart from the ipoop) is a WD passport, but last time I tried it wouldn’t work with Linux.

Thanks for the links, I’ll have a look at them in a bit.

iPong’s aside… what was the problem with the WD passport ?

was the iTouch the kids version… the iTouch Kids ? … old joke, but still makes me laugh :slight_smile:

[EDIT]

Hmm… I’ve just realised that Googling my name in the future may throw up an interesting return :o

They’ll have to sift through a ton of very helpful advice before they find the odd poor taste joke. :wink:

It’s been a while since I tried the passport, it loaded okay but I couldn’t access the files. It had been used to back-up stuff from windows, so I guessd it was to do with the file extensions… I put it aside to deal with later. ;D

Give us a shout if/when you get round to trying again :wink:

iLove, how you’se are making fun of iPlonkers. I couldn’t help but iLaugh? XD

Ok.

I tried the Passport and it wouldn’t mount and the files are password protected. So I formatted it; sounds a bit drastic, but these are drastic times. :smiley:

I booted winblows and copied the whole itunes folder – Artwork; Music; previous library; and file extensions .xml .itl – onto the passport.

Then I experimented with dragging individual music files into various places and importing also. Some methods work and play fine, some don’t; all were fiddly. Which makes me think there must be a ‘right’ way to do it.

Does anyone have any idea what that right way might be.

Can Windows read/copy the files ?

With the drive plugged in… what’s the output from:

sudo fdisk -l

and

mount

When you plug the drive in, does an icon appear on the (Linux) desktop

Windows could read the files, it was synced with the passport. You plugged it in and it fired up with a UI… but I formatted it, so it won’t now.

$ sudo fdisk -l

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x41ab2316

Device Boot Start End Blocks Id System
/dev/sda1 1 12 96358+ de Dell Utility
/dev/sda2 * 13 9729 78051802+ 7 HPFS/NTFS

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x5b6ac646

Device Boot Start End Blocks Id System
/dev/sdb1 1 19457 156288321 7 HPFS/NTFS

$ mount
/dev/loop0 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sda2 on /host type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/neil/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=neil)
/dev/sdb1 on /media/My Passport type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)

Finally, the drive shows on the desktop

3 things …

  1. Are you saying Windows CANNOT read the drive now ?

  2. What do you mean by:

it was synced with the passport. You plugged it in and it fired up with a UI
do you mean WINDOWS opened a Windows explorer window, or that some special software stepped in ?
  1. If the drive is being mounted by gvfs-fuse, and there’s a desktop icon, what exactly is the problem ?
    What happens if you just copy/paste ?
  1. I’m not sure right now, I’d need to shut down and boot on windows.

  2. Special software stepped in.

  3. gvfs-fuse a-whosie what-now?
    The problem is I want to get the quickest, neatest, method right first time. I don’t have enough room to copy the whole lot into Linux and then delete windows. I’ve tried copy/paste and dragging and, as I say, some methods worked (music played) others didn’t

I wondered if anyone else had experience.

I’m going to try copy as much as I can and then maybe I’ll just bite the bullet and go for it. :slight_smile:

Some music from iTunes may be DRM protected… could this explain the tracks that don’t play ?

or are you saying the same track when copied by a different method, sometimes works and other times doesn’t ?

What happens if you unmount the drive:

sudo umount /media/"My Passport"

Then manually mount the drive:

sudo mkdir /media/Passport

then

sudo mount /dev/sdb1 /media/Passport

An icon should appear on your desktop called “Passport” … can you copy/paste properly from that ?

don’t just unplug the drive whilst mounted in this fashion… unmount it first:

sudo umount /media/Passport
Some music from iTunes may be DRM protected... could this explain the tracks that don't play ?
Yeah. I've written them off as lost. DRM is one of the reasons I want to change.
or are you saying the same track when copied by a different method, sometimes works and other times doesn't ?

Correct. Copying into the music folder on the desktop and then the importing file option in Banshee seems to be the way to go. If not I know they are on the passport and my ipoop…

Going to read those links on partitioning and reinstalling the grub. :slight_smile:

IMPORTANT

Looking back through your mount and fdisk outputs…

Are you running from a WUBI install (did you install Ubuntu INSIDE Windows) ?

As I’m a bit baffled as to why / is mounted as a loop device, and the fact that you don’t appear to have any Linux native partitions.

If so, and your plan is to ditch Windows… stop now… AFAIK you cant delete Windows and keep a WUBI installation.

If it IS a WUBI installation… deleting the Windows partition will ALO delete Ubuntu

WUBI… I think so, yes.

I tried Ubuntu ‘inside windows’ for a while, then… I honestly can’t remember. I had a machine die on me too; I thought that was the one with WUBI.

What do I need?

To keep Windows :wink:

Or to COMPLETELY erase the drive and do a full proper installation from scratch.

WUBI installs Ubuntu into a folder on the Windows partition, do deleting that partition is going to kill Ubuntu too :o

I want rid of windross.

From scratch would be good, but I guess that means I’m going to have to back up a load of document files and photos too. This is probably something I should do anyhow.

Yup … I’m afraid there’s no way round that.

It’ll be good… like de-frosting the freezer. ;D