Fully working, now for fine tuning. (SOLVED)

Yeh, I half expected that … but it aint a problem, the USB udev permissions just need fixing :slight_smile:
Can you send the output from:

ls -a /etc/udev/rules.d

HP printers and AIO’s tend to work out of the box … HP’s are extremely well supported in Linux by the hplip (HP Linux Imaging and Printing) driver which is pre-installed in most distros … it even has a pretty GUI interface :slight_smile:

. 10-vboxdrv.rules 70-persistent-net.rules
… 70-persistent-cd.rules README

Now you’re just showing off ;), or do you have shares in HP?

Tony N

OK, run:

sudo gedit /etc/udev/rules.d/90-libsane.rules

When a BLANK file opens, make it read:-

# Kodak 3250
ATTRS{idVendor}=="040a", ATTRS{idProduct}=="4043", ENV{libsane_matched}="yes"

SAVE the file.

Turn the printer OFF, wait 10 seconds, turn it back ON (or reboot the PC).

Now what is returned from:

scanimage -L

if that finds the scanner … test it in XSane.

Hi Mark,

as you no doubt realised, the website was down for a while. No problem, it coincided with my wanting to watch the GP qualifying.

“scanimage -L” still reports, after printer OFF, re-boot and printer ON, “No scanners were identified. etc.”

I’ve double checked the rules file and, still, the only line therein is as you suggested.

# Kodak 3250
ATTRS{idVendor}==“040a”, ATTRS{idProduct}==“4043”, ENV{libsane_matched}=“yes”

Word for word this time, I’ve been using the ‘magic’ mouse clicks to copy and paste.

“sudo scanimage -L” still reports “device `kodakaio:libusb:001:007’ is a Kodak KODAK ESP 3200 Series AiO flatbed scanner”.

Linux obviously doesn’t want any old passer-by using the scanner, but how would I use it?

Tony N

Ooops … they’ve moved it.

OK, run:

sudo rm -v /etc/udev/rules.d/90-libsane.rules

(be careful to get that right … probably best to copy/paste)

sudo gedit /lib/udev/rules.d/40-libsane.rules

A file should open with a LOAD of entries …

add these 2 lines

# Kodak 3250
ATTRS{idVendor}=="040a", ATTRS{idProduct}=="4043", ENV{libsane_matched}="yes"

to the bottom of that fille … SAVE the file … restart the printer (or reboot) … then post the output from:

scanimage -L

Looks more promising: -

“device `kodakaio:libusb:001:006’ is a Kodak KODAK ESP 3200 Series AiO flatbed scanner”.

Now the system knows it’s there, how do I use it from the desktop?

Thanks Mark

Tony N

Fire up XSane :slight_smile: … and let us know if it woks ?

Hi Mark,

thanks for that.

XSane does find the scanner and I can “Acquire preview” O.K. and tweek all the enhancements, but it seems reluctant to save my scanned image: -

" Error during save: Could not create secure file (maybe a link does not exist): /home/tony/scanned images/WinXP_desktop_icons.pnm". Is ‘pnm’ the default extension for scanned images?

This, I guess, could be down to my not being familiar with the Linux directory structure and any limitations that may exist with regard to directory and file names.

Then if I click [Scan] again I get: -

“Failed to start scanner: Error during device I/O”.

If I switch the device off, and then on again, start “xsane .998” (as it shows when searching for device), and then click [Scan] I get the same error message as first quoted “Error during save etc…”.

I created the sub directories /tony and /scanned images using “Files” O.K., but wonder if I am using some characters in the directory or file names that Linux doesn’t like.

Your may guess that I was trying to scan a snapshot of my WinXP desktop as a reminder of what programs I am likely to want in Linux.


Tony N

Try saving it to a directory that exists, but has no spaces in the name.

Linux doesn’t like file/directory names with spaces … unless you surround the path with quotation marks, such as “/home/tony/scanned images” … without the quotation marks it would have read the path as /home/tony/scanned (which doesn’t exist) … then wondered what the heck images was tagged on the end for :wink:

So crfeate a directory in your home directory called scanned_images, or scans, or similar.

or try just saving them to Pictures


Oh … and save them as a PNG or JPG

or try using Simple Scan … though XSane gives you more control

[EDIT 2]

I just noticed this:-

I created the sub directories /tony and /scanned images using "Files" O.K

I have no idea what that means … but you should not have needed to create the “tony” directory … that should be your home directory ???

Just scan the image, then svae them to a directory that already exists in your home folder (your home folder is probably /home/tony … so save them to /home/tony/Pictures or similar)

Doesn’t XSane allow you to browse to where you want to save them ?

BTW, another way to represent your home directory is ~/ so if you’re logged on as “tony”, ~/ would be the same as /home/tony/ … and ~/Pictures would be the same as /home/tony/Pictures

Hi again Mark,

I think I am missing something here, or I’ve screwed up my directory structure.

If I click on the “Files” icon (Access and organise files) I get a window with “Home” at top dead centre. On the left a column listing all my drives as “DEVICES”, beneath that, in bold type “Computer” below which is a list of Directories (? Folders) headed by “Home”, “Desktop”, “Documents” down to “Rubbish bin” at the bottom.

To the right of this is a white window in which are a number of folders with “Desktop” at the top, some of which appear in the list on the left and some which don’t. Above this is the heading “Home” in a dark grey box on a lighter grey background. But…

To the left of this “Home” box is a left pointing triangle. If I click on this I get another “home”, not bold type and lower case “h” which, if I click on it renders a folder “tony” below a folder icon with the house symbol thereon.

This contains 11 folders which are the same as the “Home” folder.

It would appear to me that I have directory something like this: -

                    |                                         |
                tony                                 [b] Home[/b]
                    |                                         |
            11 Folders                       Same 11 Folders

or am reading something wrong.

Sorry to be a pain over this, but I’m sure that the reason xsane can’t save my scanned file is that it can’t find the folder in which I wanted to put it, which is a bit painful now we’ve finally got the system to recognise the scanner :frowning:

I tried “~/scanned_images/WinXP_desktop_icons.jpeg” and “home/tony/scanned_images/WinXP_Desktop.jpg” in the browser window in xsane and get the same result.

Is there a difference, as far as Linux is concerned, between “home” and “Home”.

Thanks for your help Mark, it is much appreciated, and sorry for keeping on keeping on. :-[

Best Regards

Tony N

Can you send the output from these 3 commands:-

ls -a ~/


ls -a /home/tony


ls -a /home

Is there a difference, as far as Linux is concerned, between "home" and "Home".

YES … Linux directory and file names ARE case sensitive … unlike Windows you can have multiple files/directoies called foobar, Foobar, fOObar, fooBAR, etc. in the same directory :slight_smile:

I’m a little baffled why you’re having difficulty with this … doesn’t XSane just scan the image, the ask where you want to save it … but have a browse button (so you can browse to where you want to save it) ?

I can’t ATM run XSane (no scanner attached to this PC) … I’ll check later.

Yes it does, scan, and have a browse facility. I previously entered the path and filename in the box, rather than select it from a directory listing.
I have now done it via the [browse] icon and it has worked O.K.

I can’t help feeling that my mishandling of the directory structure resulted in my telling xsane to put it somewhere that doesn’t exist.

Sorry about that.


Tony N

Your directory structure is fine :slight_smile:

Yup, capitals and spaces in Linux paths can take getting used to … along with getting used to only dealing with your “Home Folder” (~/) … but you’ll soon get the hang of it :slight_smile:

Thanks for help your Mark,

I think it’s perhaps time to close this thread so I’ll mark it “solved”.

No doubt there will be other questions in the future.

Best regards

Tony N

You’re more than welcome :slight_smile:

No doubt there will be other questions in the future.

Make one of them … “Should I replace my Kodak AiO with an HP AiO ?” :wink:

Maybe so, particularly as I read that Kodak have filed for bankruptcy Stateside! :wink:

Tony N

They were dead the second digital photography arrived … they just needed to burn off any cash they had lying around first.