Gave up waiting for root device

Trying to do a USB install onto my new computer,
There is no OS present on the PC
When I run the USB it works perfectly, goes through the entire Install process,
But when it restarts it just says
Gave up waiting for root device,
I have no idea what’s wrong with it
Any ideas?

Wait a short while and then type:
exit
(and hit enter)

If that works, you need to adjust the “rootdelay=” kernel boot parameter.

If it doesn’t work, can you post the whole error message.

Didn’t work,:frowning:
I tried redownloading the os,
And I tried reinstalling it.
The try ubantu button worked perfectly, and the reinstall works well too

It came up with the same message, but typing EXIT worked,
I think,
I don’t know how to change the route delay though?

Which Linux distribution/version are you using ?

Ok, I’ve spotted that you said Ubuntu, but which version ?

The newest one, 10.10 I think
I restarted the PC and it’s done it again,
The message reads
Gave up waiting for root device. Common problems
Boot arbs
Check root delay
Check root
Missing modules
Alert really long file name does not exist
Dropping to a shell!

Dammit. Now it’s working, again,
Seems to start working if you hit enter enough

if waiting a while and typing:
exit
then hitting enter
doesn’t work, I’m going to need the FULL “Alert” message.

if it does work, let me know and I’ll tell you how to add a rootdelay

Waiting and hitting exit worked:)
you think it just needs a longer delay?
I was afraid that I’d got oil in the hard rive case

OK, this will insert a 10 second delay in the boot sequence…

Boot to Ubuntu

Go to Applications>Accessories>Terminal

When the terminal opens, enter:

sudo gedit /etc/default/grub

(hit enter, and your password when asked)

When Gedit opens… look for this line:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”
and change it so it reads:
GRUB_CMDLINE_LINUX_DEFAULT=“rootdelay=10 quiet splash”
save and exit.

now back in the terminal, enter:

sudo update-grub

(hit enter, and your password when asked)

once the terminal is back at an $ prompt… reboot and see if the 10 second delay was long enough.

Remember - Linux commands ARE case sensitive.

15seconds works beautifully!
Thank you!
Dwarf fortress working fantastically
System currently stable at 39 degrees
It’s all good!

I can’t get it to realize that there is a DVD player in the tower but I’m sure I’ll work it out.
:slight_smile:

What do you mean about the DVD player… it doesn’t see the DVD drive at all ?

or, it won’t play DVD’s ?

It doesn’t see the player at all,
Which is odd as it sees the floppy and the SD reader

does it list a *-cdrom section when you enter:

sudo lshw -c disk

in a terminal and hit enter and password ?

no it did not.
so i pulled the top off the tank and found a loose conection to the power supply,
must have come loose when i poured the oil in,
:slight_smile:
loving the OS though,
you are being very helpfull though,
:slight_smile:
most unusual on a net forum

next up, making VENT work

huh, thats wierd.
it opens the DVD main menu, but wont open specific episodes, as it "could not read from resource.

What is VENT ?

Go to chat

[EDIT]
To read encrypted (retail) DVD’s you need to have libdvdcss2 installed…

Open a terminal and enter:

sudo apt-get install libdvdread4
sudo /usr/share/doc/libdvdread4/install-css.sh

hitting enter after each line, and your password when asked.

Rebooting may be necessary before DVD’s can be played.